[Stable Update] 2023-12-10 - Kernels, Plasma, Phosh, Systemd, Cinnamon, Gnome, libpamac

Same problem here. Happens both with 6.1.66-1 and 6.6.5-1 kernels. Have to force power off the machine to get it to stop. What appears to be hanging the system is two stop jobs, one for Network Manager and the other for WPA supplicant. On both processes, when the timer runs to the 1 min 31 sec limit, the timer resets for 3 min 1 sec. and resets again when this limit is reached.

Have 5.15.142-1, 6.1.66-1 and 6.6.5-1 LTS kernels installed. Before this update machine ran without the shutdown problem on 6.1 LTS kernel . After the update I installed the LTS, 6.6.5-1. both the 6.1 and 6.6 LTS kernels have this shutdown fault. I will use the 5.15 LTS kernel until this is resolved.


Also got this with Linux 6.6.5-1. Moved to Linux 6.7.0rc4-6 Experimental and problem solved.

1 Like

I resolved that conflict with :

sudo pacman -Rdd dotnet-runtime
sudo pacman -Syu
sudo pacman -S dotnet-runtime-7.0

Technically, you’re right. However the “stable” version is buggy and didn’t work well for me. He’s using my PKGBUILD which…

1 Like

Got 2 problems:

  1. bluetooth is not working anymore. Tried both 6.1, 6.3, and 6.6 series kernels. My laptop is using “rtw_8852be” module for bluetooth and wifi driver.

  2. restarting computer needs manually touch the power button

Kernel 6.6.5-1: if I switch on wifi (RTL8192EE PCIe Wireless Network Adapter) in NetworkManager and then switch off, the computer becomes unresponsive. No network (neither wireless nor wired), mouse moves but buttons do nothing. With prior kernel (6.6.3) had no problems. I have to use REISUB to restart, if I repeat wifi on/off again, the computer also freezes. Then switched to kernel 5.15.142 and everything works fine again so it must be something 6.6 kernel related, I will stay on 5.15 and wait for next 6.6 update.


I can conform the problem on my machine too. Shutdown/Restart/Suspend does not work anymore expect on the latest 6.7.0rc kernel.

1 Like

We’re going a bit off-topic here, by the way. :wink:

+1 - I got this too.

1 Like

thank you, that do the trick.

A post was split to a new topic: After 2023-12-01 I can not get in to a timed out session

A post was merged into an existing topic: WiFi problems after 2032.12.10 Stable Update

I’ve solved mine with this one too. Thank you:)

How did you switch the kernel… I’m not able to boot into the desktop.

1 Like

Here are the changes of 6.6.4 and 6.6.5. 6.6.5 introduced those patches:

check if 6.7 series works.

Upcoming 6.6.6 may have those additional patches:

-rw-r–r– r8152-add-rtl8152_inaccessible-checks-to-more-loops.patch 2545 logstatsplain
-rw-r–r– r8152-add-rtl8152_inaccessible-to-r8153_aldps_en.patch 1414 logstatsplain
-rw-r–r– r8152-add-rtl8152_inaccessible-to-r8153_pre_firmware.patch 1397 logstatsplain
-rw-r–r– r8152-add-rtl8152_inaccessible-to-r8156b_wait_loadin.patch 1378 logstatsplain
-rw-r–r– r8152-hold-the-rtnl_lock-for-all-of-reset.patch 3467 logstatsplain
-rw-r–r– r8169-fix-rtl8125b-pause-frames-blasting-when-suspended.patch 2889 logstatsplain

All kernels of 6.6 series can also been found on our github project: Releases · manjaro-kernels/linux66 · GitHub


I also got this error…

error: tensorflow-opt-cuda: signature from "Sven-Hendrik Haase <sh@lutzhaase.com>" is invalid
:: File /var/cache/pacman/pkg/tensorflow-opt-cuda-2.15.0-4-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] ^C
Interrupt signal received

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Are the shutdown problems with the LTS kernels >515 also on suspend/hibernate/resume actions?

postgresql seems to have been updated - the database needs upgrading…
I just deleted mine and recreated it.

I’m testing 6.7.0rc4-6 now and everything seems to work fine, wifi can be switched on-off over and over without freezes. :+1: