[Stable Update] 2023-12-01 - Kernels, NVIDIA, Thunderbird, Deepin, PipeWire 1.0, QEMU

I had the same problem with my dualshock 4 controller, apparently bluez 5.69 was broken a few months back… … not even the update to 5.70 fixed the problem for me even tho some people said it fixed it for them… my solution that worked for me was I downgraded bluez, bluez-libs, bluez-utils to 5.68 using the downgrade command thru the terminal. hope this helps


Of course not. If it had been that easy NVIDIA owners wouldn’t have suffered from flickering for half a year.

But an option to downgrade drivers is not provided for Manjaro users. linux66-nvidia now includes 545 branch, 535 is not in the official repositories anymore.


I don’t recommend it. You should restore system from backup. If you have older packages in your pacman cache, you may try to downgrade it, but it involved downgrading all kernels, all kernel modules, all graphical drivers, which may go wrong very, very wrong, assuming that system will let you do it (which I doubt it, you will get some errors and process won’t go further).


Thanks for your reply - yep, your explanation and suggestion looks spot-on.

I hope the maintainers include a proper xfce-portals.conf file. In that case it would be better to not have the local xfce-portals.conf file under ~/.config…, but one under /usr/share/xdg-desktop-portal/xfce-portals.conf, together with possibly other DESKTOP-portals.conf files.

A local ~/.config… file would override the config provided by the maintainers.

Create a Topic (or check if someone else openend one and upvote it for moderator attention) on the nvidia forum, report the issue and also get maybe help from others who maybe know a workaround for your issue.

Did you try the sleepmode, workaround?

I remember the flickering was also more visible while using steam, maybe it has to do something with Powerstates, but when you switched to max performance already and try’d the sleepmode im pretty lost.

I also would recommend to keep the last working stable update before december but maybe also update again and create another snapshot and when the next stable update comes out, you won’t run into issue when you rollback then before you update again.

Keep in mind about the files that are overwritten from your restore… i feel the pain for you but atleast you can evade this bug for some time, so get sure nvidia will pay attention.

I heared there was a legacy driver (it was mainly for nvidia 7xx Gen after they run out of support), that should work… but i never archived any experience with rolling back, to this legacy driver.

You better collect more infos in Manjaro Forum about this legacy driver and if its support your GPU.

Even if that works, im still unsure if this legacy driver actually works with the newest Gen… i wouldn’t count on it… because this driver only gets updated for security issues.

A rollback to 535 is not possible, there are to many incompatibilitys.

Edit: Additional i would also try change Hz if you own a high refreshrate Monitor or disable compositor under system settings>display monitor but thats only my last straw.

1 Like

Yeah, that’s true. My fix is based on what’s already on XFCE’s gitlab tho (see the links in EDIT4) so worst case: it would overwrite with exactly the same settings :wink:

no it won’t. we ship pre-compiled drivers which only match one certain kernel version. So if we update also the kernel that module won’t load. You can get the utils from here: Files · e1ac0a3c4c955a7d032230ced15aedf205a1bbd4 · Packages / Extra / nvidia-utils · GitLab and for lib32 here: Files · 714f1413be1a12b42d7b8f33debc13baa6acec63 · Packages / Multilib / lib32-nvidia-utils · GitLab. You have to compile it with makepkg, put them to the ignore list and use the nvidia-dkms package to compile the module for your kernel.


Same problem here. I downgraded nvidia drivers to 470x as a workaround.

1 Like

No KDE or other new issues (old: Plasma System Monitor core dumps on laptop, Powerdevil/Ddcutil on desktop) here. For the latter, manjaro-downgrade showed no dependency issue while downgrading the 2 packages.
Nvidia 545 seems to work fine here.

Wait, Dolphin can’t open folders with “?” in their name anymore (or could it ever?), but can create/trash/delete them.

I had (I hope) an interesting issue; I closed thorium-browser-bin after having it open for a few hours, and the system hard locked a few seconds later. This happened twice. I was running kernel 6.6.1 at the time.

I then updated the packages and so far it hasn’t done the same. Won’t try again until later today when I’m ready to power off anyway. There’s nothing in journald. At this point it’s all guesswork, but it could be hardware acceleration related, for example.

PS. Possibly not related, but my friend uses Arch Linux and he claims that USB “just dies” after some amount of uptime. I haven’t been able to confirm, but both of the systems in this post (mine and his) are Intel-based.

A post was split to a new topic: Optimus-manager.startup=nvidia: command not found

After the update I saw the following.

==> ERROR: module not found: ‘nvme2’
==> WARNING: errors were encountered during the build. The image may not be complete.

This also happens after manually running sudo mkinitcpio -P for all my kernels that I have installed (LTS 6.1 and LTS 6.6).

Do I miss something? It still boots fine though… for now ;).

The PGP signatures for the kernel packages, and even all packages, seem to be broken.

From Manjaro Settings, when trying to install the 6.6 kernel:

linux66-6.6.3-1-x86_64 downloading...
 linux66-nvidia-545.29.06-8-x86_64 downloading...
checking keyring...
checking package integrity...
:: File /var/cache/pacman/pkg/linux66-6.6.3-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
:: File /var/cache/pacman/pkg/linux66-nvidia-545.29.06-8-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: linux66: signature from "Manjaro Build Server <build@manjaro.org>" is unknown trust
Errors occurred, no packages were upgraded.
error: linux66-nvidia: signature from "Manjaro Build Server <build@manjaro.org>" is unknown trust
error: failed to commit transaction (invalid or corrupted package (PGP signature))

Trying to (re)install any package also causes errors regarding unknown trust. Trying to refresh or repopulate keys also doesn’t work:

❯ sudo pacman-key --refresh-keys
gpg: error reading key: No public key
gpg: key F296BDE50368C6CE: "T.J. Townsend <blakkheim@archlinux.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
pub   ed25519 2022-08-08 [SC]
uid           [ unknown] T.J. Townsend <blakkheim@archlinux.org>
sub   ed25519 2022-09-04 [SA]
sub   cv25519 2022-08-08 [E]

gpg: key A6234074498E9CEE: "Christian Hesse <eworm@archlinux.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1
pub   rsa2048 2011-08-12 [SC]
uid           [ unknown] Christian Hesse <eworm@archlinux.org>
sub   rsa2048 2011-08-12 [E]
sub   ed25519 2019-08-29 [S]
sub   cv25519 2019-08-29 [E]

gpg: error retrieving 'build@manjaro.org' via WKD: No data
gpg: error reading key: No data
gpg: refreshing 1 key from hkps://keyserver.ubuntu.com
gpg: key 279E7CF5D8D56EC8: "Manjaro Build Server <build@manjaro.org>" not changed
gpg: Total number processed: 1
gpg:              unchanged: 1

❯ sudo pacman-key --populate archlinux manjaro
==> ERROR: There is no secret key available to sign with.
==> Use 'pacman-key --init' to generate a default secret key.

❯ sudo pacman-key --init
==> Generating pacman master key. This may take some time.
gpg: Generating pacman keyring master key...
gpg: revocation certificate stored as '/etc/pacman.d/gnupg/openpgp-revocs.d/FB16E095594E1F57FA036AD9357F6022944466E6.rev'
gpg: Done
==> Updating trust database...
gpg: public key of ultimately trusted key 9C6B0359C4037DD4 not found
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   2  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 2u
==> ERROR: Trust database could not be updated.

I found a solution in completely refreshing the keys, as is described here

1 Like

Bricked my whole setup yesterday evening.

Had to rollback a Timeshift backup, from before the last update. Everything was back in working order after the rollback.

Updating to Kernel 6.6 and latest nvidia driver 545, results in:

  • Cinnamon buggy, crashes, locks up, etc…
  • No BLE, Wifi nor Ethernet
  • Even the reboot command in CLI mode using ctrl+alt+f2 get’s stuck.

Additional info and issues:

  • I updated my system to kernel 6.6 about two weeks ago. This resulted in my monitors not always turning on, when I woke my system from sleep. So I rolled back to kernel 6.1 about one week later.
  • Yesterday I got a kernel panic during boot, after updating the nvidia drivers without updating the kernel. (Had to use Live usb to recover with Timeshift).
  • Updating appstream 0.16.4-1 to 1.0.0-5, locks up pamac (graphical pacman alternative).
  • Updating libadwaita 1:1.4.0-1 to 1:1.4.0-2, results in the same issue as the appstream update.

Hope the info helps debugging the problem. Thought it could be my old GTX980, not playing well with the new drivers. But the last update causes no issues on my old Asus zenbook with an GT310M inside… My main system has a R9 5900X and GTX980 GPU + 64GB DDR4 and 3 nvme drives…

1 Like

Hello everybody. I encountered a Problem with Kernel 6.6.3-1 and nouveau drivers on:

  Device-1: NVIDIA GT218 [GeForce 210] vendor: Micro-Star MSI N210
    driver: nouveau v: kernel arch: Tesla pcie: speed: 2.5 GT/s lanes: 16 ports:
    active: VGA-1 empty: DVI-I-1,HDMI-A-1 bus-ID: 01:00.0 chip-ID: 10de:0a65
    class-ID: 0300 temp: 54.0 C
  Display: x11 server: X.Org v: 21.1.9 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: nouveau gpu: nouveau
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: VGA-1 model: Samsung S23B550 serial: H4MCB01752 res: 1920x1080
    hz: 60 dpi: 96 size: 510x287mm (20.08x11.3") diag: 585mm (23") modes:
    max: 1920x1080 min: 720x400
  API: EGL v: 1.5 hw: drv: nvidia nouveau platforms: device: 0 egl: 1.4
    drv: nouveau device: 1 drv: swrast gbm: egl: 1.4 drv: nouveau surfaceless:
    egl: 1.4 drv: nouveau x11: egl: 1.4 drv: nouveau inactive: wayland
  API: OpenGL v: 4.5 compat-v: 3.3 vendor: mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: NVA8 device-ID: 10de:0a65
  API: Vulkan Message: No Vulkan data available.
Error: unknown Command 0x0400040.

Screen remains black with Mousearrow and not blinking curser on top left. Rolling back to 6.1.64-1 solves this problem.


  Host: rich-pc Kernel: 6.1.64-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 13.2.1 clocksource: tsc Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11
    wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: P5Q v: Rev 1.xx
    serial: <superuser required> BIOS: American Megatrends v: 2209
    date: 03/11/2010

edited for readability

1 Like

One curiosity which seems related to this update (as I’ve never seen it before). On a couple of occasions my keyboard has become almost completely unresponsive. Logging out of Plasma then back in again fixes it, presumably because that restarts X.
I can still switch to a TTY using . I assume that three finger salute is handled at a lower-level than the X server.

Actually the issue is very strange. I am on lenovo legion slim 5 with amd 7840hs + amd780m and nvidia 4060. When the bios is set to dynamic graphics the system do not see the AMD gpu, and amdgpu kernel module is not loaded and I am able to boot only using nomodeset. When I switch to discrete graphics the system boots without nomodeset and sees Nvidia and AMD gpu but it detects laptop screen as connected to DP-2 and have another None-1-2 display. I am on KDE plasma.

on the other hand if I boot my system with latest kde iso with linux65 on dynamics graphics, the live system detects both GPUs and properly detects the screen as edP-1 and have all resolution options and settings. when I try to boot live system on discrete graphics it does not boot.

This was a brand new installation that was running fine with. 6.1.62 and previous nvidia 535 driver. I am running with vide-hybrid-amd-nvidia-prime.

Now that there is a newer production branch Nvidia driver… do you guys plan on adding that to the stable repo, or are you going to be staying on the new feature branch until the production branch goes to a 545 version?

Both Arch and Manjaro update to the new feature branch (currently 545) unless there’s a newer production branch release (currently 535). There were issues with the initial 545 release, so we packaged 535 temporarily until the 545 bugfix was released.

1 Like