[Stable Update] 2023-11-13 - Kernels, KDE Gear, LibreOffice, LXQt, Pipewire, Phosh, Firefox, Thunderbird

I sort of was hoping the Manjaro team would downgrade these 2 files with this upgrade, looks like they didn’t as the issue persists. I will use the downgrade tool.

After the last update (or possibly the one on November 6, not 100% sure) I have experienced problems with my Wacom Intuos Pros. I have two different computers (an HP laptop/i7 and a Lenovo desktop/Ryzen), both running Manjaro/Gnome/X11 and having identical Wacom Intuos Pro pen tablets. On both systems any use of the Wacom tablets seems to freeze the application I’m trying to interact with (in particular, both Inkscape and Xournal++). These apps work fine when using the mouse or trackpad as input device.
Any ideas on what could have gone wrong?

I Did:

sudo pacman -Sy jdk-openjdk
(said Yes to remove packages in conflict)


sudo pacman -Syu

Update went well on my main machine, gonna do this on another pc.


I get a conflicting error message when I try to update pamac.

Error: unresolvable package conflicts detected
Error: Failed to prepare transaction:
conflicting dependencies:
jdk-openjdk and jre-openjdk are in conflict.
Both are installed by default.
What do need to do?

Please look for the known issues above.

Try Either


1 Like
$ manly pacman -R -dd jre-openjdk-headless

pacman - package manager utility

-R, --remove
Remove package(s) from the system. Groups can also be specified to
be removed, in which case every package in that group will be
removed. Files belonging to the specified package will be deleted,
and the database will be updated. Most configuration files will be
saved with a .pacsave extension unless the --nosave option is used.
See Remove Options below.

-d, --nodeps
Skips dependency version checks. Package names are still checked.
Normally, pacman will always check a package’s dependency fields to
ensure that all dependencies are installed and there are no package
conflicts in the system. Specify this option twice to skip all
dependency checks.

-d, --nodeps
Skips dependency version checks. Package names are still checked.
Normally, pacman will always check a package’s dependency fields to
ensure that all dependencies are installed and there are no package
conflicts in the system. **Specify this option twice to skip all**
**dependency checks.**

-d, --deps
Restrict or filter output to packages installed as dependencies.
This option can be combined with -t for listing real orphans -
packages that were installed as dependencies but are no longer
required by any installed package.

That worked, and thanks for that quick response.
Manjaro absolutely has the BEST community of all distros! :slightly_smiling_face:

Did the same thing on the other machine, the update was done correctly as well, it’s always nice to read the update announcement thread!

Same issue

Experienced the jdk-openjdk issue myself, resolved by running pacman -S jdk-openjdk then pacman -Syu normally. Hope future updates can avoid being as rushed to avoid situations like this, otherwise everything’s running normally after restart so the update itself is good.

It’s a Nvidia issue and cuda-12.3.0-4 includes a workaround, but Manjaro Stable branch has cuda-12.3.0-1. In the meantime you could do just do export NVCC_PREPEND_FLAGS='-ccbin /opt/cuda/bin' yourself.

cuda has been updated from 12.2.2-1 to 12.3.0-4. Unfortunately, cuda 12.2 is not compatible with gcc 13. cuda 12.3 even more so. I can’t compile anything with nvcc at the moment.

/usr/include/bits/floatn-common.h(251): error: invalid combination of type specifiers
  typedef double _Float64;

/usr/include/bits/floatn-common.h(268): error: invalid combination of type specifiers
  typedef double _Float32x;
sudo pacman -U https://europe.archive.pkgbuild.com/packages/c/cuda/cuda-12.2.2-1-x86_64.pkg
.tar.zst https://europe.archive.pkgbuild.com/packages/c/cuda-tools/cuda-tools-12.2.2-1-x86_64.pkg.tar.zst

Since the Nvidia drivers remained on version 535 anyway, I downgraded cuda to version 12.2. Now it works again.

I would only update cuda to 12.3 when nvidia 545 is in the stable branch.

i tried cuda-12.3.0-4 with that workaround, but it do not work. I compile mpv-build-git with ffmpeg/cuda support and the compilation stops with the same error with cuda-12.3.0-4.

See FS#80156 - [cuda] 12.3.0 compilation errors

Which version of Wine? On EndeavourOS it was 8.18 while this problem started cropping on on Manjaro for 8.18 as well, both using Staging.

There is a blog post about a kernel update breaking a tablet pen. Maybe not related, but there is the post and an update at the bottom that may be of interest to you.

There is more discussion on Lemmy in the Linux channel.

I have an ASUS ZenBook UX363, with Manjaro GNOME and everything was fine until (the previous 2023-11-6 and also) this update (sudo pacman -Syu).

I’ve tried numerous times, ditched all extensions before the upgrade, just to be sure, but after this update the system becomes sluggish. Videos I played before, I can not play after. The sound is playing, but the video window does not show (and when showed after a long while, it is dropping nearly all frames). Even just opening terminal window animation is not fluent (was before) and takes a significant more time. It seems, that all HW video acceleration is not working.

I’m using 6.1 kernel, and tried the 6.6, but it didn’t help. Gladly I’m using btrfs+timeshift, so (as after the 2023-11-6 update) I’m back to the last update with GNOME44, on which everything is smooth & fast.

Does anybody has the same experience with graphics speed after upgrade? Any ideas what should I check, poke and fix to be fast after upgrade, as before?


Here I will try to answer my own question:
The command “pacman -R -dd” in Arch Linux is used to remove a package from the system with increased verbosity and debugging information enabled.
–dd`: This option enables debug mode and increases the verbosity level of pacman. Debug mode provides additional information about the removal process, helping to diagnose any issues encountered during package removal.
By executing this command, you would trigger the removal of a package from your Arch Linux system while getting detailed debugging information about the process.

1 Like
pacman -h -R
Verwendung:  pacman {-R --remove} [Optionen] <Paket(e)>
  -d, --nodeps         Überspringt die Versionsüberprüfungen für Abhängigkeiten
                         (-dd überspringt alle Überprüfungen)

Thanks for the pointer! Tried to see if it could solve my problem, but I couldn’t see that they were connected (maybe they are, but the symptoms were very different).