[Stable Update] 2023-10-09 - Mesa, Grub, GlibC, Thunderbird, KDE Frameworks Renaming

You can just hit enter for the KDE packages, you’ll see when you have to stop doing that because the packages are listed in alphabetical order.

One GTK package was also renamed, here you have to confirm the removal of amtk (it’s renamed and reinstalled as libgedit-amtk) by y+ENTER, it is the last of the packages to show up.

I can not confirm any of the KDE issues above, the favorites list in Appl. Launcher is untouched. But then my install is from June this year, and I’m not using Kvantum and stayed with Breeze/Breath.

I have 2 smaller, tiny issues, one already after the last update, one forever, Web Browser widget and 2 apps that don’t save the screen they’re being started on (flatpak Duolingo, portmaster-stub) that I’ll open topics for shortly.

Thank you for this update!

Due to renaming of KDE Frameworks the packages might get removed and installed fresh. during this process some local settings may restored to default ones, if anything was changed …


Ah, that might explain it. :wink:

Hi everyone,

I got the glibc-locales error. I ran the suggested fix:

sudo pacman -Syu glibc-locales --overwrite /usr/lib/locale/\*/\*

But the error persists – I am still geting the message (the end of a long list):

glibc-locales: /usr/lib/locale/zu_ZA.utf8/LC_TIME exists in filesystem
Errors occurred, no packages were upgraded.

What are other options to fix this?

Did you reboot before you tried the update again?
After a reboot, can you try with

sudo pacman -Syyu 


Before the last 2 updates, I had had stuck sddm screens (on Plasma) for up to a minute or so randomly at times after the password input and ENTER.
This seems to have gone with the SDDM or shells pacnew :slight_smile: .

There seems to be an issue with grub/btrfs in the latest update.
I just tried fresh install and after the first update without installing anything else
@ boot i get this error:
error: file “/@/boot/grub/x86_64-efi/bli.mod” was not found.
System boots fine after a few seconds.
I tried install on both encrypted drive and nonencrypted using btrfs. Same issue on both.
After boot running grub-install as root solves the issue.

Thank you for this. It explains why in recent months I’ve had to rebuild my pacman keys so often. I’ve been screwing things up by running pamac via sudo. A lesson learned.


Even after reboot, I am still getting the locales error.

Good point. Luckily I haven’t caused myself problems yet. Thanks.

Why not try it like this @tokr :

sudo pacman -Syu glibc-locales --overwrite /usr/lib/locale/zu_ZA.utf8/LC_TIME

Else you can simply remove that file before updating.

Hmm, that one is weird. Well there are couple of years between the releases of grub. Mostly a grub-install might fix it.

Thank you for the suggestion.

But, for clarity, it’s not just one file, but a long list of files (a few hundred I guess), probably left from the default installation (I don’t remember installing locales manually).

But, I finally figured it out – seems like the issue was my using nushell. In bash, the fix works.

How do i know if I have the “old” version of glibc-locales installed? Mine shows as 2.36-1 Installed 25th Jan 23. Repository Extra.


Check here:


Or to check which one’s installed:

pamac list --installed | grep --ignore-case glibc-locales



1 Like

I’m getting this, when trying to update.
installing kvantum (1.0.10-2) breaks dependency 'kvantum-qt5' required by kvantum-theme-matchama


From the search:



@programista.zacny same thing happened to me. Did you able to solve it? I also can’t login after suspend my laptop. I am using Gnome Desktop.

I accepted whole /etc/shells.pacnew into /etc/shells as effect I removed my zsh entries and cannot log in. It’s known issue but the message is misleading, it’s not about password, it’s about shell.

Just general people using Linux. @programista.zacny Please share me the steps or links. I did used the manjaro-pacnew-checker.sh. Silly me.

What’s known issue? That if you screw up merging files (ie. blindly overwrite them) there might be problems? I agree with that. :smiley:

Anyway, who would have thought that creating some pacnew merger hook will cause these kind of problems… :smiley:

@khandakershahi Boot from iso, mount / and edit /etc/shells - add zsh (or whatever you use) back in. Maybe even switching tty and login as root works. :man_shrugging: