[Stable Update] 2023-08-11 - Kernels, Plasma, Nvidia, Firefox, Thunderbird, Pamac, Pipewire, Mesa

It’s a cosmetic bug in the kernel, weird that 5.10 did not get fix backported since it got the breaking change backported?

It is not really using 100% it just looks like it. You can ignore it or preferably try updating to a more recent kernel, 5.10 is OLD.

1 Like

thanks for the insight.
I did just try 5.15 and it’s the same… I can’t upg to 6.x yet due to some DKMS dependencies that won’t compile with 6.x yet.

EDIT: I just updated another machine that’s also on 5.10 and there’s no “cosmetic bug”… seems something else is the issue?

I’ve been using perl-finance-quote with GnuCash. As of version 5.0, some dependencies were moved to AUR, but not explicitly added as AUR dependencies of the package. My workaround was

yay -S base-devel perl-readonly
yay -S perl-web-scraper perl-spreadsheet-xlsx perl-html-tokeparser-simple

perl-spreadsheet-xlsx may require a second try for success.

As of this update, I received a warning about these and some other perl modules used by perl-finance-quote. This needed to be rebuilt similarly to the python3.11 update instructions above.

yay -Syu rebuild-detector
pamac build $(pacman -Qoq /usr/lib/perl5/5.36)

Back to normal (normal since 5.0 unfortunately no longer includes Yahoo-JSON, so only 5 quotes per minute).

I get the following Error.

Warning: manjaro-hello: local (0.7.0-6) is newer than extra (0.7.0-5)
Resolving dependencies...
Checking inter-conflicts...
Warning: could not fully load metadata for package vtk-9.2.6-7
Error: Failed to prepare transaction: invalid or corrupted package

I uninstalled vtk, and the Upgrade went fine. I’m still not sure if I actually need it.

It only exist if you use use akonadi+mariadb
If you dont you wont notice the ‘issue’.

1 Like

My system wouldn’t boot after the update, but installing kernel65 and switching to that one fixed it for me.

2 things:

  1. Had to set locale.gen new (helped by:)
    [root tip] [How To] Troubleshooting locale errors
  2. timeshift gui won’t start (ask for password and then nothing)
    via terminal wtih “sudo timeshift-gtk” its works. But no start from plasma. But this issue was already before this update! I found this solution:
    [Solved] timeshift gui on KDE Plasma - Debian User Forums
    But “pkexec” is stange for me …

For some unaccountable reason, some Perl modules are no longer in the repos. I have some scripts which rely on the forks module, which was no longer valid due to the new Perl version. Trying to reinstall it failed as it was no longer there.
I’ve ended up having to install forks (and its dependency, acme::damn, which is also gone) from CPAN.
I suspect there may be other Perl modules that are no longer there as well (unless I’m just very unlucky) so it’s worth checking if you use Perl.

sudo should not be used with graphical applications.
polkit on the other hand is acceptable
(pkexec is somewhat comparable to the long deprecated gksudo)

A number of perl packages were removed from the repos but can be found in the AUR.
(as seen in the post from @rf2020 above)

The issue still exists even when not using akonadi+mariadb, that combination is just one use case that triggers the issue.

1 Like

hey, it worked for me… I changed my akonadi db to postgre and iowait is gone. thank you!

1 Like

Not sure it’s because of this update, but Android Emulator starts up with a blank screen, churning the CPU at 200%. Reinstalling didn’t help, I’ve seen complaints such as “Please update the emulator to one that supports the feature(s): Vulkan”.

I’ll keep trying but so far nothing seems to help.

Okay, I will take it back. It’s the android image that doesn’t work. Pixel_4_API_30 (Android R) doesn’t boot, while Pixel_4_API_33 (Android T) boots.

Something’s wrong with the Android image, unrelated to the Manjaro update.

4 posts were split to a new topic: Bluetooth headset showing multiple entries in KDE after update

manjaro-hello does not start anymore

After the update some flatpack apps (Notepad Next, Nomacs) fail to start. It happend after the previous update too. Reinstall helped then and probably will now too but it would be nice to know what causes the problem. Other flatpack apps work just fine.


[varikonniemi@varikonniemi-pc ~]$ manjaro-hello 
DEBUG:root:_DATA_DIR is /usr/share/application-utility
DEBUG:root:_PREF_FILE is /usr/share/application-utility/preferences.json
DEBUG:root:self.file is {'desktop': '', 'main': '/usr/share/application-utility/default.json'}
INFO:root:json to merge : /usr/share/application-utility/default.json
DEBUG:root:json : /tmp/manjaro-hello-preferences.json
** Message: 15:41:06.396: flatpak_plugin.vala:393: refreshing flathub appstream data
Error in Embled application: 'Database' object has no attribute 'enable_appstream'
Segmentation fault (core dumped)

Can you check the start of “Timeshift” ?
I am on Plasma and both apps don’t start.
Other GTK-apps are working.

FWIW I am also on Plasma and just tested: The Timeshift GUI started without a problem.

1 Like

Manjaro Hello doesn’t launch anymore