[Stable Update] 2023-07-10 - Kernels, Plasma, Gnome, LibreOffice, Pipewire, Mozilla, Wine

Okay i have Meld installed now, but Related to the file permissions what you suggested, how should i save the changes?

When i use pacdiff -S it cycles though all .pacnew files, and i viewed a few pacnew files with v and i saved the files with Meld after i edited them but is that the right way to handle the permissions?

I just wanted to be sure, because there is also m for merge and i have no clue what merge exactly does and where is the difference between merge and overwrite in pacdiff?

So is there a difference related to replace (viewed/edited till files are identical lead to autodelete, i found out) with meld or overwrite with pacdiff?

run pacdiff -s
choose view the file.
edit the changes you want and save in meld and close it.
choose remove in the pacdiff question (it is still the same file you choosed to view).
repeat procedure until pacdiff no longer asks.

The risk with overwriting is if you have added anything in the file, that will disappear.
If you are 1000% sure you have not, or anything else (like an installed program you have) have made any changes from default, then it’s most likely fine to overwrite.

As for merge, I got it described as “not optimal” to do. You do what you want with that answer.

today, after installed a libpamac 11.5.7 and a couple days from this the updater works fine and correct: I used a terminal for checking update (sudo pacman -Syu and pamac upgrade -a) for this days but today the terminal and GUI pamac has same picture.
However, the problem with screen resolution with 6.4 kernel for now isn’t been

Thank you, that worked as intended, I just commented those lines.
Not sure why it didn’t do it as it should.
I didn’t notice the first post about it, so sorry for that.

I know, how to merge pacnew files, but I do not know right syntax for pam.d configuration regarding SDDM. I am at this state:

Do you know, what to merge where and what is the meaning of leading - at almost every new line?

1 Like

The update did only work by using cli:

sudo pacman -Syu

When trying to update by GUI, the app reported a failure.

As such the update through cli went without any trouble; the system is stable. Nothing to report.

I never said that at all, perhaps you’re confusing me with another poster. I understand and know how to manage pacnew files.

I was simply pointing out that in the real world very many Manjaro users will never have done anything about pacnew files because they’re simply not aware of them (as numerous threads and posts in recent days have shown), and their system continues to run fine for years regardless because breaking changes in pacnew files are rare.

And also that telling people to run pacdiff -s is perhaps not the most user-friendly introduction to the topic given that’s it’s default difftool isn’t even installed on a standard Manjaro system. Sure, pacdiff -o is a good one to know.

This distro puts front and centre a GUI package management and update tool which doesn’t notify users about additional actions required when pacnew files are installed, or even mention them at all in it’s user manual. And then you wonder why they don’t know about them?

You can’t have it both ways. Instruct users on how to update their system properly from the start or don’t be surprised when it turns out later that they have no idea what a pacnew file is.

2 Likes

I dont wonder that much.
After these years, I am no longer surprised at the lack of RTFM.
And I have no intention of trying to defend pamac. I dont use it.
And this update is a great example - pamac itself was broken.
So using that fancy gui wouldnt work.
I added the note in this announcement because until then there was ZERO communication, including about the repo change. Being on Unstable we have already dealt with it more than a month ago.
I thought it was a nice thing to note since no one at the team did so. If not … I suppose someone can remove it.

I dont try both ways. I suggest pacman, use pacman, discourage pamac, and chafe at those who try to push a narrative that it is the only suggested package manager.
Maybe you are trying to reach someone else?

I dont know what you are trying to show with the wiki links … theres more of them … including one that explicitly talks about pacnews and how to manage them … then linking back to the archwiki for further explanation. As has already been noted here multiple times.

Look - I really dont get whatever pitchfork mentality is happening here where there seems to be a few folks who want to target … me? … for … suggesting the proper tool for required user intervention?
Whatever it is … have fun with it. I already expressed my evaporating energy for entertaining these ‘discussions’ and such effervescent repetition.
So once again … cheers.

Perhaps. There is a disconnect between the way Manjaro promotes itself as a user-friendly Arch and then when people come here for help after using a tool like Pamac they get told they shouldn’t have been using that and they should know all this stuff that Pamac has hidden from them. I agree with the idea of self-help but if you’re not told how to do things correctly in the first place then… :man_shrugging:

I would probably agree that the way Official Manjaro Twitter presents things … and what veterans/volunteers/previous-team-members have to say can often be different.
(you can also see this in the wiki too)

2 Likes

Should mkinitcpio -P be run with or without priviledged (sudo or as root) rights?

my dear,
unfortunately i am one of those people who dont have a clue.

i was outdoors all day to somehow manage the damages after yesterdays heavy rainfalls, and tomorrow i should also be out on the fields again…

after reading more than 300 posts i somehow managed to update my system with:

sudo pacman-mirrors --geoip
sudo pacman -Syyu 
pamac update --force-refresh

then i tried:
sudo pacman -Syu "pacman>=6.0.2.11"

but pacman was already updated to 6.0.2.11, so i guess there is nothing to do?

then i needed to install vim because it was not pre-installed on my standard Manjaro-MATE installation.

then i tried:
pacdiff -s

it asked to “(M)erge” but responeded “unable to find a base package”.
so i choose “(V)iew” and vim showed the content of two local files:

var/tmp/grubVVyqwtFI.pacnew
var/tmp/grub.jUMq91qU

i have no idea what to do here. the last time i used vim was 20 years ago… so i quit the terminal.

finally i also tried to remove the unused repositiories with:
sudo pacman -Sc

but “community” seems to still be on my system.

Please, if you could give any step-by-step advice what needs to be done,
or can i just dump the steps regarding “pacdiff” and unused repositories?

2 Likes

Please use a more comfortable comparison tool then… ex: meld;

DIFFPROG=meld pacdiff -s

Its usually a good idea to have these environment variables set, such as in /etc/environment … which would make the preceding environment variable unnecessary.

In case anyone does want to implement such things - so as to use sudoedit and other nice stuff…
I will put here my examples for reference … use whatever tools or paths work for you;

EDITOR=/usr/bin/micro
SUDO_EDITOR=/usr/bin/micro
VISUAL=/usr/bin/kate
DIFFPROG=/usr/bin/meld
1 Like

I held off for a few days and noted all the issues talked about here, I was a little nervous about the update. I run nothing from AUR am on kernel 5.15, xfce and updated using sudo pacman -Syyu
all went well and I can report no problems.

OK the autofill on the Pamac gui doesn’t work as before, but you only have to hit return after typing in a few characters and you find what you want. The graphics on my DELL Workstation are fine.

Note that pamac was silently replaced with a new version rebased on gtk4.
The previous pamac can be recovered by installed pamac-gtk3.

PS.
I have also updated the guide post with more verbose pacdiff instructions included, namely the env var things and some explanation.

With Pamac we have now 11.0.1 26 based on gtk4 and 10.5.3 10 based on gtk3

Currently, In the 1st post, the link for pamac-gtk3 gets a 404.

Current: https ://gitlab.manjaro.org/applications/pamac/-/releases/10.5.3
Works..: https ://gitlab.manjaro.org/applications/pamac/-/releases/v10.5.3

With superuser rights. It writes to the /boot directory, which regular users do not have write access to.


It means that PAM will not attempt to load the pertinent module if it doesn’t exist in the system, for instance in the case where a GNOME-specific module would otherwise be loaded on a system with Plasma instead of GNOME.

Or otherwise put, it’s a kind of “don’t nag about this if it’s not installed” thing. :wink:

1 Like

I had installed this lib sudo pacman -Syu lib32-libnm - its mentioned on the main thread for steam.

I use diffuse to merge files...