[Stable Update] 2023-05-07 - Kernels, KDE Gear 23.04.0, KDE Frameworks 5.105.0, Qt5, Firefox, Thunderbird


I had a Problem with the layouts switcher not working and getting this error

There is somewhere a problem with variables. Not sure by now, but when you run:

export PYTHONPATH=/usr/lib/python3.11/site-packages

and then


It finds the module.

its now working thanks to @megavolt

Regards All


0.8.35-2 of gnome-layout-switcher should fix that … @2e0raf

Im running Plasma and I updated and cant get past sddm anymore, I enter my password and the screen goes blank then sddm comes back. I ctrl-alt-f2 and tried startx and it fails. I updated and checked the mirrors and it updates with no errors. I have amd cpu and graphics.

KDE is totally broken for me: akonadi starts but KMail can’t connect to it, panels are gone, no rightclick menu on the desktop (so I don’t know how to recreate panels), ALT+F2 quickstart not appearing, konsole lost its settings, cursor-up (cycle through last commands) in konsole does not work, no icons in Dolphin.

(Kernels 6.1 and 5.15, cursor-up is working in the shell you get with CTRL+ALT+F2)

pamac when run from a sudo -i environment is no longer working

# pamac update
Warning: Building packages as dynamic user
Warning: Setting build directory to /var/cache/pamac
Synchronizing package databases...

(pamac:6446): GLib-GIO-ERROR **: 07:48:23.979: No GSettings schemas are installed on the system
Trace/breakpoint trap (core dumped)

(core is not actually dumped, so no backtrace)

No further packages to install, also no errors in /var/log/pacman.log:

$ sudo pamac update
Warning: Building packages as dynamic user
Warning: Setting build directory to /var/cache/pamac
Synchronizing package databases...
Refreshing AUR...                                                                                                                                            
Warning: manjaro-hello: local (0.7.0-6) is newer than extra (0.7.0-5)                                                                                        
Nothing to do.
Transaction successfully finished.
$ inxi -fza
  Info: model: Intel Core i5-8250U socket: BGA1356 (U3E1) note: check bits: 64
    type: MT MCP arch: Coffee Lake gen: core 8 level: v3 note: check built: 2017
    process: Intel 14nm family: 6 model-id: 0x8E (142) stepping: 0xA (10)
    microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 3399 high: 3401 min/max: 400/3400 base/boost: 3300/1800
    scaling: driver: intel_pstate governor: performance volts: 1.0 V
    ext-clock: 100 MHz cores: 1: 3398 2: 3400 3: 3400 4: 3400 5: 3400 6: 3400
    7: 3400 8: 3401 bogomips: 28808
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp
    rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected

I have not much time to investigate now unfortunately.

trying to launch KDE systemsettings reveals that it has problems loading QMLs.
kcmshell5 kcm_desktoptheme shows Plasma Style - Error loading QML file. Invalid KPackage ‘kcm_desktoptheme’

After update noticed that boot was slower than before and some programs started way slower. Like Nemo, opened about 10 seconds after click. Opening Settings → Power freezed program.

Gnome, kernel 6.2 and HP laptop.

Same problem described in here → Gnome Einstellungen starten nicht mehr -> Problem mit upower

Found solution here → [SOLVED] Last gnome version goes too slow / Applications & Desktop Environments / Arch Linux Forums

Removed libplist-git AUR package and installed libplist from Official repositories → reboot → problem gone.

Dont use sudo with pamac.
Otherwise it looks like a partial upgrade or you have an odd package
(like here: Error Logging Into Plasma After Hard Reboot)
Sort your mirrors to be sure as well. ex;

sudo pacman-mirrors -f && sudo pacman -Syyu
1 Like

Thank you. Will do and remember that.
It seems the upgrade uninstalled a number of KDE packages.

I did the KDE Plasma 5 steps from Install Desktop Environments - Manjaro and KDE is back now

Can you please enable bootsplash on linux63?

> zgrep CONFIG_BOOTSPLASH /proc/config.gz


I see, so this is not guaranteed to happen. OK, I’ll back that up and see if I experience the problem or not.

EDIT: yep, mine is safe.

I ran out of space in home and now it boots to a black screen and shows the mouse cursor. Tty2 and startx brings me to a completely black screen. I deleted some big folders, so there is enough space now, but it won’t show up sddm or the GUI. It happens with kernel 6.3, 6.2 and 5.15.

Wny ideas how to fix this?

Enter a chroot environment and run the sync again, this time with enough free space:

How to chroot

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot encironment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart.

Once successfully in the chroot environment, run the following to do a complete sync/update:

pamac upgrade && pamac upgrade --aur --devel || echo -e '\033[0;91mThere was an error upgrading the system. AUR packages not upgraded.\e[0m'

This will update your system and ONLY if that was successful update any AUR packages.

a Reminder: While use of the AUR is possible, it’s neither recommended nor supported.

I recommend pamac instead of pacman, especially for newcomers as pamac was developed by Manajaro (developers) for Manjaro and just takes care of more thing than pacman.

1 Like

I can not run Spyder anymore :frowning:
in the terminal i got this last line:

pkg_resources.DistributionNotFound: The ‘astroid<=2.17.0-dev0,>=2.15.4’ distribution was not found and is required by pylint

I still have astroid 2.15.2. How can i update to astroid 2.15.4 ?

OK, it appears that the update itself went fine. My chrooted pamac said “nothing to do”. So, I tried to restore my time shift backup instead, which brings back SDDM, but now I cannot login. I type in my password and hit enter. Thereafter, SDDM freezes. I can still move the mouse cursor but cannot click anything.

Can I somehow circumvent SDDM / repair SDDM / see if Plasma is running fine or SDDM is hanging and just not loading KDE?

1 Like

For me xfce4-pulseaudio-plugin kept crashing instantly until i downgraded it to the previous version.

I recommend pamac instead of pacman, especially for newcomers as pamac was developed by Manajaro (developers) for Manjaro and just takes care of more thing[s] than pacman.

Does it have the same commands, like for instance sudo pacman -Syyu equals sudo pamac -Syyu ?
And are you the only one who recommends pamac over pacman from tty?
I did pacman updates from tty and got few bugs except the slide back desktop effect which confuses front and back then and when when I switched Activities.
I recommend force re-installing video-nvidia after every update.

as a update, i had updated everything except amd-ucode, and it was fine, then upgraded the bios version (ASUS b550f from 2803 to 3002) and it ran fine, then installed the update for amd-ucode and it also runs fine now


A post was split to a new topic: All of my screen recording programs don’twork anymore

Hi, After this update crc start fails with message ‘internal error: virtiofsd died unexpectedly’. systemctl status libvirtd.service shows as no longer active. Linux419. Reverted back to snapshot and its fine.

Not the same.
pamac uses ‘regular phrases’ like install.
pamac also has some bugs about grabbing packages from the AUR at the moment … and some other quirks. AFAIK theres not any reason to recommend pamac over pacman besides that ‘easiness’.
(in fact myself and some others much prefer, and choose, to use pacman exclusively)
Someone once said ‘pamac does extra things’ … I still dont have any evidence for what they were referring to. Most automation that pamac does (like automatically changing mirrors) is not required, many people deactivate, and are often a source of breakage.
All of that is not to tell folks what they should use … just that I dont see any reason to avoid pacman if you are comfortable with it.


It APPEARS that the default kernel gets changed automatically to 6.2? For whatever reason, my system won’t run the 6.2 kernel. Luckily, it runs 6.1 okay.