[Stable Update] 2023-05-07 - Kernels, KDE Gear 23.04.0, KDE Frameworks 5.105.0, Qt5, Firefox, Thunderbird

Is it safe to remove this package ?

Yes, remove it


Kernels 6.2 & 6.3 still broken with AMD iGPU (AMD Ryzen 7950X3D) (and maybe multi-monitor?)
When I use any of them (instead of 6.1) after login my desktop has a white layer on top of everything. Moving the mouse quick, makes the desktop appear briefly.

  Host: wizzy-am5-manjaro Kernel: 6.1.26-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.4 Distro: Manjaro Linux
  Type: Desktop System: Gigabyte product: X670E AORUS MASTER v: -CF
    serial: <superuser required>
  Mobo: Gigabyte model: X670E AORUS MASTER v: x.x
    serial: <superuser required> UEFI: American Megatrends LLC. v: F10d
    date: 05/05/2023
  Info: 16-core model: AMD Ryzen 9 7950X3D bits: 64 type: MT MCP cache:
    L2: 16 MiB
  Speed (MHz): avg: 4069 min/max: 3000/5759 cores: 1: 5025 2: 5034 3: 5019
    4: 5038 5: 5030 6: 5035 7: 5035 8: 5039 9: 2862 10: 3000 11: 3000 12: 3000
    13: 3000 14: 2706 15: 3000 16: 5123 17: 5025 18: 5026 19: 5034 20: 5010
    21: 5046 22: 5036 23: 5022 24: 5029 25: 2873 26: 2699 27: 2743 28: 3000
    29: 3000 30: 3000 31: 3000 32: 3722
  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] driver: vfio-pci
    v: N/A
  Device-2: AMD Raphael driver: amdgpu v: kernel
  Device-3: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: amdgpu
    unloaded: modesetting,radeon dri: radeonsi gpu: amdgpu resolution:
    1: 1200x1920~60Hz 2: 2560x1440~60Hz
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: AMD Radeon Graphics (gfx1036
    LLVM 15.0.7 DRM 3.49 6.1.26-1-MANJARO)
  Device-1: AMD Navi 21/23 HDMI/DP Audio driver: vfio-pci
  Device-2: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
  Device-3: Creative Sound Blaster X5 type: USB
    driver: cdc_acm,hid-generic,snd-usb-audio,usbhid
  Device-4: Logitech HD Pro Webcam C920 type: USB
    driver: snd-usb-audio,uvcvideo
  API: ALSA v: k6.1.26-1-MANJARO status: kernel-api
  Server-1: PulseAudio v: 16.1 status: active
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: vfio-pci
  Device-2: Intel Ethernet I225-V driver: igc
  IF: enp15s0 state: up speed: 1000 Mbps duplex: full mac: 74:56:3c:4b:74:7e
  Device-3: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi
  IF: wlp16s0 state: down mac: 06:5e:84:aa:2d:31
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 5.48 TiB used: 1.11 TiB (20.2%)
  ID-1: /dev/nvme1n1 vendor: Seagate model: XPG GAMMIX S50 Lite
    size: 953.87 GiB
  ID-2: /dev/nvme2n1 vendor: Samsung model: SSD 970 EVO 500GB
    size: 465.76 GiB
  ID-3: /dev/sda vendor: Toshiba model: HDWE140 size: 3.64 TiB
  ID-4: /dev/sdb vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
  ID-1: / size: 448.43 GiB used: 17.8 GiB (4.0%) fs: ext4 dev: /dev/nvme2n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat
    dev: /dev/nvme2n1p1
  ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme2n1p3
  System Temperatures: cpu: 50.9 C mobo: N/A gpu: amdgpu temp: 43.0 C
  Fan Speeds (RPM): N/A
  Processes: 538 Uptime: 36m Memory: 61.95 GiB used: 40.42 GiB (65.2%)
  Shell: Zsh inxi: 3.3.26

After this Stable Update rustup and rust-analyzer both provided by our community Repos are in conflict. Not sure what happened…

EDIT: it seems like rustup is providing rust-analyzer, I don’t know if it did before, so it should be only a matter of configuration

Well it was a matter of configuring rustup just as described at rust-analyzer’s User Manual (look at rustup session)

If you copy ~/config/plasma-org.kde.plasma.desktop-appletsrc somewhere safe, you can restore your desktop widgets if necessary.
If you need to restore, do so with your desktop logged off (you can use a TTY), as otherwise your restored file will be over-written.

That said, I had no such problem upgrading my KDE Plasma system.

1 Like



FFS Can you PLEASE stop changing the settings of my Konsole in every other update? This has happened for the fourth time - I don’t want ZSH, I want my bash. Ridiculous.


It should not force you to use our profile if you have your own set up in your home folder. Can you send me your /etc/xdg/konsolerc and ~/.config/konsolerc?


I had a Problem with the layouts switcher not working and getting this error

There is somewhere a problem with variables. Not sure by now, but when you run:

export PYTHONPATH=/usr/lib/python3.11/site-packages

and then


It finds the module.

its now working thanks to @megavolt

Regards All


0.8.35-2 of gnome-layout-switcher should fix that … @2e0raf

Im running Plasma and I updated and cant get past sddm anymore, I enter my password and the screen goes blank then sddm comes back. I ctrl-alt-f2 and tried startx and it fails. I updated and checked the mirrors and it updates with no errors. I have amd cpu and graphics.

KDE is totally broken for me: akonadi starts but KMail can’t connect to it, panels are gone, no rightclick menu on the desktop (so I don’t know how to recreate panels), ALT+F2 quickstart not appearing, konsole lost its settings, cursor-up (cycle through last commands) in konsole does not work, no icons in Dolphin.

(Kernels 6.1 and 5.15, cursor-up is working in the shell you get with CTRL+ALT+F2)

pamac when run from a sudo -i environment is no longer working

# pamac update
Warning: Building packages as dynamic user
Warning: Setting build directory to /var/cache/pamac
Synchronizing package databases...

(pamac:6446): GLib-GIO-ERROR **: 07:48:23.979: No GSettings schemas are installed on the system
Trace/breakpoint trap (core dumped)

(core is not actually dumped, so no backtrace)

No further packages to install, also no errors in /var/log/pacman.log:

$ sudo pamac update
Warning: Building packages as dynamic user
Warning: Setting build directory to /var/cache/pamac
Synchronizing package databases...
Refreshing AUR...                                                                                                                                            
Warning: manjaro-hello: local (0.7.0-6) is newer than extra (0.7.0-5)                                                                                        
Nothing to do.
Transaction successfully finished.
$ inxi -fza
  Info: model: Intel Core i5-8250U socket: BGA1356 (U3E1) note: check bits: 64
    type: MT MCP arch: Coffee Lake gen: core 8 level: v3 note: check built: 2017
    process: Intel 14nm family: 6 model-id: 0x8E (142) stepping: 0xA (10)
    microcode: 0xF0
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 3399 high: 3401 min/max: 400/3400 base/boost: 3300/1800
    scaling: driver: intel_pstate governor: performance volts: 1.0 V
    ext-clock: 100 MHz cores: 1: 3398 2: 3400 3: 3400 4: 3400 5: 3400 6: 3400
    7: 3400 8: 3401 bogomips: 28808
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp
    rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected

I have not much time to investigate now unfortunately.

trying to launch KDE systemsettings reveals that it has problems loading QMLs.
kcmshell5 kcm_desktoptheme shows Plasma Style - Error loading QML file. Invalid KPackage ‘kcm_desktoptheme’

After update noticed that boot was slower than before and some programs started way slower. Like Nemo, opened about 10 seconds after click. Opening Settings → Power freezed program.

Gnome, kernel 6.2 and HP laptop.

Same problem described in here → Gnome Einstellungen starten nicht mehr -> Problem mit upower

Found solution here → [SOLVED] Last gnome version goes too slow / Applications & Desktop Environments / Arch Linux Forums

Removed libplist-git AUR package and installed libplist from Official repositories → reboot → problem gone.

Dont use sudo with pamac.
Otherwise it looks like a partial upgrade or you have an odd package
(like here: Error Logging Into Plasma After Hard Reboot)
Sort your mirrors to be sure as well. ex;

sudo pacman-mirrors -f && sudo pacman -Syyu
1 Like

Thank you. Will do and remember that.
It seems the upgrade uninstalled a number of KDE packages.

I did the KDE Plasma 5 steps from Install Desktop Environments - Manjaro and KDE is back now

Can you please enable bootsplash on linux63?

> zgrep CONFIG_BOOTSPLASH /proc/config.gz


I see, so this is not guaranteed to happen. OK, I’ll back that up and see if I experience the problem or not.

EDIT: yep, mine is safe.

I ran out of space in home and now it boots to a black screen and shows the mouse cursor. Tty2 and startx brings me to a completely black screen. I deleted some big folders, so there is enough space now, but it won’t show up sddm or the GUI. It happens with kernel 6.3, 6.2 and 5.15.

Wny ideas how to fix this?

Enter a chroot environment and run the sync again, this time with enough free space:

How to chroot

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot encironment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart.

Once successfully in the chroot environment, run the following to do a complete sync/update:

pamac upgrade && pamac upgrade --aur --devel || echo -e '\033[0;91mThere was an error upgrading the system. AUR packages not upgraded.\e[0m'

This will update your system and ONLY if that was successful update any AUR packages.

a Reminder: While use of the AUR is possible, it’s neither recommended nor supported.

I recommend pamac instead of pacman, especially for newcomers as pamac was developed by Manajaro (developers) for Manjaro and just takes care of more thing than pacman.

1 Like

I can not run Spyder anymore :frowning:
in the terminal i got this last line:

pkg_resources.DistributionNotFound: The ‘astroid<=2.17.0-dev0,>=2.15.4’ distribution was not found and is required by pylint

I still have astroid 2.15.2. How can i update to astroid 2.15.4 ?