[Stable Update] 2023-03-31 - Kernels, Plasma 5.27 LTS, Pamac, Phosh, Mesa, LibreOffice

3 posts were split to a new topic: Ttf-noto-nerd: failed to commit transaction (conflicting files)

A post was merged into an existing topic: Ttf-noto-nerd: failed to commit transaction (conflicting files)

My GNOME Settings > About panel shows the current Gnome version as 43.4. Meanwhile, Packages shows the current version of the gnome-desktop package in stable as 1:43.2-1. So which is it? I’m trying to troubleshoot an issue on another forum and I want to be able to tell them which versions of stuff I’m running with a bit of confidence.

Hi there.

I’m wondering if it might be worth offering a choice of full disk vs root disk encryption in the installer. I’m running Arch (I used “archinstall” script" on an old laptop with Xfce, Grub & partial encryption & am not having any issues. Given that a significant number of people will want a level of encryption on their notebook, I think it’s worth considering.

Thanks team & everyone that tests it for the rest of us. More power to you all. Ruziel :slight_smile:

1 Like

And I think I found a bug with the new KDE Plasma, related to multi-monitor support. The Move Window KWin script broke. Can someone please point me to where I should report it to KDE? (Bug description here.)

It is fairly simple to do already

Updated and the desktop and all icons vanished and no app icon runs. Looking at it right now.
I cannot use the command prompt but I have Yakuake. Through this I looked at the command “xfdesktop” which had an error returned on gtk-appmenu-module. I use packman to install this module but it just chained into another error so I reversed change.

Through Yakquake I can launch programs just I have an un-usable desktop/workspace.

Note:- All icons even Manjaro icons do not work I seem to only have the one app Yakuake that works.

Any ideas would be appreciated.

[edit] I installed the gtk-appmenu-module and proceeded on but it leads to another error.
command xfdesktop - Failed to connect to session manager: Failed to connect to the session manager: SESSION_MANAGER environment variable not defined.

A post was split to a new topic: Input delay with external monitor connected via DisplayPort

My Creative Soundblaster AE-5 (soundcard) no longer working after changing the output device in the KDE Sound Control, i think its called pavu control.

My soundcard was working, till the moment i played with the pavu sound manager.

The creative card is no longer listed there, but still can be accesses with alsamixer, still no sound at all.

Just wondering if it will be better when changes that could impact booting your system or similar, if there should be a more “official” wiki entry explaining how you might solve and update your configuration to avoid the booting issues. It will also increase the community knowledge :slight_smile:

The current approach where everyone posts their solution (for their setup) and having the information spread across threads make it even more confusing, and potentially dangerous if you don’t know well what you are doing.


one simple thing would be to make the CLI password input environmental flag default. Currently i suspect less than 1% of users know about it and suffer cli->gui->cli workflow.

I did the update yesterday and lutris didnt work anymore. I had 2 games, where it said once “D3D rendering failed”, the second said “need a GPU what supports (…)11”

I had to completly remove nvidia-470 470.182.03-1 and switch to nvidia-470 530.41.03-1
The update also removed my nvidia-settings without any other replacement.
Now it seems it works normal as before.

Kernel 6.1 GPU Nvidia GTX 960

you have to add nvidia-settings

After the update, my trackpoint freaked out. Moving towards the top right worked fine, any slight movement in other directions lead to erratic jumping.

Rebooting the computer another time fixed it. (I had already rebooted to apply changes.)

KDE Plasma version and Lenovo E470, in case anyone wants to check if they have the same issue.

After last upgrade I had a black desktop screen problem. I followed these instructions (prime driver not working for my dual gpu laptop) than it worked.
But on reboot I got the message “error: no such cryptodisk found. Perhaps a needed disk or cryptodisk is not loaded”
I enabled GRUB_ENABLE_CRYPTODISK=y in /etc/default/grub, did sudo update-grub and rebooted. But than the black desktop screen came back again. I have set it back again for now.

Regarding your other suggestions: /boot/grub/grub.cfg “…try to remove the dash separators”, does it mean the UUID has to be written like this instead (in your example): ’ 3722dfb23b32414bbd59-4329fa92b6a9??

What can be done to keep away the black desktop screen (including the KDE Plasma ssdm still does not appear in color anymore) and getting rid of the error message on booting as well.

I do have one luks ssd for root and another separated luks hard disk for my data. For the second luks hard disk I have to enter always the password on boot as well.

After the update, most everything I use seemed to work, except OBS. Since I rely on OBS for work and streaming several times a week, I had to use Timeshift to revert my system. OBS is working again but I’d really like to keep my system updated. So, my question is…

This may be a noob question but is there a procedure (or guide) we could use to check the dependencies for a specific app, and then choose not to upgrade things that will cause the app not to work?

I know I can do this:

$ pacman -Qi obs-studio-git
Name            : obs-studio-git
Version         : 28.1.0.beta1-2
Description     : Free and open source software for video recording and live streaming.
Architecture    : x86_64
URL             : https://github.com/obsproject/obs-studio
Licenses        : GPL2
Groups          : None
Provides        : obs-studio=28.1.0.beta1
Depends On      : ffmpeg  jansson  libxinerama  libxkbcommon-x11  mbedtls  qt6-svg  curl  jack  gtk-update-icon-cache
                  speexdsp  pciutils  libajantv2  librist
Optional Deps   : libfdk-aac: FDK AAC codec support [installed]
                  libxcomposite: XComposite capture support [installed]
                  libva-intel-driver: hardware encoding [installed]
                  libva-mesa-driver: hardware encoding [installed]
                  vlc: VLC Media Source [installed]
                  luajit: Lua scripting [installed]
                  python: Python scripting [installed]
                  v4l2loopback-dkms: Virtual webcam [installed]
                  pipewire: Pipewire capture [installed]
                  pipewire-media-session: Pipewire capture [installed]
                  xdg-desktop-portal: Pipewire capture [installed]

and get a list of dependencies, but most of those dependencies don’t appear in my Pamac list of updates. So, is there an easy way to tell what is causing OBS (or any app) to fail? And then, is there a way to revert ONLY the necessary things to make that app work again?


It’s always worth trying to run it from a terminal; you may well get some useful messages that way. Check if there are any command-line flags to the program to enable extra diagnostics/verbosity. It’s also often useful to have another terminal watching the systemd journal as relevant messages can appear there as well


Ksysguard seems broken since the update:

When I click the icon in the GUI it doesn’t start. In terminal I get this

ksysguard: error while loading shared libraries: libhwy.so.0: cannot open shared object file: No such file or directory

This is actually causing a lot of apps to fail. OBS for example

Edit: User Olli sent me a message explaining me libjxl was missing. After installing this ( it replaced libjxl-git ) everyhting works normal.

After upgrade I got a black screen with blinking cursor. When logged in via the terminal and did a startx and got a "fatal server error (ee) no screens found (ee). I looked in the xorg log and that said “failed to initialize the nvidia kernel module”.

after installation or after update ? your statement is vague. please open a thread for this issue and provide clear infos.