[Stable Update] 2023-03-31 - Kernels, Plasma 5.27 LTS, Pamac, Phosh, Mesa, LibreOffice

the system has updated smoothly (manjaro gnome) but i found out that after restart the headphone doesn’t work unless i unplug it and plug it again .
i found the solution in the forum
the title : [Dell Laptop: Analog Speaker Audio only after plugging and unplugging headphones]

the link :

the solution is deleting your pulseaudio user settings

rm ~/.config/pulse/cookie ~/.config/pulse/*.tdb

then reboot

I allowed myself to edit the wiki post in order to clarify the two points regarding GRUB, if anyone wants to double check me.

1 Like

Great operating system, smooth update. Thanks for everything. The combination of Plasma and Manjaro has proved stellar. Come on everyone, consider donating to Manjaro on a regular basis. I have been a supporter 5 for the last months for the price of two espressos a month. Small price to pay for a great system!

so this is why i now don’t have my desktop anymore?

Automatically removing orphans could lead to problems, list them out and do it manually, it’s only a bit of time but could potentially save you time.

A post was split to a new topic: Davinci Resolve: gpu init failed, cannot find opengl

I’m getting a systemd error on boot after the update:
Failed to insert module 'nvidia_uvm': No such device

System continues on afterwards and finishes booting.

For background, I am using vfio-pci to stub out my nvidia card for GPU passthrough to a VM. I don’t need to load any drivers for it. lspci -nnk shows these drivers are correctly in-use for the video card.

EDIT: I simply added nvidia, nvidia-drm, and nvidia-uvm to the blacklist, restarted systemd-modules-load successfully.

Also for some feedback on the LUKS encrypted drive solution, I ran update-grub and grub-install after adding the cryptodisk module to the grub config. Didn’t rerun mkinitcpio however since it didn’t make sense to me do so (the pacman hooks already run this, and the grub config doesn’t affect the kernel images). Rebooted fine save for the one error message.

May I make a suggestion for the partition scheme?

It is very nice that Manjaro includes Plymouth again. Plymouth CAN be particularly useful if the root partition is encrypted - because the graphical password prompt has a few advantages over the simple text input. (It also just looks better…)

In order for the graphical password prompt to work with EFI we need actually an unencrypted /boot-partition in addition the unencrypted /boot/efi and /root partitions.

I know there is supposed to be a potential security vulnerability with an unencrypted /boot. I’m not sure what it is, but other otherwise professional distributions (Fedora, Ubuntu, …) do this as well. So maybe this would be a nice addition to the installer for Manjaro?

I read the comments about Grub and blocked it for now. Than the update went smooth.
Thanks to that Great :hugs: Community and the Manjaro Team.

It’s for sure a great job of the team to deal with all that hardware out there.

A Backup on a 1TB SSD before major updates is done in 15 minutes, no big deal at all and Timeshift should be active for the root partition anyway!

Among the Arch forks, I still believe that Manjaro is the best choice concerning “user friendliness”.

Long live Manjaro :green_heart:


I am still having an issue with grub. I followed the solution for grub with LUKS and am left with a grub_debug_malloc not found error and dropped into grub rescue.

I followed solutions from


Decided to revert to pre 3.31 until this can be solved.

I had the issue with grub that went into rescue mode, but I was able to start the live ISO and chroot and fix the grub installation.

Update /etc/default/grub config to add cryptodisk module

GRUB_PRELOAD_MODULES="cryptodisk part_gpt part_msdos"

Then apply changes

sudo update-grub
sudo mkinitcpio -P
sudo grub-install --target=x86_64-efi --efi-directory=/boot --bootloader-id=manjaro # as I use UEFI and my ESP is /boot (where my EFI folder is located i.e: /boot/EFI)

After fixing the boot, I had to edit the desktops in edit mode → manage desktops and panels.
Somehow I had several panels in one desktop, and the secondary was swapped with a fresh config.

Also it seems that Wayland still have issues with nvidia on 5.27, so I’ll keep x11 for now

Noticed a new issue after the update: when I disconnect my displayport monitor, plasmashell segfaults and is restarted by systemd. System info:

Operating System: Manjaro Linux 
KDE Plasma Version: 5.27.3
KDE Frameworks Version: 5.104.0
Qt Version: 5.15.8
Kernel Version: 5.10.176-2-MANJARO (64-bit)
Graphics Platform: X11
Processors: 12 × Intel® Core™ i5-10600K CPU @ 4.10GHz
Memory: 31.2 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630
Manufacturer: Micro-Star International Co., Ltd.
Product Name: MS-7C75
System Version: 1.0

Before plasmashell crashes I see this in the journal logs:

kwin_x11[1460]: kwin_core: Parse error in tiles configuration for monitor "5b7a5ba4-43cc-5910-8e98-f358f9d54b43" : "illegal value" Creating default setup

I have 1 DP monitor, and 1 HDMI. No crashes if I turn off the HDMI monitor, only happens with displayport. Also occurs if I switch the DP monitor to another input.

EDIT: SOLVED. I added an entry to ~/.config/kwinrc with the “ghost” monitor uuid:


No more segfaults!

Thanks the the heads up for grub, and for bringing KDE Plasma 5.27 to stable!

Took care of all my “pacnew” files (pacman & grub) post update (before reboot), sudo update-grub, sudo mkinitcpio -P for good measure, rebooted, and all was well!

1 Like

Ditto! After sending it to the background, things have finally stopped looking far too tiny. :smiley:

Most people notice the error message that the module cryptodisk is not found and can press any key to continue the boot process. Others have a broken grub bootloader installation, either following the steps wrong or other reasons.

So here again:

  • /etc/default/grub needs to been checked for GRUB_PRELOAD_MODULES="cryptodisk part_gpt part_msdos" and GRUB_ENABLE_CRYPTODISK=y
  • grub menu needs to been updated via update-grub

That should be the only thing you may need. Installing grub to MBR/UEFI always should be the last resort unless you want to have security updates or the latest grub version on your system. If your system however has a broken bootloader installation you may need to restore it. Read the linked discussion thread for more info about further solutions.

Well, the solution you posted is still confusing as the issue actually is only a warning that the cryptodisk module is not found and people can still boot. Then they start to do stupid things to get that fixed which is “ain’t broken”. As stated above the /etc/default/grub needs to been “fixed” and the menu updated. Calling mkinitcpio makes no sense here as it only recreates the kernels and calls update-grub in the end. Also calling grub-install should be a last resort based on known reasons. Also the issue what we have with grub in general should be clear by now.


I wonder why Pamac looks completely different in X11 Plasma session vs in Wayland Plasma?

PS. I had a problem finally switching from X11 to Wayland and changing scaling in KDE: the window of Pamac became 4 times bigger than my screen, so I had to do some tricks to make it smaller.

Pama is still a GTK3 or GTK4 application. Depending which version you have installed. You can also check Discover and Octopi if you want more native looking Plasma Apps.

So, this update kinda made the XMPP Client Programm “Dino” like… white? Beforehand it was dark like the rest of my system - Settings are Breath Dark for native and Breeze for GTK Programms. Funny thing is the output of neofetch:
It does not mention Breath Dark in anyway, I think it did in the past - maybe wrong memory…
What is wrong here and why did the update trigger this?

The QT alternative didn’t really take off and isn’t really a big payoff for the effort I assume, but GTK is fine… and with native Breeze or Lightly theming (follows colour scheme) there’s not really much of a problem.

CLI sucks a bit because it’s not inclusive… for example, I had issues with shortwave, sorted in the Flatpak

Flatpak only shows in GUI.

well write down on how we should improve the CLI experience of pamac. You can look if others already mentioned stuff here: Issues · Applications / pamac · GitLab

1 Like