[Stable Update] 2023-02-12 - Kernels, OpenSSL, Nvidia, Mesa, LibreOffice 7.5, Pamac, Thunderbird

Hello community,

Another stable branch update with some usual package updates for you.

Recent News:

Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates:

  • All our supported Kernels got either updated or rebuild against the new toolchain
  • OpenSSL got a security fix update
  • NVIDIA 525.89.02 fixes a bug that could cause banding or flickering of color gradients on DisplayPort monitors.
  • Mesa got updated to 22.3.5 and Xorg-Server to 21.1.7
  • Chromium 110.0.5481.77
  • Thunderbird is now at 102.7.2
  • OpenZFS got renewed to 2.1.9
  • KDE Gear is now at 22.12.2
  • For Pamac we integrated a community patch to not use polkit UI for passwords when using it in a cli. PAMAC_CLI_AUTH=1 needs to been specified. Detailed infos can be found in this reddit post. Let us know what you think …
  • LibreOffice 7.5.0 is now the new fresh release. Still continues now with 7.4.5
  • Beside the usual upstream updates like Firefox Developer Edition, Python, Haskell and others we added our KDE Unstable packages as usual

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

Info about GNOME 43

GNOME 43 is here! :partying_face:

New in Manjaro GNOME:

Lonely leftover orphan packages that have been removed from the Arch / Manjaro repositories:

  • adwaita-maia
  • dynamic-wallpaper-editor
  • firefox-gnome-theme-maia
  • gtkhash-nautilus
    (Not compatible with Nautilus 43)
  • manjaro-dynamic-wallpaper
  • manjaro-gdm-tweak
  • nautilus-terminal
    (Not compatible with Nautilus 43 & EOL)

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.272
  • linux54 5.4.231
  • linux510 5.10.167
  • linux515 5.15.93
  • linux60 6.0.19 [EOL]
  • linux61 6.1.11
  • linux62 6.2.0rc7
  • linux515-rt 5.15.86_rt56
  • linux60-rt 6.0.5_rt14

**Package changes (Fri Feb 10 17:49:38 CET 2023)

  • stable community x86_64: 1448 new and 1426 removed package(s)
  • stable core x86_64: 44 new and 43 removed package(s)
  • stable extra x86_64: 802 new and 794 removed package(s)
  • stable kde-unstable x86_64: 38 new and 38 removed package(s)
  • stable multilib x86_64: 27 new and 24 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-02-12

Switch to the base-devel meta package requires manual intervention

2023-02-12 - Robin Candau

On February 2nd, the base-devel package group has been replaced by a meta package of the same name.
If you installed the base-devel package group prior to this date, explicitly re-install it to get the new base-devel package installed on the system:

pacman -Syu base-devel

Arch Linux - News: Switch to the base-devel meta package requires manual intervention


vlc player crashes while playing videos

A solution, regarding to rob215x, is:
VLC would crash immediately when trying to play any video. I opened VLC directly, and changed Preferences > Video > Output from “Automatic” to “VDPAU” and it works now. I found that solution on another thread but I still don’t understand the problem and why VDPAU works.


PHP 8.2 update and introduction of legacy branch

2023-01-13 - Pierre Schmitz

The php packages have been updated to the latest version 8.2. In addition to this, a new set of php-legacy packages have been introduced. These will follow the oldest but still actively supported PHP branch. This enables users to install the latest version but also introduces the option to use third party applications that might rely on an older version. Both branches will be kept up to date following our rolling release model. php and php-legacy can be installed at the same time as the latter uses a -legacy suffix for its binaries and configuration files.

In addition to this, the php7 packages have been removed as they reached end of life. The imap extension will no longer be provided as it relies on the c-client library which has been abandoned for many years.

Arch Linux - News: PHP 8.2 update and introduction of legacy branch


pacman-mirrors was temporarily renamed to manjaro-mirrors (changed has been reverted)

This was done to avoid confusion with an AUR / WSL package with the same name and avoid possible breakage. It should be a seamless transition.

Rename project (#183) · Issues · Applications / pacman-mirrors · GitLab

dbus-x11 demoted to AUR

dbus-x11 was installed out of the box on some flavors of Manjaro as of a year ago, but is no longer needed. If you have it installed, please replace it with dbus using the following:

sudo pacman -Syu dbus
XFCE becomes unusable if libxfce4ui-nocsd is still installed

So far XFCE Classic project hasn’t updated yet to 4.18 series. We pushed 4.17.0 version of the package, but don’t know if that helps in that situation. It is recommended to install the regular libxfce4ui package to avoid issues and comment on this issue: libxfce4ui 4.18.0 released · Issue #15 · Xfce-Classic/libxfce4ui-nocsd · GitHub


python-cairo 1.23.0-2 update requires manual intervention

The python-cairo package prior to version 1.23.0-2 was missing the compiled python module. This has been fixed in 1.23.0-2, so the upgrade will need to overwrite the untracked pyc file that was created. If you receive this error

python-cairo: /usr/lib/python3.10/site-packages/cairo/__pycache__/__init__.cpython-310.pyc exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/python3.10/site-packages/cairo/__pycache__/\*

to perform the upgrade.


We recommend to install openssl-1.1

Due to the update to openssl 3.0 some things still look for the older LTS version 1.1. You may install openssl-1.1 and maybe lib32-openssl-1.1 packages. However report such issues to us.

Known issues:

  • some SDDM themes might not work
  • dkms might not sign modules properly as header files may still depend on 1.1 version of openssl

Issues reported to Archlinux so far:

FS#76567 : [plasma-framework] 5.99.0 needs a rebuild against openssl 3.0

libx11 1.8.2 causes firefox to freeze

libx11 1.8.2 causes Firefox to freeze, mainly when highlighting text and copying things to the clipboard (e.g. password manager).

Issues reported:

Workaround (UNTESTED - at your own risk!):
Install the AUR Package libx11-firefox-fix

Kernel 6.0: AMDGPU - Screen freezes when waking from hibernation or suspend

Screen doesn't turn on when waking from suspend: Failed to pin framebuffer with error -19 (#2213) · Issues · drm / amd · GitLab

Mesa 22.2.x renders Calamares black on Gnome Development ISOs

For some yet unknown reason Calamares is rendered black on Gnome when Mesa 22.2.x is used. Current workaround is to install 22.1.x series and relogin to the live-session.

idk where else to ask that, is there an option for pamac to only output somewhat important messages, cuz it’s hard to find such between thousands of “updating program”

I’m experiencing a conflict while running this update:
/usr/lib/libnvidia-tls.so is present in both nvidia-390xx-utils and lib32-nvidia-390xx-utils packages, and
/usr/lib/libnvidia-tls.so.390.157 is present in both nvidia-390xx-utils and lib32-nvidia-390xx-utils packages.

I can totally understand if there’s no solution for this issue, given that this is a fairly old driver on a fairly old hardware (this is the most up-to-date one for my 920m according to mhwd), but if anyone knows an easy fix without investing time investigating it, I would appreciate it.


Maybe @philm could have a look, I saw something about it here [Testing Update] 2023-02-09 - Kernels, toolchain, OpenSSL, NVIDIA, Mesa, Thunderbird - #9 by philm, and a thread is opened here too Can't install proprietary NVIDIA drivers with mhwd, maybe continue discussion there.

1 Like

Files /usr/lib/libnvidia-tls.so, /usr/lib/libnvidia-tls.so.390.157 should be removed from lib32-nvidia-390xx-utils package. To finish upgrade I have to remove lib32-nvidia-390xx-utils package.

1 Like

Why don’t you try using the nvidia-470 driver together with optimus-manager? As a nivida lagacy user (GTX 770M) I think this is the best option in terms of performance/compatibility/vulkan extensions for our old laptops :wink:

Hello everybody,

I tried as usual to check if the list of updated hosts was correct, then I checked if I had any updates for the system, but it showed me that there are no new updates.

What could be the cause? So far I have not encountered this problem.

pacman-mirrors --status                                                                                                                              ✔ 
Local mirror status for stable branch
Mirror #1   OK  07:49   Bulgaria       https://mirror.telepoint.bg/manjaro/
Mirror #2   OK  01:56   France         http://ftp.free.org/mirrors/repo.manjaro.org/repos/
Mirror #3   OK  01:41   Netherlands    https://mirror.koddos.net/manjaro/
Mirror #4   OK  03:39   Bulgaria       https://mirrors.netix.net/manjaro/
Mirror #5   OK  03:16   Georgia        https://repos.silknet.com/manjaro/
Mirror #6   OK  04:00   Denmark        https://mirrors.dotsrc.org/manjaro/
Mirror #7   OK  00:03   United_States  https://codingflyboy.mm.fcix.net/manjaro/
Mirror #8   OK  03:27   Philippines    http://mirror.rise.ph/manjaro/
Mirror #9   OK  00:59   Uruguay        https://manjaro.repo.cure.edu.uy/
Mirror #10  OK  03:26   Greece         https://ftp.cc.uoc.gr/mirrors/linux/manjaro/

pamac checkupdates -a                                                                                                                                ✔ 
Your system is up to date.

Out of Date:
dbschema  9.0.2-1  AUR

Removing lib32-nvidia-390xx-utils helped, after updating all packages, Nvidia graphics are fine. Thanks

Verry odd after other mirrors refresh for fast 10, after he changed some mirrors now I see the updates. Maybe was a glitch or a bug I don’t know… Will see …

pacman-mirrors --status                                                                                                                   100 ✘  4s  
Local mirror status for stable branch
Mirror #1   OK  02:15   Bulgaria        https://mirror.telepoint.bg/manjaro/
Mirror #2   OK  02:18   United_Kingdom  https://mirrors.gethosted.online/manjaro/repos/
Mirror #3   OK  03:38   Ukraine         https://manjaro.astra.in.ua/
Mirror #4   OK  00:31   Portugal        https://mirrors.up.pt/pub/manjaro/
Mirror #5   OK  01:56   Italy           https://manjaro.mirror.garr.it/manjaro/
Mirror #6   OK  00:10   Germany         https://mirror.moson.org/manjaro/
Mirror #7   OK  04:03   United_States   https://mirror2.sandyriver.net/pub/manjaro/
Mirror #8   OK  00:47   South_Africa    http://manjaro.mirror.ac.za/
Mirror #9   OK  01:35   Chile           https://mirror.ufro.cl/manjaro/
Mirror #10  OK  01:14   Bangladesh      https://bd.mirror.vanehost.com/Manjaro/

Or they just haven’t sync’d yet…

More here:



The latest driver version that is compatible with my 920m is 430.40, but even that isn’t offered by mhwd. I remember some years ago once I managed to hack mhwd to allow me to install the 430, but I haven’t noticed any difference compared to 390, and I don’t think I could ever get vulkan support on this GPU. So ever since my last install I’m just going with what mhwd offers.

@geser’s solution solved the issue for me.

Maybe, but there was not the case if you see what I have posted.
Now In the end everything was ok, and the update has been done without problems.

Pay attention that removing lib32-nvidia may brake 32 bit games. From my point of view first of all this affects steam and its games.

And that is the most important thing.

1 Like

Fixed with lib32-nvidia-390xx-utils 390.157-3 coming along shortly.


Sorry I didn’t realize it was another readme from a different version of the driver. I was just trying to help


Thanks in advance to the entire manjaro team for your great work.

1 Like

You’re wrong if you look at the proper README file:


The compatibility in MHWD is taken directly from the provided Nvidia files. Manjaro only provides three version of Nvidia drivers to fit pretty much all cards (not the very old ones), which are 390, 470, and latest current driver.


Thanks for your answer :wink:

I just experienced recent nvidia-470 drivers are still working thankfully with some of the old listed cards not showing up in the new listing with the optimus-manager method.

1 Like

The Linux Kernel 6.1 is a LTS Kernel now, it should be labeled as such