[Stable Update] 2023-01-24 - Kernels, Plasma, Frameworks, Gear, Libreoffice, Mesa, Nvidia, Deepin

Today’s release gave me this dependency issue:

Warning: installing nvidia-utils (525.85.05-1) breaks dependency 'nvidia-utils=525.60.11' required by linux519-nvidia
Add linux519-nvidia to remove

linux519 is long EOL - remove that kernel (and switch to a newer one if that is your only kernel) before the update.

Error during update:

[2023-01-26T00:48:38-0800] [ALPM] error: could not extract /usr/share/locale/el/LC_MESSAGES/vlc.mo (Write failed)
[2023-01-26T00:48:38-0800] [ALPM] error: could not extract /usr/share/locale/en_GB/LC_MESSAGES/vlc.mo (Write failed)

Seems your disk is full.

Hello Forum. After the recent update I cannot login anymore. I am using i3wm with lightdm. Every time I try to login I am redirected to the login screen. Anyone else facing this issue? Any ideas for a fix? Thanks, z0id

Fix: It turned out to be a known lightdm issue (“Infinite Login Loop”). According to the ArchWiki (https://wiki.archlinux.org/title/LightDM#Troubleshooting), running

rm ~/.Xauthority

solved the problem.

Just reimaged back to k5.15.84-1 and noted system partition had 15 GB free.

Upgraded to k5.15.89-1 then deleted contents of /var/cache/pacman/pkg/

Now have 8.7 GB free space.

What is taking-up all that space?

Is there any other storage that can be deleted?

I’m probably the only person this will affect, but I’ll mention it just on the offchance that someone else has the problem.
Using photomatix (from AUR) I found that after this update it crashed due to not being able to find libtiff.so.5, since this has been upgraded to libtiff.so.6. Rebuilding the package didn’t help, but simply symlinking libtiff.so to libtiff.so.5 solved the problem (I haven’t seen any incompatibilities yet).

Thanks, I did not realize I was on an EOL kernel :rofl:

Which filesystem? I just had fun learning about BTRFS - with my 50GiB home partition, 130GiB total root and home - but 250GiB disk full.

I have issues with LibreOffice 7.4.4. It keeps crashing. This seems to be a known issue and should be resolved in 7.4.5. See LibreOffice 7.4.5 Released to Fix Crash Affecting a Large Number of Users - 9to5Linux

It however works in safe mode.

Fresh LibreOffice 7.45-1 7.4.5-1.0 packages are coming soon to a mirror near you.

EDIT: Sorry, 7.45-1.0 is coming to fix the library mismatch with 7.45-1.

1 Like

Although I did this step in my own time as Java 8 was indeed the default this is unfortunately not related to the issue of a linked library that cannot be found. Also my MultiMC game instances are using absolute paths to their respective Java versions, not just relying on the system default.

I have the same problem with the library, I have three different java versions, because Sweethome 3D uses java 11, freeplane and minecraft, java 17 and some others works with 19, using export LD_LIBRARY_PATH=/usr/lib64/jvm/java-xx-openjdk/lib/server works but applications like Sweethome 3D stopped working definitely, and it is cumbersome to be using the shell to launch each application.

Using btrfs

Moved the tmp build folder to a different volume and regained 2GB.

In construction:


1 Like

I have used AUR packages for years & not had problems. As long as one uses one’s judgement, I think it should generally be fine. In an ideal world, every package we needed would be maintained by Manjaro but that’s not possible. Onward & upward…


Try also ‘cleanup’.

pacman -Sc && pamac clean --build-files && paccache -rvuk0 && paru --clean && flatpak uninstall --unused && sudo journalctl --vacuum-time=3h && sudo journalctl --flush --rotate 

Read it, understand and edit it before you use it. It’s a nice way to clear out old journalctl errors too.

1 Like

Acutally was the only solution for me too. Thanks

Yeah I mentioned this in my original reply/post as a temporary workaround, but I’d like to know how to truly fix this issue (or if its an upstream bug from whoever is maintaining the packages…).