[Stable Update] 2023-01-24 - Kernels, Plasma, Frameworks, Gear, Libreoffice, Mesa, Nvidia, Deepin

Virtualbox refused to update because the AUR package virtualbox-ext-oracle is pinning the old version. You can resolve it by removing the AUR package before pacman -Syu and re-install it later.

mkinitcpio complained the consolefont, ter-124n not found. This can be solved by installing terminus-font from the main repo.

or by modifying the PKGBUILD and building manually.



A post was split to a new topic: Can’t start Steam anymore

A post was split to a new topic: DisplayPort issues

2 posts were split to a new topic: Doom and Doom Eternal in Steam freeze


When I rapidly move the firefox window towards the side of the screen (so that the window uses the left half for example), X11 get killed :

[118810.972] (EE) 
[118810.972] (EE) Backtrace:
[118810.972] (EE) 0: /usr/lib/Xorg (WriteToClient+0x3ed) [0x55fc9c12857d]
[118810.973] (EE) 1: /usr/lib/libc.so.6 (__sigaction+0x50) [0x7fca689329e0]
[118810.973] (EE) 2: /usr/lib/libc.so.6 (pthread_key_delete+0x14c) [0x7fca6898264c]
[118810.973] (EE) 3: /usr/lib/libc.so.6 (gsignal+0x18) [0x7fca68932938]
[118810.973] (EE) 4: /usr/lib/libc.so.6 (abort+0xd7) [0x7fca6891c53d]
[118810.974] (EE) unw_get_proc_name failed: no unwind info found [-10]
[118810.974] (EE) 5: /usr/lib/libc.so.6 (?+0x0) [0x7fca6891c45c]
[118810.974] (EE) 6: /usr/lib/libc.so.6 (__assert_fail+0x46) [0x7fca6892b486]
[118810.974] (EE) 7: /usr/lib/dri/iris_dri.so (nouveau_drm_screen_create+0xa16ab0) [0x7fca66c79810]
[118810.974] (EE) 8: /usr/lib/dri/iris_dri.so (nouveau_drm_screen_create+0x7477b9) [0x7fca669aa519]
[118810.974] (EE) 9: /usr/lib/dri/iris_dri.so (nouveau_drm_screen_create+0x75b6a1) [0x7fca669be401]
[118810.975] (EE) 10: /usr/lib/dri/iris_dri.so (__driDriverGetExtensions_d3d12+0x61bf98) [0x7fca65ef4808]
[118810.975] (EE) 11: /usr/lib/dri/iris_dri.so (__driDriverGetExtensions_d3d12+0x7d7f3) [0x7fca65956063]
[118810.975] (EE) 12: /usr/lib/dri/iris_dri.so (__driDriverGetExtensions_d3d12+0x67879) [0x7fca659400e9]
[118810.975] (EE) 13: /usr/lib/dri/iris_dri.so (__driDriverGetExtensions_d3d12+0x6e839) [0x7fca659470a9]
[118810.975] (EE) 14: /usr/lib/dri/iris_dri.so (__driDriverGetExtensions_d3d12+0x6f10e) [0x7fca6594797e]
[118810.975] (EE) 15: /usr/lib/xorg/modules/libglamoregl.so (glamor_name_from_pixmap+0xb3bb) [0x7fca67c1ccdb]
[118810.975] (EE) 16: /usr/lib/xorg/modules/libglamoregl.so (glamor_change_window_attributes+0x4a41) [0x7fca67c22c91]
[118810.975] (EE) 17: /usr/lib/xorg/modules/libglamoregl.so (glamor_set_pixmap_texture+0x95) [0x7fca67c09d55]
[118810.976] (EE) 18: /usr/lib/xorg/modules/libglamoregl.so (glamor_egl_create_textured_pixmap_from_gbm_bo+0x16c) [0x7fca67c09f4c]
[118810.976] (EE) 19: /usr/lib/xorg/modules/libglamoregl.so (glamor_back_pixmap_from_fd+0x11e) [0x7fca67c0a16e]
[118810.976] (EE) 20: /usr/lib/xorg/modules/libglamoregl.so (glamor_pixmap_from_fds+0xe2) [0x7fca67c0a4c2]
[118810.976] (EE) 21: /usr/lib/Xorg (ProcessCommandLine+0x2830) [0x55fc9c12c090]
[118810.976] (EE) 22: /usr/lib/Xorg (dri3_screen_init+0x44fe) [0x55fc9c133a1e]
[118810.976] (EE) 23: /usr/lib/Xorg (SProcXkbDispatch+0x28b8) [0x55fc9c00ff1f]
[118810.976] (EE) 24: /usr/lib/libc.so.6 (__libc_init_first+0x90) [0x7fca6891d290]
[118810.977] (EE) 25: /usr/lib/libc.so.6 (__libc_start_main+0x8a) [0x7fca6891d34a]
[118810.977] (EE) 26: /usr/lib/Xorg (_start+0x25) [0x55fc9c010315]
[118810.977] (EE) 
[118810.977] (EE) 
Fatal server error:
[118810.977] (EE) Caught signal 6 (Aborted). Server aborting
[118810.977] (EE) 
[118810.977] (EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
[118810.977] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[118810.977] (EE) 
[118810.977] (II) AIGLX: Suspending AIGLX clients for VT switch
[118811.065] (EE) Server terminated with error (1). Closing log file. du code ici

Sorry of for not being more precise but the game was running fine before the update. So I probably had all the requirements, It does need the Steam Proton experimental version though. There was a new mesa package with this update but that include a Vulkan one too? Please, how do I make a report ? Tx

Ryzen 5600, Gigabyte Rx570 (Amd)

Let me add my story:

After the update, the sound was gone.
I was scared, but luckily I was able to roll back (thanks to my scripts GitHub - hrotkogabor/manjaro-btrfs: Script collection to set up Manjaro with btrfs, and easy rollback.).

Later I had enough time to fix.

Looks like some lame changes was the problem:

$ pactl info
pactl: symbol lookup error: /usr/lib/libsndfile.so.1: undefined symbol: lame_encode_buffer_interleaved_int

For some reason, it is loaded from /usr/local/lib64

$ ldd /usr/lib/libsndfile.so.1.0.35 
        linux-vdso.so.1 (0x00007ffdaabf7000)
        libm.so.6 => /usr/lib/libm.so.6 (0x00007f91cfc43000)
        libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0x00007f91cfb93000)
        libFLAC.so.12 => /usr/lib/libFLAC.so.12 (0x00007f91cfb4b000)
        libopus.so.0 => /usr/lib/libopus.so.0 (0x00007f91cfaeb000)
        libmpg123.so.0 => /usr/lib/libmpg123.so.0 (0x00007f91cfa8b000)
******  libmp3lame.so.0 => /usr/local/lib64/libmp3lame.so.0 (0x00007f91cf600000)
        libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x00007f91cfa5b000)
        libogg.so.0 => /usr/lib/libogg.so.0 (0x00007f91cfa4b000)
        libc.so.6 => /usr/lib/libc.so.6 (0x00007f91cf413000)
        /usr/lib64/ld-linux-x86-64.so.2 (0x00007f91cfdfb000)

There were a config to preload the library path:

$ cat /etc/ld.so.conf.d/ng-xim.conf 

But it was not installed with the package manager

$ pacman -Qo /usr/local/lib64/libmp3lame.so.0
hiba: Egyik csomag sem tartalmazza a következőt: /usr/local/lib64/libmp3lame.so.0
$ pacman -Qo /etc/ld.so.conf.d/ng-xim.conf
hiba: Egyik csomag sem tartalmazza a következőt: /etc/ld.so.conf.d/ng-xim.conf

I found that I “installed” a program (ng-xim) by hand years ago, unzipped from an “installation” archive.

When I deleted all the files belongs to this program, the sound is working fine after the upgrade.

btrfs-assistant GUI can do that for you, it uses snapper with the default layout or custom layout

It is available in Manjaro repo.

On my ThinkPad T14 (AMD Ryzen 7 PRO 4750U with Radeon Graphics; 5.15.89-1) hibernation stopped working properly after this update. It occurs in both cases: when I close the lid and when I select hibernation from the menu. In the latter case, I see that the screen goes black first. After a few seconds, keyboard light and the screen background light turn on (the screen remains empty) and they stay on. There is no reaction to any keys or key combinations. The only way to get out is to do a hard reboot. I did not find any relevant information in the log files.

My system is running Plasma + X11 + Nvidia (driver: nvidia) and I ran into both of these issues too; I fixed the obs-studio one with sudo downgrade obs-studio (29.0.0-1 => 28.1.2-2) and I fixed the vlc one with sudo downgrade libva (2.17.0-1 => 2.16.0-1).

I don’t claim to really know what’s going on, I followed some links here, learned how to downgrade and downgraded various things until I pinpointed that those two downgrades were the ones that fixed things for me.

For completeness, here’s the terminal output from when vlc was crashing:

$ vlc myvideo.mp4
VLC media player 3.0.18 Vetinari (revision 3.0.13-8-g41878ff4f2)  
[0000559535118550] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.  
[00007fe1d8007420] gl gl: Initialized libplacebo v5.229.0 (API v229)  
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)  
[00007fe1d8007420] glconv_vaapi_x11 gl error: vaInitialize: unknown libva error  
zsh: segmentation fault (core dumped)  vlc myvideo.mp4

And here it is after the successful downgrade:

terminal output
$ vlc myvideo.mp4
VLC media player 3.0.18 Vetinari (revision 3.0.13-8-g41878ff4f2)  
[000056433858a550] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.  
[00007fe46c007420] gl gl: Initialized libplacebo v5.229.0 (API v229)  
[00007fe46c007420] glconv_vaapi_x11 gl error: vaCreateSurfaces: attribute not supported  
[00007fe470047480] main video output error: video output creation failed  
[00007fe478c1a140] main decoder error: failed to create video output  
[00007fe46c6abb60] gl gl: Initialized libplacebo v5.229.0 (API v229)  
[00007fe478c1a140] avcodec decoder: Using NVIDIA VDPAU Driver Shared Library  525.85.05  Sat Jan 14 00:38:30 UTC 2023 for hardware decoding  
uint DBusMenuExporterDBus::GetLayout(int, int, const QStringList&, DBusMenuLayoutItem&): Condition failed: menu

When obs-studio was crashing, I ran coredumpctl debug obs and found a stacktrace, here’s the important bit afaik:

stack trace
      Message: Process 10011 (obs) of user 1000 dumped core.  
               Stack trace of thread 10011:  
               #0  0x00007f7684b258c4 XDisplayString (libX11.so.6 + 0x2b8c4)  
               #1  0x00007f7658b37a1d __vaDriverInit_1_13 (nvidia_drv_video.so + 0xda1d)  
               #2  0x00007f7684c6d9c3 n/a (libva.so.2 + 0x39c3)  
               #3  0x00007f7684c70cd0 vaInitialize (libva.so.2 + 0x6cd0)  
               #4  0x00007f7658c28b76 vaapi_open_device (obs-ffmpeg.so + 0x16b76)  
               #5  0x00007f7658c29124 vaapi_device_h264_supported (obs-ffmpeg.so + 0x17124)  
               #6  0x00007f7658c291f9 vaapi_get_h264_default_device (obs-ffmpeg.so + 0x171f9)  
               #7  0x00007f7658c25384 obs_module_load (obs-ffmpeg.so + 0x13384)  
               #8  0x00007f76925fb64e obs_init_module (libobs.so.0 + 0x5164e)  

When I did
sudo pacman -Syu
there was only 0.2MB worth of updates for some reason. When I accepted the update it began it’s usual process. A few seconds later, the terminal asked me if I want to replace a font (I don’t remember the name of the font package) with another font. As soon as this question appeared in the terminal the whole computer began jittering like crazy. The mouse pointer was only moving at about 3 pixels per second and eventually after about 10 seconds, the mouse vanished completely. Maybe 30 seconds later, the mouse reappeared but was still jittering and I couldn’t do anything. I couldn’t do anything else so I force shut down the PC by holding down the power button.

After turning the PC back on and attempting to update the system again, I now after entering sudo pacman -Syu, get the message
“error: failed to synchronize all databases (unable to lock database)”

I don’t know what this means or what to do to fix this and update the system.

Please use the search function about the locked database.

sudo rm /var/lib/pacman/db.lck

1 Like

Oh - I just found this out today - can’t open any Database or documents, it crashes and offers recovery but can’t open anything.

Flatpak fixed that for now.

Thanks. It’s been a day and I just tried to perform the upgrade again and I didn’t have the locked database issue any more.

But how is removing the file db.lck a search function? If that’s not what you meant, why would I remove that file? I can see db probably stands for database and lck probably stands for lock, but why would removing it help the issue?

You find good answers in:


(Wisdom lies in reading :wink: )


:mag: lock database

After this update, I noticed that with Manjaro Gnome the power profile gets reset to Power Saver after some delay. I want it to stay at Balanced, but it gets flipped back. It doesn’t seem to require idle time, and it sure doesn’t require locking the desktop. There’s also Performance option, but it immediately jumps to Power Saver.

I’m running Lenovo X1 Carbon with 12th gen Intel i7 CPU. I have checked all the settings Gnome has to offer, everything seems to be in order there… Any suggestions?

Edit: This makes my laptop grind down to a halt during video conversations, for obvious reasons…

thanks for this it fixed my issue

HALO Infinite stopped working on my system after working flawlessly last release…
i already submitted a bug report