[Stable Update] 2022-12-20 - Kernels, XFCE 4.18, KDE Frameworks, Kde Gear, Mesa, Plasma-Mobile, Thunderbird, Firefox

Hibernation is no longer working after this update…wonder if anyone is having similar issues?

Pacman GUI, only shows updates when i use pamac update -a in the Terminal. When i dont use that command, its telling me that no updates found and that im up to date.

After updating Manjaro tonight to the latest bits, I get this notification every time I use ALT+TAB in KDE: “The Window Switcher installation is broken, resources are missing. Contact your distribution about this.”

just to check, you are using integrated graphics, right?

No, nothing. Tried a remove / reboot / re-install. Same result.

Had the same issue. Somehow, even if the switch “Search for updates” is set and a fixed time intervall is set, it would not search for the updates. After refreshing the database, it found all the updates.
Try this the next time (update databases) in the pacman GUI:

1 Like

This has been “solved”, but read below!!

First reboot after the update of my KDE flavor got me to the login, after that I had a mouse cursor and a totally black screen. I waited for a long time tried to go to a terminal (also a black screen), returning to the ‘desktop’ gave me nothing, also no cursor anymore. I waited a while until I rebooted.

Now after the BIOS there is sometimes a short one-liner flashed to the screen for like one frame. I am still trying to capture it with a camera. After that: Nothing. Black, no cursor.

I am trying to download a new image, but apparently manjaro.org is down.

This really weird thing happened, but only on my laptop. The desktop is still blacked out:

By the way: Witchcraft happened: I let the laptop unattended for about three hours - turned on, ready to do something but children came into the planning… Well. I last saw it about an hour ago, still the same, black screen. Now it showed the graphical log-in. The only difference is that the battery apparently has run down to 20% in between. (Not plugged in for some reason)

I really would like to find out what has happened in between! Any ideas what to look for?

I am on kernel 6.0.14-1, by the way. If anyone will give me some command to run for information I will happily provide that, if not, I probably just won’t find the time these days to dig myself.

(My other machine is still on a black screen.)

This is really, really bad. I’m scared to reboot!

In hindsight two things have happened:

Machine number one:

  • No Grub, nothing. Restoring the MBR and grub did allow for one bootprocess, ending in a black screen, no TTY, nothing after graphical login. Each time. Restore MBR, restore Grub, boot, login, black screen.

This was solved by: Going to kernel 5.15. Cleaning up space on the system partition, which was down to 0 byte at some point. (This cannot really have been the main issue, there was space at first, but apparently some updates did fill the system at some point. In my opinion pacman/pamac should be very much more aware of low disk space…)

The system is back for now, I am scared to use a different kernel…

Machine number two

  • No idea. It did show the grub menu, but did not accept any input. It went straght to black screen with a curser, blinking in a non-regular, repeating pattern. I could not switch to a TTY, input (any key) changed the blinking pattern to another one, no other input did anything else. I tried a lot of things, mainly to get grub to accept any input, all without any success. The machine was unattended for about three hours, sitting with a blinking cursor on a black screen. Sometime between two and three hours the machine must have “healed itself”. I looked at the screen after three hours, it showed a graphical login and behaves like nothing happened. It boots, suspends, comes back etc. Updates ran through, kernel was and is 6.0.15.

The second machine scares me. I have no idea what had happened, I missed the chance to look at the logs (I rebooted before trying…).

systemd, with version 252 changes behaviour in suspend-then-hibernate.
Now the system suspends and then hibernates only if battery drops below 5%, so the setting HibernateDelaySec= in /etc/systemd/sleep.conf is somehow ignored.

See: suspend-then-hibernate: add option to force early hibernate · Issue #25269 · systemd/systemd · GitHub

1 Like


I’ve read the git lab posts you linked and I do have in pamac the option to upgrade the pacman-mirrors the msys2 version from AUR, which is a conflict with the original mirrors.

Do I replace pacman-mirrors with manjaro-mirrors or wait until the issue is resolved and the package is deleted ?? msys2 wrote he added prefix to the package name msys2-pacman-mirrors.


EDIT The package is renamed AUR (en) - msys2-pacman-mirrors, but the old one is still not deleted

Yes, I’m using the integrated graphics. I don’t own a dedicated gfx card. I have to say, though, that I am using a fairly standard KDE setup without any effects, custom themes or the like. I only use a few apps (browser, office, printing, scanning, sw development, music, videos, but no gaming) and like to keep my system setup clean and simple. I uninstall stuff I don’t use. For example, all the apps I use are 64bit, so I removed all 32bit libs. I switched to Wayland half a year ago and more recently moved from PulseAudio to PipeWire. Soon, I’ll try to uninstall X11, because all my apps run native on Wayland.
I only use one monitor, albeit a big 40" one, connected via DP with 3840x2160@60hz. So I’me not affected by the KDE multi-monitor issues that have been reported very recently as mostly fixed in Plasma 5.27 here and in Nate’s blog.

So far, knock on wood, I’ve never had any KDE related stability issues. Sure, every once in a while I encounter a bug or even a crash in an application, but I guess this happens with most/all OSs and applications.
I am also not plagued by any issues some manjaro users are complaining about, which are causing them to hold back on KDE updates. This might be either due to my simple HW setup or the lack of custom configurations, which are a big source of errors and problems.

Resolved the issue by deleting the config file. Now it starts and works.

EDIT: Fixed it by me self.

“Tweaks” → “Legacy Applications” was empty after the update.
Choosed adw-dark and it’s back to normal.

I use dark mode all the time.
After the update i got a strange mix of both.

How to fix this?

Do you even see the process if you check in the System Monitor or when issuing the command:

ps -A | grep smb4k

Thanks for your comments. Whether or not I may have some configuration more complex than yours, this looks as a severe kernel regression since the system is OK with 6.0 and KO with 6.1…

I resolved the problem by deleting the config file. It now works.

1 Like

What is going on here?

First off, (22/12/22) told to remove pacman-mirrors and install manjaro-mirrors, okay done,
Then today an update for manjaro-mirrors, okay done.
And just now told to remove manjaro-mirrors and install pacman-mirrors???, done it anyway.

Please someone on the Manjaro team tell us what’s going on here!

Spaming Coredumps AppImageLauncher on 2 PC’s

kernel: traps: appimagelaunche[2221] general protection fault ip:7efc688bf4d4 sp:7ffeb8934db8 error:0 in libstdc++.so.6.0.30[7efc68899000+116000]
audit: type=1701 audit(1671748682.704:315): auid=1000 uid=1000 gid=1001 ses=2 subj=unconfined pid=2221 comm="appimagelaunche" exe="/usr/bin/appimagelauncherd" sig=11 res=1
systemd-coredump[2239]: Process 2221 (appimagelaunche) of user 1000 dumped core.
                                                     #1  0x000056524d297e71 n/a (appimagelauncherd + 0x16e71)
                                                     #2  0x000056524d29164a n/a (appimagelauncherd + 0x1064a)
                                                     #15 0x000056524d28c0e1 n/a (appimagelauncherd + 0xb0e1)
                                                     #18 0x000056524d28cb55 n/a (appimagelauncherd + 0xbb55)
1 Like

Okay, it looks like my computer isn’t supplying the password when it tries to connect. I’m not sure if it’s being saved or not–when I go into network settings, there’s no password, but that may be normal. If I connect and wait long enough, I’ll get a password prompt, supply the wifi password and then connect successfully.

Thanks for solution, lts kernel it works!
LTS kernel solve freeze issue, but it bring back an issue related to sound:
Sound disappear when I pause the stream and I can repair only when I switch of sound profile and on again.

1 Like