[Stable Update] 2022-11-14 - Kernels, GNOME 43.1, Plasma 5.26.3, Systemd 251.8, Firefox 106.0.5, Thunderbird, LXQt

After recent update, my quick menu looks ugly, icons are too big, and also the calendar widget looks too big. Can anyone help me figure out what’s the problem?
My screen resolution is 1920x1080
I already tried rename ~/.local/share and ~/.config and ~/.cache . Nothing helped. After reboot I think the system was reset, however, the icon/widget size are still too big. Also, checked the Display->Scale setting. It’s set to 100%
I have ‘user themes’ gome extension. It’s set to default. If I switch to gnome classic, the quick menu looks much better, but it’s light themed, regardless the dark mode is on. Maybe missing some deps?

1 Like

I’ve created some fresh ISOs with this update included. Those who want to start fresh can try those: Release 202211150747 · manjaro/release-review · GitHub Gnome users may want to downgrade to mesa 22.1.7 to get Calamares displayed properly when trying on Virtual Machines: Calamares renderes Black on Gnome 43.1 when using Administrator Mode (polkit/sudo) · Issue #2074 · calamares/calamares · GitHub

after update, paperWM focus mode not work on gnome43, someone try to downgrade to gnome42, still not work

After the update, both browsers (Firefox and Chrome) stopped being able to find my microphone. It sometimes works again after restarting the browsers. It (sometimes?) stops working after going to sleep (closing the laptop lid). I don’t know the exact cause that triggers this issue.

How to reproduce:

  1. Go to some website that uses the microphone (e.g. Zoom, Slack, mictests, etc.).
  2. Try using the microphone. It doesn’t work. The browser can’t find any microphone.

I’m using KDE/Plasma on X11 and pipewire. I’m sometimes connecting a bluetooth headphone. Still, when this bug happens, the browser fails to find even the built-in laptop microphone.

I initially thought the issue was related only to Chrome, so I opened issue 1383943. But now I see both browsers have issues.

maybe try standalone applications, instead webpages.

i have no experience with Zoom, Slack etc. but discord as sample you can use on a website or download the application. Or use mumble to get sure its a browser problem or something else.

On my Laptop i can no longer connect with my VPN after this stable update. I installed first openssl-1.1 and after the same error i also installed lib32-openssl-1.1 packages as you suggested. I also restarted my system after the install but no success.

The Eddie OpenVPN Client still use the newest OpenSSL 3.0.7 that is installed and refused the connection. On my second PC with the older (not updated) Manjaro (Open SSL 1.1 ) still works without problems.

How can i fix this issue with the newest stable release? Do i have to uninstall OpenSSL 3.0?

This is the logfile from my (not updated) PC where the VPN still works:

. 2022.11.15 11:31:20 - Eddie version: 2.21.8 / linux_x64, System: Linux, Name: Manjaro Linux, Version: Linux koboldx-z170 5.15.76-1-MANJARO #1 SMP PREEMPT Sat Oct 29 14:22:16 UTC 2022 x86_64 GNU/Linux, Mono/.Net: 6.12.0 (makepkg/ed0788bf61f Sun Apr 24 04:25:18 PM UTC 2022); Framework: v4.0.30319
. 2022.11.15 11:31:20 - Command line arguments (2): path.resources="/usr/share/eddie-ui" path.exec="/usr/bin/eddie-ui"
. 2022.11.15 11:31:20 - Raise system privileges
. 2022.11.15 11:31:25 - Reading options from /home/koboldx/.config/eddie/default.profile
. 2022.11.15 11:31:26 - OpenVPN - Version: 2.5.7 - OpenSSL 1.1.1q  5 Jul 2022, LZO 2.10 (/usr/bin/openvpn)
. 2022.11.15 11:31:26 - SSH - Version: OpenSSH_9.1p1, OpenSSL 1.1.1q  5 Jul 2022 (/usr/bin/ssh)
. 2022.11.15 11:31:26 - SSL - Version: Initializing (/usr/bin/stunnel)
. 2022.11.15 11:31:26 - curl - Version: 7.86.0 (/usr/bin/curl)
! 2022.11.15 11:31:26 - Activation of Network Lock - Linux iptables
I 2022.11.15 11:31:27 - Ready
. 2022.11.15 11:31:27 - Collect information about AirVPN completed

This is the logfile from my (updated) Laptop where the VPN no longer works:

. 2022.11.15 11:43:56 - Eddie version: 2.21.8 / linux_x64, System: Linux, Name: Manjaro Linux, Version: Linux koboldx-tuxedopulse15 5.15.78-1-MANJARO #1 SMP PREEMPT Thu Nov 10 20:50:09 UTC 2022 x86_64 GNU/Linux, Mono/.Net: 6.12.0 (makepkg/ed0788bf61f Sun Apr 24 04:25:18 PM UTC 2022); Framework: v4.0.30319
. 2022.11.15 11:43:56 - Command line arguments (2): path.resources="/usr/share/eddie-ui" path.exec="/usr/bin/eddie-ui"
. 2022.11.15 11:43:56 - Raise system privileges
. 2022.11.15 11:44:02 - Reading options from /home/koboldx/.config/eddie/default.profile
. 2022.11.15 11:44:03 - OpenVPN - Version: 2.5.8 - OpenSSL 3.0.7 1 Nov 2022, LZO 2.10 (/usr/bin/openvpn)
. 2022.11.15 11:44:03 - SSH - Version: OpenSSH_9.1p1, OpenSSL 3.0.7 1 Nov 2022 (/usr/bin/ssh)
. 2022.11.15 11:44:03 - SSL - Version: Initializing (/usr/bin/stunnel)
. 2022.11.15 11:44:03 - curl - Version: 7.86.0 (/usr/bin/curl)
! 2022.11.15 11:44:03 - Activation of Network Lock - Linux iptables
I 2022.11.15 11:44:04 - Ready
. 2022.11.15 11:44:05 - Collect information about AirVPN completed

Here is the actual error that i copy&pasted from the logfile:

. 2022.11.15 12:02:42 - OpenVPN > OpenVPN 2.5.8 [git:makepkg/0357ceb877687faa+] x86_64-pc-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Nov  1 2022
. 2022.11.15 12:02:42 - OpenVPN > library versions: OpenSSL 3.0.7 1 Nov 2022, LZO 2.10
. 2022.11.15 12:02:42 - OpenVPN > OpenSSL: error:0A00018E:SSL routines::ca md too weak
. 2022.11.15 12:02:42 - OpenVPN > Cannot load inline certificate file
. 2022.11.15 12:02:42 - OpenVPN > Exiting due to fatal error
! 2022.11.15 12:02:42 - Disconnecting

Update failing due to keyring problem. Not a huge deal for me, since next month im gonna do a fresh install with kernel 6.1 lts i supose, so dont bother much with me lol… Im not much of a programmer, please go gentle:

yesterday 14/11/22 ive tried ‘sudo pacman -Syu’, it started by updating the arch linux keyring or something. Today it fails to download the update by terminal or pamac app. Ive tried syyu, downloading manjaro keyring, and the comands ive found in the forum (sudo pacman-mirrors --continent and pacman --query --info manjaro-keyring or something). Im able to provide more info if needed.
*UPDATE ive solved the issue using timeshift lol

Ah I get it now.
Your keyslot uses Whirlpool AF hash which needs /usr/lib/ossl-modules/legacy.so in order to be unlocked on boot, and that has been worked around by Arch maintainers with adding it explicitly to /usr/lib/initcpio/install/{sd-}encrypt with this:

I suggested you to switch over to sha256 hash btw so you could be sure if that was the reason why you have this issue.

Anyway, the culprit here is poor integration with Plymouth which hasn’t been updated the way encrypt and sd-encrypt hooks were, i.e. it’s plymouth-encrypt hook has no instructions on adding ossl-modules/legacy.so to the initrd, you can check it now with say, lsinitcpio /boot/initramfs-5.15-x86_64.img |grep legacy.so (assuming your kernel is 5.15, amend accordingly), and the output should be empty. But that’s what you use as encrypting hook in your mkinitcpio.conf instead of encrypt, because you use Plymouth. So what you can do (3 ways):

  1. Switch away from Whirlpool hashing
  2. Switch over to regular encrypt hook without Plymouth support
  3. Edit plymouth-encrypt hook manually in a way that the above 2 hooks were modified by Arch people.

Pinging @Yochanan to let him know that our Plymouth package might need slight adjustments… :upside_down_face:

Shame on me, I always forget about the fact that Plymouth has its own encrypting hook and it often could be out of sync with everything else, but I use it too and sometimes experience weird hiccups as well.

1 Like

"There was an error extracting ‘manjaro-gnome-22.0-221115-linux519.iso.zip’
not an archive"


@Riquez: download .zip and .z01 files. You must use the following command line: 7z x *.z01
You will have the iso file after that and then you can check checksum.

@ManjaroTeam: Thanks to give Gnome 43.x. I’m come back to Gnome because I’ve got many issue with KDE. I’m also using Manjaro Cinnamon who is very good too. :slightly_smiling_face:

After updating, Duplicati started returning the error Failed: EVP_MD_size assembly:<unknown assembly> type:<unknown type> member:(null). This thread on the duplicati forum clued me into it being openSSL-related.

I installed openssl-1.1 and restarted Duplicati, this fixed the error.

I get Using GtkSettings:gtk-application-prefer-dark-theme with libadwaita is unsupported. Please use AdwStyleManager:color-scheme instead when opening nautilus from the terminal (within Awesome WM). The icons and colors are screwed up.

Seems to be a configuration issue in ~/.config/gtk-4.0/settings.ini. I copied my settings from the gtk3 configuration to gtk4, which seems to work (with some warnings).

The latest update broke my OpenVPN connection. I tried a few setting changes that worked in Kubuntu 22.10 but no luck. So I rolled back to the previous version of OpenVPN and my connection was restored successfully.

Below is the proper way to restore back OpenVPN to the previous version (2.5.7):

# remove openvpn and networkmanager-openvpn
sudo pacman -R openvpn networkmanager-openvpn

# install openssl-1.1. This won't override openssl-3.0
sudo pacman -S openssl-1.1

# download and install openvpn-2.5.7
cd ~/Downloads
wget https://archive.archlinux.org/packages/o/openvpn/openvpn-2.5.7-1-x86_64.pkg.tar.zst
sudo pacman -U ./openvpn-2.5.7-1-x86_64.pkg.tar.zst

# install networkmanager-openvpn
sudo pacman -S networkmanager-openvpn

To mask openvpn package from upgrading:

sudo nano /etc/pacman.conf

Uncomment IgnorePkg and add openvpn:

IgnorePkg   = openvpn

Save the change.


hmm, i tried that but it gave an iso which properties says is a plain text doc size 0 bytes.

7z x '/home/rico/Downloads/manjaro-gnome-22.0-221115-linux519.iso.z01'
the zip is is also in the same location (Downloads)


Screenshot from 2022-11-15 14-30-51

It seems this issue is related to having a browser open before putting the laptop to sleep. Then later waking up the laptop, then later connecting bluetooth headphones. And possibly related to the automatic profile switching (from A2DP to HSF/HFP) from when the browser requests the default microphone. Somehow, this combination leads to the browser being unable to get the microphones anymore, until the browser is restarted.

I don’t have Zoom, Slack, Discord or any of those installed as applications. (And I believe under the hood they’re just browsers.)

On my machine KeePassXC stopped respecting a dark theme. If I downgrade it back to 2.7.1, it gets back to being dark again; if I upgrade it to 2.7.4, it goes to being white.

Can anyone confirm that it happens on their system too?


7z x '/home/rico/Downloads/manjaro-gnome-22.0-221115-linux519.iso.zip'

the first file .zip not .z01.

Also try closing file manager, then re-open file manage and see if its still 0 bytes, some times file managers fail to update/refresh the window.

Thank you, thank you, thank you!!!

For me, the most favorable choice will be the plymouth magic
on the one hand for the fun factor and to fit my use case.
On the other hand I had tried to use the one char key previously for testing,
which had used sha256, however it has not worked either as I had mentioned before
(but the digest is pbkdf2 and using whirlpool soooo… who knows).

yepp the command, (

lsinitcpio /boot/initramfs-5.15-x86_64.img |grep legacy.so

) you have mentioned, gives back empty output indeed

I will write again as soon as I get results.

well the masterkey’s digest itself is made with whirlpool,
and I have no idea, how to change that without luksFormat :-((

(I have read the dm also. Thank you as well!)

tried, same result.
I also rebooted & copied the resulting iso file to a USB drive - it really is a 0 byte file. :thinking:
downloading both files again …

oh, perhaps this is why!

Igor Pavlov - 2012-03-19

7-Zip doesn’t support .z01 multi-volume ZIP archives.

Finally wow
zip -F manjaro-gnome-22.0-221115-linux519.iso.zip --out mg22.zip

My bad it should have been

7z e filename

and not 7z x filename
And yes 7z now supports multi-volume.