[Stable Update] 2022-11-02 - Kernel, Plasma 5.26.2, Plasma Mobile Gear 22.09, LibreOffice, Virtualbox 7.0.2, Systemd, Mesa

I updated my desktop system from a command line environment using pamac upgrade --force-refresh --no-aur, there was only brave-bin to update from the AUR.

On trying to boot the system with the updated kernel 6.0.6-1 the following message was displayed:

[FAILED] Failed to start **Load Kernel Modules**.

and the system failed to boot.
Correction: I discovered the system does boot, but no graphical environment, I am able to switch to a command line environment with Ctrl+Alt+F1…F6.

After Ctrl+Alt+Del to reboot the system I was able to boot to a normally running system with the 5.15 kernel. Running pamac upgrade --force-refresh displayed a warning message:

Warning: linux60-nvidia-390xx: local (390.154-3) is newer than extra (390.154-2)

which may be a clue to the above [FAILED] message?

I have yet to do an in depth search of the internet where I may find a solution to the problem though any hints are welcome in the meantime.

so everyhting is working on the 5.15 kernel?
maybe the nvidia drivers dont work properly on the 6.0 kernel…
were you on testing/unstable branch?

Appears to be so far, though I have not been using it for long. I am on the Stable branch, I am not so advanced as to risk or need testing/unstable.

I’ve yet to find out.

there are issues with the 470xx drivers on kernel 6.0, so it could be the case also for the 390 version… since you are on stable, this indicates, that there was a downgrade:

you can ‘fix’ it with:
sudo pacman -Syuu

1 Like

Switched to pipewire because Desktop-Audio was not working w/ Pulseaudio on obs-studio

Unfortunately running that command, which did downgrade the driver, has not helped :frowning:

Note I have added a correction to my original message, that I discovered the system does boot and I am able to switch to a command line environment.

lib32-polkit is now a AUR Package.

Is it safe to uninstall?

pacman -Qi lib32-polkit
Name            : lib32-polkit
Version         : 121-1
Description     : Application development toolkit for controlling system-wide privileges
Architecture    : x86_64
URL             : https://gitlab.freedesktop.org/polkit/polkit
Licenses        : LGPL
Groups          : None
Provides        : libpolkit-agent-1.so=0-32  libpolkit-gobject-1.so=0-32
Depends On      : lib32-expat  lib32-glib2  lib32-pam  lib32-systemd  polkit
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 175,22 KiB
Packager        : Jan Alexander Steffens (heftig) <heftig@archlinux.org>
Build Date      : Di 12 Jul 2022 18:12:27 CEST
Install Date    : Mi 20 Jul 2022 16:25:02 CEST
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

Why wouldn’t it be?


I wanted to double check first, befor i uninstall it.
Im also wondering, why its not mentioned on the First Posting, like this:

Anyways thanks for your quick response :slight_smile:


Edit: Audio working again after full shutdown and power up instead of reboot.

Pulseaudio no longer recognising bluetooth speakers/headphones after the latest update. I can connect them and bluetooth recognises them as headphones but they are not available in the audio settings.

LibreOffice issue appears to be fixed, my work around is no longer necessary.

The latest version of VirtualBox ignored my out of band hacks. This isn’t a problem with the upgrade, more a problem for my hack which attempts to force a square peg into a round hole. Where I make VBox act as if it’s in Full screen mode.

My KWin shortcut for moving to the next desktop virtual desktops (KDE) doesn’t loop around to the first anymore.

I fixed it by finding a presumably new option called “Navigation wraps around” in Workspace behaviour → Virtual Desktops → Navigation wraps around.

1 Like

cryptsetup seems to have dissappeared from my laptop after the this update. Now I am stuck in failover shell.

After the update my installed snap applications (Spotify and Discord) wont start anymore. Spotify gives me the following error, when trying to start it via terminal:

/snap/spotify/60/usr/bin/spotify: error while loading shared libraries: /snap/spotify/60/usr/lib/x86_64-linux-gnu/libthai.so.0: ELF file's phentsize not the expected size

While I was able to change the Discord-client to the version on “Official Repositories (community)” there’s currently no such alternative for Spotify (or at least I can’t find it).
Also all snap functionality seems to be removed from the “Add/Remove Software” application, even after reinstalling snapd, snapd-glib and libpamac-snap-plugin.
Have I missed an announcement that snap was removed from Manjaro or something like that?

Edit: After installing an update of snapd-glib (1.63-2.0 built 2022.11.04 21:55:19 CET) I’m displayed another error when trying to launch Spotify via terminal:

chmod: chmod: no version information available (required by chmod)
chmod: symbol lookup error: chmod: undefined symbol: 
/snap/spotify/60/usr/bin/spotify: /lib/x86_64-linux-gnu/libuuid.so.1: unsupported version 0 of Verdef record
/snap/spotify/60/usr/bin/spotify: error while loading shared libraries: /snap/spotify/60/gnome-platform/usr/lib/x86_64-linux-gnu/libpsl.so.5: unsupported version 0 of Verneed record

Edit 2:
After another reboot of the system the problem seems to be solved.

System info:

  • Operating System: Manjaro Linux
  • KDE Plasma Version: 5.26.2
  • KDE Frameworks Version: 5.99.0
  • Qt Version: 5.15.6
  • Kernel Version: 6.0.6-1-MANJARO (64-bit)
  • Graphics Platform: X11

As a test I installed the 5.19 kernel and the system boots and runs as normal. This implies to me that the problem, [FAILED] Failed to start Load Kernel Modules, is or related to this particular kernel version 6.0.6-1 for my desktop hardware? Earlier versions of 6 worked ok.

If that is the case then probably my best solution is to wait for the next 6.0.x kernel update.

After updating, I’m unable to login locally (XFCE). No mouse or keyboard. Unable to switch to alternate console.

I’m able to ssh in, and run “shutdown -r”. Default kernel is 5.15.76. Reboot takes a long time, complains about modprobe, system-udevd, rasdaemon, and maybe others.

Booting with fall-back kernel of 5.10 works fine thus far.

I’m out of ideas for today, but will re-visit tomorrow. At least system seems to work with older kernel.

Uninstalling rasdaemon enabled the system to run after the latest update.

This I’ve got the same problems as kippie.

When I tried to reinstall Manjaro via bootable drive, the icons are back up again. But when I’m update it’s all gone. Something the updates is causing my stuff to bad.

Any help by the way?

create a new test user, log out and log in with it, and see if it has also issues…

Minor issue where various KDE apps (Dolphin, Konsole, Kate, KSystemLog) have forgotten window size/position settings. Not a big deal but annoying all the same.

Created a test user and the icons show up. But when I hover on them, they disappear.
Tried also reverting updates via installing from the latest installer Ruach, and didn’t install the following:

No dice. I still get the same no icons problem. The font on some of my windows are also kinda funky.

I think I’m having the same problems as this guy: All desktop and menu icons missing
But I don’t have the same packages installed as his. Tried also the mhwd commands with the top answer, but nothing happens with my case. I’m using AMD radeon rx 6800 xt as graphics card. Not nvidia