[Stable Update] 2022-10-05 - Kernels, Systemd, AMDVLK, Deepin, Pamac, QEMU, Thunderbird, Firefox, 0 A.D., Gradience, Linux Firmware, WINE, GNOME, Pipewire

Hi wntr
Thanks very much, currently parsing the diffs in the gui logs. Will try CLI. Many thanks.

Update seams fine…but…
However, pamac now thinks he wants to run an update for ceph-lib from AUR.
I started it stupidly, which completely overloaded my computer, so that I could no longer switch to a console and only came out with REISUB.

What is ceph-lib needed for?

And pamac now lists steam as orphaned???


My pc crashed twice during compiling ceph-lib from AUR. I don’t know why this was needed and ended up removing it. It might be because of virtualization software that I still yet want to use.


The program “simplenote” will not launch anymore. I had to revert to the flatpak version.

8990:1005/215003.405003:FATAL:gpu_data_manager_impl_private.cc(415)] GPU process isn’t usable. Goodbye.
Trappe pour point d’arrêt et de trace (core dumped)

ok, i found it with pacman -Qi…
it’s for qemu-block-rbd…
Will check if I can remove it…


KDE Plasma
I had 354 updates. I did a pamac update and everything went smooth. How ever, there was another update after reboot. “cpeh-libs”. It is a system AUR package installed program. You have to chose a java-runtime program from the menu option. I’ve tried both 1 and 2 with no success. After a while it goes to a loop and tries several times to update but it gets stuck on line 127. After 10 minutes of trying, you get an error, and can’t update that ceph-libs program from 15.2.17-1 to 16.2.7-1.
I’m not sure if this is an important program that is required by Plasma or if it’s safe to remove the program entirely ? I have updated 3 of my computers, and they all get stuck there! Any suggestions as if it’s safe to remove it or try it at a later time?

Checking ceph-libs dependencies...
Choose a provider for java-runtime:
1:  jre-openjdk   extra
2:  jre11-openjdk  extra
3:  jre17-openjdk   extra
4:  jre8-openjdk   8.345.u01-1     extra

Enter a number (default=1):

/usr/include/c++/12.2.0/bits/stl_iterator_base_types.h:127:34: note: declared here
  127 |     struct _GLIBCXX17_DEPRECATED iterator
      |                                  ^~~~~~~~
/var/tmp/pamac-build-fred/ceph/src/ceph-16.2.7/src/include/xlist.h:186:30: warning: ‘template<class _Category, class _Tp, class _Distance, class _Pointer, class _Reference> struct std::iterator’ is deprecated [-Wdeprecated-declarations]
  186 |   class const_iterator: std::iterator<std::forward_iterator_tag, T> {
      |                              ^~~~~~~~
/usr/include/c++/12.2.0/bits/stl_iterator_base_types.h:127:34: note: declared here
  127 |     struct _GLIBCXX17_DEPRECATED iterator
  and then
  ==> ERROR: A failure occurred in build().

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

1 Like

If the following command reveals that ceph-libs is not “Required By” anything, you likely can safely remove the package ceph-libs.

pacman -Qi ceph-libs

is an old archlinux package, now is not in repos :wink: “Description : Distributed, fault-tolerant storage platform delivering object, block, and file system”

pactree -r ceph-libs

for me (now) not used and installed as a dependency (orphan), i can remove it (remove also oath-toolkit)

pacman -Rsn ceph-libs
checking dependencies...

Package (2)   Old Version  Net Change

oath-toolkit  2.6.7-1       -1.07 MiB
ceph-libs     15.2.17-1    -59.55 MiB

It says the following:
Depends On : boost-libs curl glibc keyutils libutil-linux bzip2 lz4 nss oath-toolkit python
snappy systemd-libs fmt
Also why do you think it was installed by the program if it was not needed?

pacman -Qi ceph-libs                                                                             ✔ 
Name            : ceph-libs
Version         : 15.2.17-1
Description     : Distributed, fault-tolerant storage platform delivering object, block, and file system
Architecture    : x86_64
URL             : https://ceph.com/
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : boost-libs  curl  glibc  keyutils  libutil-linux  bzip2  lz4  nss  oath-toolkit  python
                  snappy  systemd-libs  fmt
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 59.55 MiB
Packager        : Maxime Gauduin <alucryd@archlinux.org>
Build Date      : Fri 19 Aug 2022 09:36:10 AM CDT
Install Date    : Mon 12 Sep 2022 08:44:32 PM CDT
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

No ! read

Required By : None
Install Reason : Installed as a dependency for another package

is the definition of an orphan :wink:

“Depends On” : this package (ceph-libs) installs (if not installed) these packages


Looks like it’s not required by anything on your system, and can be safely removed.

KDE Plasma
Timeshift is no longer working.

open a new subjet with more infos !!! (load from terminal is alway a good idea)

My suggestion is either remove it with sudo pacman -R ceph-libs if you know you don’t need it or if you do, use the bin AUR package, ceph-libs-bin. Waaaaay faster install


qBittorrent 4.4.5-1 doesn’t launch. Getting a Segmentation fault (core dumped) error from the CLI.

EDIT: Adding log entry

12:09:56 systemd-coredum: Process 1528 (qbittorrent) of user 1000 dumped core.

Module linux-vdso.so.1 with build-id 1bec817aa8e8d6a151ba4f355252509a26f0f4b8
Module libqt6ct.so with build-id b33f2301ca6ab69c95f7b38bfb29a80a7b5944e0
Module libXfixes.so.3 with build-id 0a05c7e8714522bfbdd7c0027c3e2a94965664b0
Module libXrender.so.1 with build-id 42e386d2acf3cde61081959d9671ca74acfb3edc
Module libXcursor.so.1 with build-id f0525ae3715ac95f96a8cdb44795b03f831334b0
Module libuuid.so.1 with build-id 9057a530e6b3b0e71f24602a0039c490c9a0b5a1
Module libxcb-util.so.1 with build-id b1e4c01b388a3bd7a0a9ad384865b61f5f1d4a24
Module libxkbcommon-x11.so.0 with build-id 90654f41d9fe91c74bef6672a8b57ab34418b27a
Module libxcb-xinput.so.0 with build-id 409ee697e2b16243bf1fc6429e672f2359033388
Module libICE.so.6 with build-id a78252e65631a98d7935f1bca668c2fe1d6bbb53
Module libSM.so.6 with build-id 66cef8ae9a7848679be78dd26fd47e05110d03b5
Module libX11-xcb.so.1 with build-id f92352eae0a30aea89d11beb22367fa985288925
Module libxcb-xkb.so.1 with build-id bad7e1eb65df04a6b2d676a08f68844856edaace
Module libxcb-xfixes.so.0 with build-id e231a68d00ee4cfa12a2c31e755a9e2c1e7be450
Module libxcb-sync.so.1 with build-id 13025f6de23a271636ad321c77eda98801e62e8e
Module libxcb-shm.so.0 with build-id 828fec4d856e2710e732ea8d92c3f250c807b1c2
Module libxcb-shape.so.0 with build-id f9aab9846b5e3523bd534f8a845f36a37d42b3fa
Module libxcb-render-util.so.0 with build-id 32609134bf1b73183d07a66f6bd65c94b4542460
Module libxcb-render.so.0 with build-id b1ca498d665807ab0ccdafbe8070853efd058173
Module libxcb-randr.so.0 with build-id c914473ab7592ed5cf5c191200faaac1089c12ad
Module libxcb-keysyms.so.1 with build-id 507bdc94868b9b1f9d95e31c492694f2513da88d
Module libxcb-image.so.0 with build-id 0e6feae23e34658646dbd63d11f899c92c5d3c79
Module libxcb-icccm.so.4 with build-id 5eb9288df14c7f50af1e8db26c37e19d78bf0978
Module libQt6XcbQpa.so.6 with build-id 25b9675bdd9d2a213a39759b1eadc200aa074ea9
Module libqxcb.so with build-id b1ebe7743227f6a9051d44c34d9e9fd40aad0c55
Module libgpg-error.so.0 with build-id 4738b8a9478177c202cccd64e0eb65d3dea2bfae
Module libXdmcp.so.6 with build-id d864159ab0008415667db8d5f251696d75c90df2
Module libXau.so.6 with build-id d9d5e8277140f1a86d3a07d9b52b1703c0a2f9a8
Module libgomp.so.1 with build-id 117ab7458eb756ac0e9e4791c510ae72fe710bd5
Module liblz4.so.1 with build-id 84ea95d811dad359e94e100ebe6a746294ffe8a7
Module liblzma.so.5 with build-id d08f5868cd5adcc6b7c53bf1725aac65bd4539cd
Module libgcrypt.so.20 with build-id 8bf3cb884124273640de797a3e77d86c98434ea4
Module libcap.so.2 with build-id 9b38b08de708f439a9d0a4f8b9914151bc8d4b50
Module libicudata.so.71 with build-id 4fef196388e678deb881978139e125e20ee2d94d
Module libbrotlicommon.so.1 with build-id acfd597a977c8087bb6184383daae2e828a9ce42
Module libresolv.so.2 with build-id 2e70cfe9f2972fb13487eeefcb10e4afafed6157
Module libkeyutils.so.1 with build-id ac405ddd17be10ce538da3211415ee50c8f8df79
Module libkrb5support.so.0 with build-id 9a22a372b2157fb05da1bad94b92d9617513af81
Module libcom_err.so.2 with build-id 3360a28740ffbbd5a5c0c21d09072445908707e5
Module libk5crypto.so.3 with build-id 47d53a3ea2b172eb3db1be0ae0272c7c045267e8
Module libkrb5.so.3 with build-id 1fc969c1f54103d87e400237751b4804569a2730
Module libbz2.so.1.0 with build-id 919597c477c9b2cb9cdbb7745ed6494ac0e6da60
Module libgraphite2.so.3 with build-id ce58945ebb55b86d3a4e717b6eae29efc4720d8e
Module libpcre2-8.so.0 with build-id 917fc43d2c9f8539a3e324555c6c73886e8000a8
Module libxcb.so.1 with build-id 13d677412a71468381b11092915d231f664d18d3
Module libexpat.so.1 with build-id 52f685635e8711c1164d20a1ef8acd3840312094
Module libGLdispatch.so.0 with build-id 7879a881271650eff97c35aff7a8674859c5ae94
Module libpcre2-16.so.0 with build-id 8ad49680a3f743a5241632a400d0de30aeaa54dd
Module libb2.so.1 with build-id e39ae9514401c72c0e5cafa1abe0741360c22e87
Module libdouble-conversion.so.3 with build-id 74bfa78f70f9ae1f759f0ae383fbc7f6f7faf6f8
Module libsystemd.so.0 with build-id ef3e323faf54271c824851913c119a7767c6bff1
Module libicuuc.so.71 with build-id 633fdc0c5385d916571f6140e7a978ad0630ef55
Module libicui18n.so.71 with build-id 6fd5c97fd2808ee29958bf809656d5885e7e8963
Module libdbus-1.so.3 with build-id bceb2b7ca7e38f015d36a631a128beb06e9fb29f
Module libzstd.so.1 with build-id ab54c2881f53ab314e134f3e08c76d504376dd5d
Module libbrotlidec.so.1 with build-id 66c54e9301f7e102ecc1d88547e5f0e8a056fe22
Module libgssapi_krb5.so.2 with build-id a10eaeef6e9969e80048d247666a3af155716afc
Module ld-linux-x86-64.so.2 with build-id 075a6ad9f1c3f9cbb5f3301186bbe68c6a477808
Module libssl.so.1.1 with build-id e6b1f97a5b60b4248c49dfc5b11f53f281b507d0
Module libfreetype.so.6 with build-id f89dd5502e75aca28fb5c3ccd0dbd26fe822bfef
Module libmd4c.so.0 with build-id 2151dba72cdc9960097e6e960a58a2f03c8bb96e
Module libharfbuzz.so.0 with build-id 0083e085bcb9cb3869e5cb05fbcd9736c41434ab
Module libpng16.so.16 with build-id 14d3b3cc9d61ec1b7c1f86bdf108218a99364945
Module libOpenGL.so.0 with build-id 3df533822644f44fa89abdb75b9f89220dfdee56
Module libGLX.so.0 with build-id d2c37fb8ec3bc53c67c013b0c6ac63ec086c8883
Module libxkbcommon.so.0 with build-id 6cf66eead3fcc20fe5df10162bfbcdcdc8b2a183
Module libglib-2.0.so.0 with build-id 3ef8f9239c93af698703b12c5c6738fe0129eaa7
Module libX11.so.6 with build-id 21e886e968772b7964d646f54c1faecc56734de9
Module libfontconfig.so.1 with build-id 36be6951b8c1e42a7dd05684a37400fc8ef9147c
Module libEGL.so.1 with build-id 14389538015bb4a3a44e794e2466e31bf0834209
Module libc.so.6 with build-id 90b9e4f641f8752292698389f241cbf0ff49d687
Module libgcc_s.so.1 with build-id 85db482c4585a328d95ec41124337a967bb24d8f
Module libm.so.6 with build-id 2c8ff1d29b255da5b7371efd5caf57444d622838
Module libstdc++.so.6 with build-id 735a3d0cc7699fd69337361cba4aedb644b2a7ed
Module libQt6Core.so.6 with build-id 58691aace71818944994ca8feaf835e774031d59
Module libQt6DBus.so.6 with build-id cd5a01c0313f99f4d1009205cddccff5d860bd6c
Module libQt6Xml.so.6 with build-id 31ad96da392be42a2061335c4f538ec2490854f5
Module libQt6Sql.so.6 with build-id d3c415257965c14eea6d3213a7f3d466461c9d6b
Module libQt6Network.so.6 with build-id 0428be8cf2a7e5d36a8af6f011b3c4fe8cd62267
Module libcrypto.so.1.1 with build-id 7981ea3d69f3c28e46ee312a815af96eab93775c
Module libtorrent-rasterbar.so.2.0 with build-id 5c8111961cc39ec6c60958c08937c87ba115dd0e
Module libz.so.1 with build-id fefe3219a96d682ec98fcfb78866b8594298b5a2
Module libQt6Gui.so.6 with build-id fc60e808c0e0f8caef00cfdb1f0feae4b6702759
Module libQt6Widgets.so.6 with build-id fb5fb1f09b6a1ddefd2c330d68dc538a75bbfa91
Module qbittorrent with build-id 67db50024241435d7cd6d2bb2d43b49452cb6e2b
Stack trace of thread 1528:
#0  0x00007f32ea78547c _ZNK5QFonteqERKS_ (libQt6Gui.so.6 + 0x38547c)
#1  0x00007f32ea78586e _ZNK5QFontneERKS_ (libQt6Gui.so.6 + 0x38586e)
#2  0x00007f32ea5a40a2 _ZN15QGuiApplication7setFontERK5QFont (libQt6Gui.so.6 + 0x1a40a2)
#3  0x00007f32e51f997d n/a (libqt6ct.so + 0xb97d)
#4  0x00007f32e51f9f2a n/a (libqt6ct.so + 0xbf2a)
#5  0x00007f32ea5cfd0d _ZN21QPlatformThemeFactory6createERK7QStringS2_ (libQt6Gui.so.6 + 0x1cfd0d)
#6  0x00007f32ea5960b0 _ZN22QGuiApplicationPrivate25createPlatformIntegrationEv (libQt6Gui.so.6 + 0x1960b0)
#7  0x00007f32ea597bc9 _ZN22QGuiApplicationPrivate21createEventDispatcherEv (libQt6Gui.so.6 + 0x197bc9)
#8  0x00007f32e932f28c _ZN23QCoreApplicationPrivate4initEv (libQt6Core.so.6 + 0x12f28c)
#9  0x00007f32ea597c51 _ZN22QGuiApplicationPrivate4initEv (libQt6Gui.so.6 + 0x197c51)
#10 0x00007f32ead6cade _ZN19QApplicationPrivate4initEv (libQt6Widgets.so.6 + 0x16cade)
#11 0x000055b4f6d2ed85 n/a (qbittorrent + 0xcbd85)
#12 0x000055b4f6d22634 n/a (qbittorrent + 0xbf634)
#13 0x00007f32e8c3d290 n/a (libc.so.6 + 0x23290)
#14 0x00007f32e8c3d34a __libc_start_main (libc.so.6 + 0x2334a)
#15 0x000055b4f6d2a805 n/a (qbittorrent + 0xc7805)

Stack trace of thread 1574:
#0  0x00007f32e8d14e5f __poll (libc.so.6 + 0xfae5f)
#1  0x00007f32e7f8a20b n/a (libxcb.so.1 + 0xd20b)
#2  0x00007f32e7f8bccd xcb_wait_for_event (libxcb.so.1 + 0xeccd)
#3  0x00007f32e5df93b2 n/a (libQt6XcbQpa.so.6 + 0x4e3b2)
#4  0x00007f32e9485dd1 n/a (libQt6Core.so.6 + 0x285dd1)
#5  0x00007f32e8ca074d n/a (libc.so.6 + 0x8674d)
#6  0x00007f32e8d22700 n/a (libc.so.6 + 0x108700)
ELF object binary architecture: AMD x86-64

EDIT 2: After looking for solutions, it seems there’s a bug in qt6 or something. I’ve switched to qbittorrent-qt5 from the AUR based on what I’ve read here and it works.

1 Like

Found radically different gui logs on Timeshift from my earlier post. Tried to parse these without much success. Decided to reinstall timeshift which I did, rebooted (2nd reboot after the update), started a backup and was watching timeshift when it crashed, both the main and progress windows…what is interesting is that rsync is still running in the process table. When I ask for process details its parent is timeshift. I also see disk activity on both the source and destination drives for the backup. Got to be a GUI problem I would guess as wntr kindly suggested so… what also is a PITA is that so far the updates havent shown up in the GUI although I have tried a couple of updates and the destination drive is a lot more full than it was. Not much help but my experience. Regards

Had exactly the same issue hangs at line 127 and eats all of the memory. Found this thing in my orphan files and deleted without incident.

:information_source: An update for plasma-settings and kirigami-addons will be along shortly. You will need to manually update kirigami-addons from 1:0.3-1 to 0.4-1.

EDIT: No one probably has either application installed as only kclock and ktrip depend on them.

For people wondering why they suddenly need to build ceph-libs from the AUR:



Updated with no issues.