[Stable Update] 2022-10-05 - Kernels, Systemd, AMDVLK, Deepin, Pamac, QEMU, Thunderbird, Firefox, 0 A.D., Gradience, Linux Firmware, WINE, GNOME, Pipewire

Hey everyone, after updating timeshift can’t save backup. Approximately 30% does and closes. A copy of exactly RSYNS. Kernel 5.19, BTRFS

1 Like

I got a black screen after updating and booting to the latest stable.
After searching the web it seems like a lot of people with nvidia 30x0 series cards and using HDMI have the same issues with driver 515.76, display port users seems to be unaffected. Downgrading the drivers seems to solve the issue. A known workaround that worked for me is to disconnect the HDMI cable, boot the OS up to the login prompt, and then connect the cable again… hilarious =)

1 Like

OBS 28 crashes Gnome on Wayland, tried 2 PCs.

I run X11 in Plasma, it doesn’t run in Wayland at all. I also tested the window capture, it does not capture the window until you refresh it, for example, by launching a new tab
Here is a short video

Conflict between manjaro-pulse and pipewire-jack. Had to remove manjaro-pulse as it was not needed by anything.

sudo pacman -R manjaro-pulse

Similar or same problem as Angel2035. Before update did a Timeshift backup (manually) for a most recent backup. After the update read angel2035’s post. Told Timeshift to make another manual backup, it started and then quit without writing anything to the backup drive. I see where I ran the backup in the Timeshift gui.log but no errors there and no backup. log. I back up every day automatically and have both a gui.log and backup.log for each successful backup. Kernel 5.15.71-1 Stable Manjo KDE Plasma desktop. EXT4 FS.

Since my original post I have been examining the gui.log for the pre update backup and the post update backup attempt which was unsuccessful. Rather than taking up space here could the mods please open a new thread for this Timeshift problem and I will share the gui.log diffs and hopefully find out how to rectify for myself, Angel2035 and any other user that experiences this…thanks…


for me, error with locale-info package

(260/260) checking for file conflicts                                                         [######################################################] 100%
error: failed to commit transaction (conflicting files)
glibc: /usr/share/i18n/SUPPORTED exists in filesystem (owned by locale-info)
Errors occurred, no packages were upgraded.

ok with pacman -Syu --overwrite "/usr/share/i18n/" or best remove this package
old manjaro package removed in repos

My fellow KDE denizens. How did this one fare? :pleading_face:


All good here with Wayland on a Ryzen APU.


Probably a glib issue, cli seems to work.

Hi wntr
Thanks very much, currently parsing the diffs in the gui logs. Will try CLI. Many thanks.

Update seams fine…but…
However, pamac now thinks he wants to run an update for ceph-lib from AUR.
I started it stupidly, which completely overloaded my computer, so that I could no longer switch to a console and only came out with REISUB.

What is ceph-lib needed for?

And pamac now lists steam as orphaned???


My pc crashed twice during compiling ceph-lib from AUR. I don’t know why this was needed and ended up removing it. It might be because of virtualization software that I still yet want to use.


The program “simplenote” will not launch anymore. I had to revert to the flatpak version.

8990:1005/215003.405003:FATAL:gpu_data_manager_impl_private.cc(415)] GPU process isn’t usable. Goodbye.
Trappe pour point d’arrêt et de trace (core dumped)

ok, i found it with pacman -Qi…
it’s for qemu-block-rbd…
Will check if I can remove it…


KDE Plasma
I had 354 updates. I did a pamac update and everything went smooth. How ever, there was another update after reboot. “cpeh-libs”. It is a system AUR package installed program. You have to chose a java-runtime program from the menu option. I’ve tried both 1 and 2 with no success. After a while it goes to a loop and tries several times to update but it gets stuck on line 127. After 10 minutes of trying, you get an error, and can’t update that ceph-libs program from 15.2.17-1 to 16.2.7-1.
I’m not sure if this is an important program that is required by Plasma or if it’s safe to remove the program entirely ? I have updated 3 of my computers, and they all get stuck there! Any suggestions as if it’s safe to remove it or try it at a later time?

Checking ceph-libs dependencies...
Choose a provider for java-runtime:
1:  jre-openjdk   extra
2:  jre11-openjdk  extra
3:  jre17-openjdk   extra
4:  jre8-openjdk   8.345.u01-1     extra

Enter a number (default=1):

/usr/include/c++/12.2.0/bits/stl_iterator_base_types.h:127:34: note: declared here
  127 |     struct _GLIBCXX17_DEPRECATED iterator
      |                                  ^~~~~~~~
/var/tmp/pamac-build-fred/ceph/src/ceph-16.2.7/src/include/xlist.h:186:30: warning: ‘template<class _Category, class _Tp, class _Distance, class _Pointer, class _Reference> struct std::iterator’ is deprecated [-Wdeprecated-declarations]
  186 |   class const_iterator: std::iterator<std::forward_iterator_tag, T> {
      |                              ^~~~~~~~
/usr/include/c++/12.2.0/bits/stl_iterator_base_types.h:127:34: note: declared here
  127 |     struct _GLIBCXX17_DEPRECATED iterator
  and then
  ==> ERROR: A failure occurred in build().

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

1 Like

If the following command reveals that ceph-libs is not “Required By” anything, you likely can safely remove the package ceph-libs.

pacman -Qi ceph-libs

is an old archlinux package, now is not in repos :wink: “Description : Distributed, fault-tolerant storage platform delivering object, block, and file system”

pactree -r ceph-libs

for me (now) not used and installed as a dependency (orphan), i can remove it (remove also oath-toolkit)

pacman -Rsn ceph-libs
checking dependencies...

Package (2)   Old Version  Net Change

oath-toolkit  2.6.7-1       -1.07 MiB
ceph-libs     15.2.17-1    -59.55 MiB

It says the following:
Depends On : boost-libs curl glibc keyutils libutil-linux bzip2 lz4 nss oath-toolkit python
snappy systemd-libs fmt
Also why do you think it was installed by the program if it was not needed?

pacman -Qi ceph-libs                                                                             ✔ 
Name            : ceph-libs
Version         : 15.2.17-1
Description     : Distributed, fault-tolerant storage platform delivering object, block, and file system
Architecture    : x86_64
URL             : https://ceph.com/
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : boost-libs  curl  glibc  keyutils  libutil-linux  bzip2  lz4  nss  oath-toolkit  python
                  snappy  systemd-libs  fmt
Optional Deps   : None
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 59.55 MiB
Packager        : Maxime Gauduin <alucryd@archlinux.org>
Build Date      : Fri 19 Aug 2022 09:36:10 AM CDT
Install Date    : Mon 12 Sep 2022 08:44:32 PM CDT
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

No ! read

Required By : None
Install Reason : Installed as a dependency for another package

is the definition of an orphan :wink:

“Depends On” : this package (ceph-libs) installs (if not installed) these packages