[Stable Update] 2022-09-12 - Kernels, LibreOffice, KDE Gear, KDE Frameworks, Firefox, Thunderbird, Pipewire, Mesa

Yes, that is possible.

same for me.

also plank uses huge ram it was using only 50-100 MB before update

OMG, not again!!!

Can I freeze Plasma on 5.24 someway?

5 Likes

I think it was renamed from steam-manjaro to steam.

KDE doesn’t have “bugs”. They have “transitional features” that are perpetually being “worked on”, but never actually properly implemented. :smirk:

( If you’re reading this: Hi, Nate! :wave: )


“KDE! We’ll fix it one day… some year… maybe… oh whatever. Here’s a new feature that no one asked for! ENJOY!”

8 Likes

At first I was scared when pamac told me “to install: libmalcontent” :scream:
but then I found out it is some kind of parental control stuff used in gnome.
https://gitlab.freedesktop.org/pwithnall/malcontent
Who comes up with names like that?

2 Likes

Unfortunately with the latest stable update my PC is no longer waking from sleep properly. The screens stay black and I need to perform a manual reset. May need to roll the OS back to continue using it.

I’ve updated everything except the plasma packages. All seems to work fine. For now I will stay with version 5.24

2 Likes

The update had several errors for me, including breaking the bridged network configuration I was using to run my machine on br0 for better VM support. I don’t know what the update did to networking, but ‘ip a’ normally shows me 3 interfaces (lo, enp7s0 and br0). But after the update I had 8 interfaces. Why? The update took a very long time compared to all the other updates I’ve ran in the past two years, coming in at 41 minutes. The failed electron16 update took most of the time, see below. Also:

Install DKMS modules                                                                                                                                                                                   
==> ERROR: Missing 5.18.19-3-MANJARO kernel headers for module v4l2loopback/0.12.5.

I’ve been getting this error for at least a few updates, I’m not sure why and I haven’t needed to fix it yet.

Cloning brave-bin build files...
Running as unit: run-u66.service
fatal: not a git repository (or any parent up to mount point /var/cache/private)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
Finished with result: exit-code
Main processes terminated with: code=exited/status=128

Brave updated successfully after I updated my system with pacman -Syu first and then pamac for AUR. I got four fatal: not a git repository messages for various packages in total.

________ running 'cipd ensure -log-level error -root /var/cache/private/pamac/electron16/src -ensure-file /tmp/tmpwy79w8vb.ensure' in '.'
CIPD selfupdate failed. Trying to bootstrap the CIPD client from scratch...
[P27196 22:28:55.372 client.go:308 W] RPC failed transiently. Will retry in 8m32s {"error":"rpc error: code = Internal desc = prpc: when sending request: Post \"https://chrome-infra-packages.appspot.com/prpc/cipd.Repository/ResolveVersion\": dial tcp: lookup chrome-infra-packages.appspot.com on [::1]:53: read udp [::1]:41517->[::1]:53: read: connection refused", "host":"chrome-infra-packages.appspot.com", "method":"ResolveVersion", "service":"cipd.Repository", "sleepTime":"8m32s"}
Error: prpc: when sending request: Post "https://chrome-infra-packages.appspot.com/prpc/cipd.Repository/ResolveVersion": dial tcp: lookup chrome-infra-packages.appspot.com on [::1]:53: read udp [::1]:36245->[::1]:53: read: connection refused.

This error repeated itself, retrying over and over and doubling the time between attempts (1s, 2s, 4s, 8s …) until it finally gave up after wasting 17 minutes (1023 seconds). I removed electron16 as I no longer needed it, so that problem is solved.

wine-ge-custom also fails to update. I’ll have to retry it again when I have more time to get the errors for you.

My corsair mouse configuration was also somehow affected. I use ckb-next as a driver and I had to reset the DPI from 1400 to a DPI of 3000 to have the same mouse acceleration speed.

==> ERROR: A failure occurred in prepare().
    Aborting...
Finished with result: exit-code
Main processes terminated with: code=exited/status=4
Service runtime: 41min 21.622s
CPU time consumed: 30min 43.977s

That was the final exit code.

Looking at the comments in this thread, and what users are saying in other forums, and reading the KDE bugtracker, I might even consider this myself…

I don’t want to have to resort to it, but it’s not looking good.

For now, I’m going to simply skip this particular update and see if things improve in the next batch of Stable Updates.

* I’ve been bitten by too many show-stopper bugs because of KDE (one step forwards, two steps backwards), so you can understand why I’m tentative about upgrading.


* Some bugs may seem “harmless” or “only annoying” on the surface, but could in fact lead to data loss, corruption, needless CPU / hardware stress, system freezes, or lost time. It’s a matter of usage and circumstances, in which the bug is the “trigger” that knocks off the first domino.

8 Likes

After experiencing about one hundred tiny bugs with the newest KDE I decided to revert to the previous version of Manjaro via timeshift-btrfs.

I am going to reemphasize the general consensus of everybody in this thread who’s using Manjaro KDE:

You should have never pushed from an LTS version of KDE to the newest, extremely buggy one.
This is supposed to be a stable update for the stable branch of Manjaro. Why did anyone think going from stable KDE to this p-o-s was a good idea?

I know that bad things can happen with any update. But the amount of bugs the newest KDE introduces is just ridiculous. Sorry for the little rant and a little bit of rudeness. I actually love you guys and the work you do. This is why I’m asking you to:
please revert to old KDE.

15 Likes

Thunderbird doesn’t remember the screen position anymore always opens in the middle.
I prefer it on the left half of the screen. Same bug as firefox.

That is what I did too. Thankful KDE is modular.

1 Like

I have to agree!

1 Like

Hi!!
Please, could you show me where is this option located? My desktop is in Spanish so I can’t find it, probably due to translation.

Thank you so much!!

Anyone else with problem with Steam?
I don’t updated yet, scared with so many issues reported here.
I think I will wait one week to update here…

1 Like

Hi,
with the new update I’ve experienced quite a lot of annoying stuff which forced me to time shift back. Most of my keybindings in KDE stopped working. My windows could not be closed since I had disabled the title bar and used only keybindings to close them. I couldn’t change the window appearance/decorations for some reason (after clicking apply nothing would happen). The meta key stopped working as well although in the keybinding settings everything was unchanged. At this point, frustrated, I’ve time-shifted back.

How you did it?

Anyone with Manjaro KDE wanting to update BUT without the buggy new KDE Plasma:

sudo vim /etc/pacman.conf

[options]
IgnoreGroup = plasma
8 Likes

Some minor issues here:

Using Evolution Mail on KDE with Seahorse to store mail passwords. Seahorse forgot all the passwords.
The keyring was previously named “default keyring”, name appears to have changed to “kdewallet”.

Fix: had to re-enter my passwords and save them in keyring.
Side effect: it seems that entering a password to unlock the mail keyring after reboot is no longer necessary.

On KDE, mouse speed changed to slow and suddenly there was a hot corner active that was not turned on before the update.

Fix: changed settings.

Edit: “Leave” option in context-menu was also disabled.
Fix: Re-enabled option in “configure desktop and wallpaper” → “Mouse Actions” → click cogwheel next to Right-Button" and check option to add “Leave” back to context menu.