[Stable Update] 2022-09-12 - Kernels, LibreOffice, KDE Gear, KDE Frameworks, Firefox, Thunderbird, Pipewire, Mesa

I run in konsole :
sudo pacman-mirrors --continent
sudo pacman -Syy
sudo pacman -S $(pacman -Qu|grep -v "5\.25\.5"|cut -d' ' -f1| tr -t "\n" " ")

2 Likes

I had no issue with Steam. Still works like before the update for me.

Same here with seahorse and “default” keyring

:point_down:

2 Likes

Same for me.

2 Likes

after the update there are some pipewire errors:

pipewire[390]: mod.rt: Can't find xdg-portal: (null)
pipewire[390]: mod.rt: found session bus but no portal
pipewire-pulse[392]: mod.rt: Can't find xdg-portal: (null)
pipewire-pulse[392]: mod.rt: found session bus but no portal
pipewire[390]: mod.rt: RTKit error: org.freedesktop.DBus.Error.AccessDenied
pipewire[390]: mod.rt: could not make thread 423 realtime using RTKit: Permission denied

I had the plasma entry in the ignore package spot.

oops.

It’s interesting to see that most of the Manjaro KDE users report that their system is broken while the poll results tell a majority has no issues.

Maybe it’s time to break down the single poll into polls per desktop environment?

7 Likes

completely how? I can put an order :
example
" kate"
and kate autostart
And I can put scripts too and they are correct launched. the thing is not launched is everything that has more than 1 command or has enviromment variables

After switching from Linux 5.18 to 5.19 the battery indicator as well as the info given by ‘acpi’ did not update and suspending the system on closing my laptop’s lid did not work, the system just kept on running. I’m not quiet sure if this issue is specific to Manjaro, it rather looks like a Kernel issue.

Although rolling back to a supported Kerne prior to 5.19 also works around the problem, I was able to fix it with the following steps:

  1. put blacklist asus_ec_sensors in /etc/modprobe.d/asus_ec_sensors.conf
  2. run sudo mkinitcpio -p linux519
  3. Reboot the system.

Off course. Because the moderators ask the user not to report if everything is okay and leave the space for discussion and help for people who actually have an issue.

3 Likes

No issue with Steam, just the package has been renamed. It works fine after update.

Can confirm. Happens when I try to add widgets to a panel also. Repeatable, every time. Hoping there’s some solution for this.

Issue with shutdown:

Since this update, my laptop dosen´t shut down after closing the laptop. The kde energy settings are not changed. The system should shut down if the laptop is closed, but it dosen´t do it.
It looks like suspend. The mouse is working but with a black screen.
I can switch to terminal with strg+alt+F2. There I can login and shutdown or restart the system correctly.

System:
  Kernel: 5.19.7-1-MANJARO arch: x86_64 bits: 64 Desktop: KDE Plasma
    v: 5.25.5 Distro: Manjaro Linux
Machine:
  Type: Laptop System: TUXEDO product: TUXEDO Pulse 15 Gen1 v: Standard
    serial: <superuser required>
  Mobo: TUXEDO s model: PULSE1501 v: Standard serial: <superuser required>
    UEFI: American Megatrends v: N.1.07.A02 date: 12/08/2020
Battery:
  ID-1: BAT0 charge: 89.6 Wh (99.0%) condition: 90.5/91.6 Wh (98.7%)
CPU:
  Info: 8-core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 1590 min/max: 1400/2900 cores: 1: 2900 2: 1400 3: 1400
    4: 1400 5: 1400 6: 1400 7: 1400 8: 1400 9: 1400 10: 1400 11: 1452 12: 2900
    13: 1400 14: 1400 15: 1400 16: 1400
Graphics:
  Device-1: AMD Renoir driver: amdgpu v: kernel
  Device-2: Chicony HD Webcam type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: amdgpu
    unloaded: modesetting gpu: amdgpu resolution: 1920x1080~60Hz
  OpenGL: renderer: AMD RENOIR (LLVM 14.0.6 DRM 3.47 5.19.7-1-MANJARO) v: 4.6
    Mesa 22.1.7
Audio:
  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.19.7-1-MANJARO running: yes
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.57 running: yes
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi
  IF: wlp1s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: eno1 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb
  Report: bt-adapter ID: hci0 rfk-id: 1 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 232.89 GiB used: 54.45 GiB (23.4%)
  ID-1: /dev/nvme0n1 vendor: Kingston model: SA2000M8250G size: 232.89 GiB
Partition:
  ID-1: / size: 219.81 GiB used: 54.45 GiB (24.8%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 511 MiB used: 312 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
Swap:
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p3
Sensors:
  System Temperatures: cpu: 33.4 C mobo: N/A gpu: amdgpu temp: 32.0 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 321 Uptime: 7m Memory: 7.19 GiB used: 1.75 GiB (24.4%)
  Shell: Zsh inxi: 3.3.21

Do you have a tip for me :thinking:
regards
caho

I have weird issues on KDE, this time I’ve put appearance and workspace settings back to default and then updated. After update, most of the keybindings don’t work. Windows wont close, and I can’t move them. So things just stack on top of each other. Can’t use a system like this.
Has anyone similar issues and fixes?

1 Like

I think that’s an excellent idea. I plan to vote that everything went okay - because it did. It just so happens this new KDE version introduced a bunch of bugs. Which is nothing new for KDE, and really not the fault of the stable update as a whole. They had to pull the trigger sometime to get us up to 5.25, and there appeared to be no ideal time to do it. So here we are.

1 Like

I have only one problem (using KDE Plasma). When starting Thunderbird, and intermittently while using it, it becomes very unresponsive. Clicking on a menu may take 10 seconds before anything happens, IF anything happens. I have no idea if this is KDE issue or Thunderbird issue. All I know is that I didn’t have this problem before.
Firefox and all other applications seems to work fine.

I run Manjaro KDE and I haven’t seen any bugs with this update.

7 Likes

After this update my KDE desktop system has a lot of lag with some applications, such as Thunderbird and Dolphin. There was a suggestion to:

but this seems very brutal and as @Weidenwiesel reported:

My ~/.cache/ folder is 7.8 GiB in size and I was wondering if there is a safe way to selectively remove old unused cache files? Or are there better ways to deal with the cache size problem or system lags?

The ~/.cache/ contains a lot of files with an old last modified date but they have a recent last accessed date and times.

1 Like

I have a pretty major issue here, after this update. Thinkpad L13 Yoga Gen2, after the update the cursor jumps to the left edge of the screen frequently. I suspect the linux-firmware package to be the problem, because the issue even appears in the bios menu. Deactivating the trackpoint and using the touchpad is a workaround (not practical for me though, because I cannot work with touchpads :stuck_out_tongue: ). Downgrading the linux-image package (installing the previous version from cache) didn’t have any effect. Any help is greatly appreciated!