[Stable Update] 2022-08-16 - Glibc with EAC fix, Nextcloud, KDE-git, Cinnamon, Haskell, Python

It seems that network manager cannot save or retrieve the wifi password from kwallet anymore.
Everytime I start my computer it asks me for the password again and if I check my journal I get the following warnings:

Aug 21 20:38:08 kded5[1307]: org.kde.plasma.nm.kded: Unhandled active connection state change:  1
Aug 21 20:38:34 kded5[1307]: org.kde.plasma.nm.kded: Error opening kwallet.
Aug 21 20:38:34 kded5[1307]: kf.bluezqt: PendingCall Error: "Failed to activate service 'org.bluez': timed out (service_start_timeout=25000ms)"
Aug 21 20:40:08 NetworkManager[705]: <warn>  [1661107208.9667] device (wlo1): no secrets: No agents were available for this request.
Aug 21 20:40:09 NetworkManager[705]: <warn>  [1661107209.8227] device (wlo1): Activation: failed for connection 'NETWORKNAME'

However, according to kwalletmanager, kwallet is running and and the entry for the wifi is there. so it seems there might be some issue with the communication of NetworkManager and kwallet

After this update, it seems it can’t auto mount with my NAS (network mounts) anymore…
Once my machine is started and I execute the following command sudo mount -a, the network mounts does work!

I use fstab with cifs for this, e.g.:

//serverA/Documents       /mnt/serverA/documents        cifs uid=1000,gid=1000,defaults,workgroup=WORKGROUP,credentials=/home/xtreemrage/.something,_netdev 0 0

This worked before, but maybe I have missed something?

Machine info:

OS: Manjaro Linux x86_64 
Kernel: 5.15.60-1-MANJARO 
DE: Plasma 5.24.6 
WM: KWin 
Theme: Breath2 2021 Dark [Plasma], Breath-Dark [GTK2/3] 

Also, third-party program icons are not displayed in the system tray. Like steam, discord, manjaro-settings-manager or pamac-tray.

They are hidden at screen coordinates 0:0.
Left clicking in the corner of the screen shows the context menu of the program.

Unfortunately the existing solution does not fix it.

h__s://i.ibb.co/fG6NC9k/Screenshot-20220822-143949.png

UP:
Nevermind.
Because new user there is no such issue. I just deleted ~/.config/ded5rc and now all is fine.

I believe in the last update or something changed requiring the vers= option to be specified. I have always used the vers=3.0 in my config and it has continued to work without issue.

I looked but couldn’t find the posting on the site where it was discussed what changed within the last couple of updates but, basically for your example make it something like this:

//serverA/Documents       /mnt/serverA/documents        cifs vers=3.0,uid=1000,gid=1000,defaults,workgroup=WORKGROUP,credentials=/home/xtreemrage/.something,_netdev 0 0

You can use other versions if you are connecting to an older samba server 3.0 still goes back to windows 8 so it has been around for awhile and most NAS drives, etc are should be using and will probably work in most cases. If not just try the lower versions until you find one that works. Here is a little snipit I found awhile back explaining the versions and what version of windows used them.

    vers=3.0 is SMB3 i.e. Windows 8, Windows Server 2012
    vers=2.1 is SMB2_10 i.e. Windows 7, Windows Server 2008 R2
    vers=2.0 is SMB2_02 i.e. Vista SP1, Windows Server 2008
    vers=1.0 is NT1 i.e. Windows 95, NT 4.0

Today i mentioned this:

$ sudo pamac upgrade -a
Warnung: Pakete als dynamischer Benutzer bauen
Warnung: Konfiguriere Build-Verzeichnis /var/cache/pamac
Vorbereitung...
Synchronisiere Paketdatenbanken...
Aktualisierung von extra.db...                                                                                                                              
Aktualisierung von community.db...                                                                                                                          
Aktualisierung von AUR...                                                                                                                                   
Überprüfe kde-servicemenus-rootactions Abhängigkeiten...                                                                                                    
Warnung: libcpuid: Lokale Version (0.5.1.r10.g7a580fd-1) ist neuer als community (0.5.1-2)
Abhängigkeiten werden aufgelöst...
Interne Konflikte werden überprüft...

Zu aktualisieren (1):
  inxi                          3.3.21.1-1  (3.3.20.1-1)  community  315,6 kB
Zu erstellen (1):
  kde-servicemenus-rootactions  2.9.1-2     (2.9.1-1)     AUR

Download-Größe gesamt: 315,6 kB
Gesamtgröße installiert: 5,5 kB

Somthing from KDE went to AUR?
(kde-servicemenus-rootactions)

Purge or build?

:point_down:

No, root menu items isn’t KDE - it’s a cheat :wink: but it seems okay, I upgraded yesterday and it’s fine.

1 Like

A post was split to a new topic: Kann Datenbank nicht sperren

Audio in Discord stopped working after upgrading. I’m using pipewire for audio; KDE. Audio is fine in all other software, including Steam + Proton. Rolling back (using TimeShift) fixes the issue. Deleting $HOME/.config/discord has not fixed it. I’ll follow up if I find a solution.

I found that uninstalling EasyEffects solved the issue, though this isn’t going to be a solution for anyone who regularly uses EasyEffects.

Before uninstalling EasyEffects, my system got into a state which caused other programs to lose sound as well. I found that they were always using EasyEffects as the default audio device and required switching to the real audio device each time the program started to resolve this. This didn’t seem to work with Discord, though I’d need to reinstall EasyEffects and retest to determine if the result is consistent.

Hi everyone,

I have just noticed under Manjaro Cinnamon that after this update rabbitvcs no longer works in Nemo, at least as far as Subversion is concerned. Although the Subversion context menu entries are still displayed correctly by rabbitvcs-nemo, the corresponding svn commands are apparently not executed.

Affected are rabbitvcs and rabbitvcs-nemo in version 0.18+55+ga9b4922-1. After downgrading to the previous version 0.18+40+g88d6c36-1 all Nemo context menu entries work again as expected.

Thanks in advance for diving into it. :slightly_smiling_face:

Have a nice day,
//rj

I also noticed issues I didn’t catch before. You’ll see 1:0.18+40+g88d6c36-1 coming along soon.

A post was merged into an existing topic: Lightdm not running after fresh Manjaro Cinnamon install

For the record:

In the first ~3-5 days after the update Solaar keeps reporting that my Logitech MX Master 3 has a battery of 4% despite it’s (re)charged shorter than a hour ago.

However last days it does not report that anymore despite I did not recharge that wireless mouse for days if not a whole week.

Not sure if it’s something with the kernel or not. But it’s a phenomenon to keep in mind :man_shrugging:t2:

Thanks for the information, but unfortunately it doesn’t work for me. A lot of times it will not auto mount, but sometimes it will (8 of 10 atm, it will not auto mount). So the same situation as before :frowning: .

Is your Computer connected to the Network by Wifi or Ethernet? With Wifi to find the Accesspoint can have a dellay. Then the Networkshare will not be found at Boottime. I have let it to use the cifs-tools. Just use Dolphin to setup a Network-Share.

If you like to use the cifs-tools, you can create a cronjob.

su -u
pacman -S cronie
systemctl enable cronie
crontab -e

In the crontab type in this

@reboot sleep 20 && mount -a

20 Seconds after boot it run the command mount -a

1 Like

Ethernet, it used to work all the time though, but after this update…

A post was split to a new topic: Been a long while…

Why to use that and not Libva?

Anyone else having bluetooth wakeup issues after standby? I used to have AutoEnable=yes to resolve this. Since bluez 5.65 they have AutoEnable=yes by default and suddenly bluetooth wakes up no more after standby. I have to systemd restart bluetooth to make it work again. Bluetooth is so flaky on linux. Really annoying.

4 Likes

Yes. Having to restart after wake from suspend. Small thing but my garuda install doesn’t have this problem