[Stable Update] 2022-08-07 - Kernels, Nvidia, Thunderbird, Cinnamon, Glibc, GCC, LibreOffice, Firefox, MangoHud, KDE-git

After this update & applying k 5.19 my suspend sticks on black screen when waking.
Using 5.18 it works ok.

Since k 5.11 iommu=soft has been flawless for suspend working on my AMD. But 5.19 has broken something anew.


I’m having issues with passing GPU to virtual machine
After the update calling nodedev-detach results in a crash in amdgpu_device_fini it was working before
As a workaround binding using vfio-pci.ids works (as long as you have second GPU ofc)

My card is Radeon RX 6800 XT

Same here: Firefox Coredump errors in journal
@bogdancovaciu posted about it HERE
Got rid of the Coredump errors by removing the libva-vdpau-driver.
Works for me as well.
At least a temporary workaround…

Yes, reported this as well, at this time I see no fixups here:


You can also bisect bad and good Kernel version to identify which commit causes this problem.

And it’s a good choice to use LTS Kernel.:

Suspend/hibernate does not work, or does not work consistently
There have been many reports about the screen going black without easily viewable errors or the ability to do anything when going into and coming back from suspend and/or hibernate. These problems have been seen on both laptops and desktops. This is not an official solution, but switching to an older kernel, especially the LTS-kernel, will probably fix this.


My guess it was something they did on 5.19 that was backported to 5.15 as well. That’s what happened last time with suspend and 5.17 which was backported to 5.15.

I already do. My whole reasoning for sticking with only “LTS” kernels was to avoid these types of nasty bugs. As you can see, it also affects me on 5.15.59, so I think the regression was backported. :frowning:

Nice find, I’ll take a read through it. I’m just tired of these frequent show-stopping bugs from the upstream kernels lately. Especially when they affect “LTS” kernels. When suspend is broken on a laptop, it’s a major issue. (This has happened before two previous times with an update to 5.15.x, one broke suspend, the other broken reboot/shutdown.)

EDIT: The last time an upstream kernel update broke suspend, a bunch of Arch Linux laptop users really felt it. So probably going to keep an eye peeled on the Arch Linux BBS.

1 Like

Then it’s a hardware related regression so maybe bisect 5.15.58 if this version work for you with 5.15.59

It gets awkward. Because the previous version on the Stable Updates was 5.15.57, which had a different issue in regards to shutdown/reboots.

Ironically, 5.15.59 seems to have fixed this issue (re: shutdown/reboot), but then introduced the suspend regression. I’m not even sure if it was 5.15.57 → 5.15.58 that caused this, or .58 → .59, due to the nature of the Stable Updates skipping over intermediary kernel releases.

I had same issues, I noticed that when I play an HDR video on VLC Player, the solution is to change the libva-vdpau-driver with intel-media-driver due i have an 10th gen Intel processor. If you want to known about it, you can read the Intel section of the “Hardware video acceleration” arch wiki post.


I have issue on KDE with last update and last kernel 5.19.0-2, it doesn’t find my audio card or microphone at all. Was everithing ok with last 5.19RC but the new official kernel doesn’t detect my audio. Using LTS kernel 5.15 everithing is ok.
My audio hw is this

  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Huawei
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 02:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Huawei
    driver: snd_pci_acp3x v: kernel alternate: snd_rn_pci_acp3x,snd_pci_acp5x
    pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 02:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Huawei driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 02:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.59-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes

Two systems. One has a update notification. The other does not. I updated mirrors and fast track and waited a day, but this system still has no updates indicated.

My system won’t reboot or shutdown now when using kernel 5.15 (tried 5.4 and it worked). When trying shutdown now, or just shutting down graphically, the screen turns off, and the PC keeps running with a beep sound from time to time until I do a REISUB (which fortunately works). This happens just after the update, and never happened before.

Ironically, your post describes exactly what I, and another user, went through with the previous Stable Update (with kernel 5.15.57).

Now with 5.15.59, shutting down and rebooting seems to be working properly again, except there’s a randomly occurring issue with suspend, in which it will immediately wake up from suspend. It’s about one out of every three times will it work correctly.

3 posts were split to a new topic: I keep getting a message that I should update my kernel

There seems to be a problem with Firefox, it’s dumping core each time at startup (although it DOES start). From the logs, this behavior appears to have started as far as 27 Jul 2022. Example:

systemd-coredump[7340]: [🡕] Process 7329 (firefox) of user 1000 dumped core.

Module /usr/lib/firefox/libmozsandbox.so with build-id 3a1d8ced680cedf65e163b17029445d3595fcedf
Module linux-vdso.so.1 with build-id df9e557f9a852e1ab249bb542b08b481e4404a5a
Module libGLX.so.0 with build-id 02bd4ac6acc4da9288c543ea1a0cdaa70c5e151a
Module libGLdispatch.so.0 with build-id de981c020bd9dbdc159b11f4a2a541310cc3b8d5
Module libvdpau.so.1 with build-id fccd021ff13c37ebf7144d184a3250624e086f52
Module libGL.so.1 with build-id b915a2e48be6c9fd3cc6f9f4c7aab1f7aeed8a4c
Module nvidia_drv_video.so with build-id 8976d88c463676c8a7a27a4fa06ab51a4f428200
Module libdrm.so.2 with build-id 39847bc84bc769f632f8f599a62fdcc98c9270cd
Module libva.so.2 with build-id 86d5ae6b358ba79962131649d99e42e1ba669501
Module libva-drm.so.2 with build-id 58df7fa92e899fee0c784db7a9fc68bb107156b6
Module libxcb-glx.so.0 with build-id 71d5b6691f53a235696da49ffa2178d643ecc228
Module librt.so.1 with build-id 6c2560cb8cee7be4d9571d9ba46e875b1c9070cd
Module libplds4.so with build-id 2b49ec2f43d2e5fc2e56f35bcd094968f9bf36e6
Module libX11-xcb.so.1 with build-id f92352eae0a30aea89d11beb22367fa985288925
Module libdbus-glib-1.so.2 with build-id 9b483ffff76251ff057e007a0b960bff84ce34a8
Module libnssutil3.so with build-id 36c34a5ab8de68047e7886fe56da7ccf6722f465
Module libnss3.so with build-id 87abb242025e6e243d6974b3a9da26166884533a
Module libsmime3.so with build-id e80b1eacbb0979a1355fd008847c6eef060e83e3
Module libssl3.so with build-id 94040772bf0029a13562ab6314237dc26ea29a60
Module libplc4.so with build-id 2f3f90e73b1f4fc3424689615d6d32f7427bb783
Module libasound.so.2 with build-id aefb908044b1b408df406f1a9bab9bba486c0e94
Module libxul.so with build-id 9af35b34c784db1c7e97c65c483dffee56f83d9c
Module libmozwayland.so with build-id e6a63bb7680fbce5adc6bb057d81a2cc5d51a839
Module libgpg-error.so.0 with build-id 4738b8a9478177c202cccd64e0eb65d3dea2bfae
Module liblz4.so.1 with build-id e63600ab23b2f6997f42fac2fa56e1f02ce159a1
Module libgcrypt.so.20 with build-id 8bf3cb884124273640de797a3e77d86c98434ea4
Module libcap.so.2 with build-id 1f87347b85b55db2f75a2ecea5cb45d846dc7093
Module libbrotlicommon.so.1 with build-id acfd597a977c8087bb6184383daae2e828a9ce42
Module libicudata.so.71 with build-id 4fef196388e678deb881978139e125e20ee2d94d
Module libsystemd.so.0 with build-id 761a39da56f185d6f1ef6f7bb95a3299789eb3e2
Module liblzma.so.5 with build-id 28b40c7af8098a66af6ee093b6986b91cad7694d
Module libzstd.so.1 with build-id ab54c2881f53ab314e134f3e08c76d504376dd5d
Module libXdmcp.so.6 with build-id d864159ab0008415667db8d5f251696d75c90df2
Module libXau.so.6 with build-id 60db1eac70f819bea9d4c366603c1583067510b4
Module libbrotlidec.so.1 with build-id 66c54e9301f7e102ecc1d88547e5f0e8a056fe22
Module libbz2.so.1.0 with build-id 919597c477c9b2cb9cdbb7745ed6494ac0e6da60
Module libdatrie.so.1 with build-id 6fe3b6ece2c8e7d11869fa051375128d8f808f58
Module libblkid.so.1 with build-id 140694a62d8d4d07c6c320a501f948dd1b389d73
Module libpthread.so.0 with build-id beb247374758b5c4cdc7a45b934fff02bfd90a71
Module libxml2.so.2 with build-id 8cdf00fa954d9a27f2f184c4d354cb14677446ac
Module libjson-glib-1.0.so.0 with build-id 58decebd2c409d59b07f926ae4c513281918bc4d
Module libsqlite3.so.0 with build-id 90fb9a043b4a51db25530e16cd543c4b2a9319a9
Module libicui18n.so.71 with build-id 6fd5c97fd2808ee29958bf809656d5885e7e8963
Module libicuuc.so.71 with build-id 633fdc0c5385d916571f6140e7a978ad0630ef55
Module libstemmer.so.0 with build-id 013b48e71279a5ec55e3021fc0bd8fb10a08bae5
Module libatspi.so.0 with build-id 87bca381f073faea3b0ffd1ab06f5f8f204e24cf
Module libdbus-1.so.3 with build-id 7f4b16b4b407cbae2d7118d6f99610e29a18a56a
Module libtiff.so.5 with build-id 5f020a8eb30e12c2e4012d0cb50da9480c7b5d34
Module libjpeg.so.8 with build-id 8e6d3f3e8f438912b561c43b6e7f66e6e5e097d0
Module libexpat.so.1 with build-id 113bb5a3e9ad856801bfcfc029102c9bdc13d67e
Module libpixman-1.so.0 with build-id d2170a3ac106c2a68597bf7910ab04b1cdd69c14
Module libxcb-shm.so.0 with build-id 828fec4d856e2710e732ea8d92c3f250c807b1c2
Module libxcb-render.so.0 with build-id b1ca498d665807ab0ccdafbe8070853efd058173
Module libxcb.so.1 with build-id 13d677412a71468381b11092915d231f664d18d3
Module libXrender.so.1 with build-id 42e386d2acf3cde61081959d9671ca74acfb3edc
Module libpng16.so.16 with build-id 2dc0bce07f199bf983c07a05fb95a6f4af83a9b3
Module libgraphite2.so.3 with build-id ce58945ebb55b86d3a4e717b6eae29efc4720d8e
Module libfreetype.so.6 with build-id f89dd5502e75aca28fb5c3ccd0dbd26fe822bfef
Module libthai.so.0 with build-id a7ac5010b4275c49308021200d23690533952702
Module libmount.so.1 with build-id 4436aeea0cd8c01b5a77969e0531184f8b3513ce
Module libz.so.1 with build-id fefe3219a96d682ec98fcfb78866b8594298b5a2
Module libffi.so.8 with build-id f0a9586cf0f42d2b9971bd1065ca3a6b19f4a2c2
Module libpcre.so.1 with build-id 845483dd0acba86de9f0313102bebbaf3ce52767
Module libXinerama.so.1 with build-id 8198240259261b612189e89c9fcfc902b025b382
Module libXrandr.so.2 with build-id 154e55f082ee9e685d0794c98c5b76ffe9c8868e
Module libXcomposite.so.1 with build-id 13228d108b290268d88510db494daefd5521cda0
Module libXdamage.so.1 with build-id a99dbe3fc2b01da9fbdd90d5ad00621f9022379f
Module libXcursor.so.1 with build-id f0525ae3715ac95f96a8cdb44795b03f831334b0
Module libXext.so.6 with build-id 17beadf1cb40d41ab36629db3b4eed74110678a7
Module libwayland-egl.so.1 with build-id dd02a2af320297e68308cc698f75828529271a57
Module libwayland-cursor.so.0 with build-id 46a637dbcbb02d6712a201f177377b66598b9121
Module libwayland-client.so.0 with build-id 515c72111400d7bdbfbdfcec78d597e4986a5943
Module libxkbcommon.so.0 with build-id 6cf66eead3fcc20fe5df10162bfbcdcdc8b2a183
Module libXfixes.so.3 with build-id 0a05c7e8714522bfbdd7c0027c3e2a94965664b0
Module libtracker-sparql-3.0.so.0 with build-id eb5972c9f0b0292b8a7053255db5245c07669a88
Module libcloudproviders.so.0 with build-id ed1d9c9e60be4e858ad148484767249be1edf95f
Module libatk-bridge-2.0.so.0 with build-id 1161ebbcc5aa791075dfa026671875e5417287bd
Module libX11.so.6 with build-id 21e886e968772b7964d646f54c1faecc56734de9
Module libXi.so.6 with build-id 16603be937a02a7e61b0b0395d064be7efd86f49
Module libepoxy.so.0 with build-id edc178a150c4255d124e1e1ecbdbecebd1a388cd
Module libatk-1.0.so.0 with build-id c2de8b4fcbd9681cef225fe3956a9608a2a664bb
Module libgdk_pixbuf-2.0.so.0 with build-id 5b8422ab971b1a8a8e1c43b88738d4ee217f609e
Module libcairo-gobject.so.2 with build-id 9927090dddfb180365695a8f37d1cac89463f109
Module libfribidi.so.0 with build-id fe9f35ac2a0074108c8306c517793f7279bd9b37
Module libfontconfig.so.1 with build-id 36be6951b8c1e42a7dd05684a37400fc8ef9147c
Module libpangoft2-1.0.so.0 with build-id 1d293edcbaefc8c1b024f83d0935e88e6f09dfcb
Module libcairo.so.2 with build-id a222d042e56108d2786ece7bf291b56ba2069591
Module libharfbuzz.so.0 with build-id 236ab65053439e673a39fcb7aadedb28b17a338a
Module libpango-1.0.so.0 with build-id b358a862a5ca8b1e4e69235edce1780e9f860a0a
Module libpangocairo-1.0.so.0 with build-id e7a2a9e56f2e2f6121d9c5741b3e93871b673cfa
Module libgio-2.0.so.0 with build-id 7a769ec24a9a705d04ee0297730032f70ed0835b
Module libgobject-2.0.so.0 with build-id a7515bd8cd51064d187953c0f506a43958de31a6
Module libglib-2.0.so.0 with build-id 1340f3a762b2293ebf6d725edf0eb14839f85317
Module libgmodule-2.0.so.0 with build-id abd986222e2cf12fc7324cb0182dfc2c8f2269c0
Module libgdk-3.so.0 with build-id 4a9a6d5ddd18f22c56c05773208f8808cefacab6
Module libgtk-3.so.0 with build-id 48baf44dfd4d51f8c2b81d852eb44de692c16b19
Module libmozgtk.so with build-id 26604d3ee49807c520a93ea0c3c5eb922461b4d3
Module libmozsqlite3.so with build-id f30a1c9ed67d10972f70aa61ad057cac93fc3731
Module liblgpllibs.so with build-id fba0112e20d9aba6ae106c3ba4c1215d8630c609
Module libnspr4.so with build-id e54087b0e38cf8936f6c458e922589406343b05d
Module ld-linux-x86-64.so.2 with build-id 8dac9e5903543a5f8a5f7339139c14444b9b4e0e
Module libc.so.6 with build-id e637217a46491314667a7a37b2155cb07afc1a40
Module libgcc_s.so.1 with build-id 308aed8b7d7e38f5efa23f75c25601668c1fc009
Module libm.so.6 with build-id 598f2cb2b61d6ba52686c3d0d380daea7e55e97c
Module libstdc++.so.6 with build-id e0dd3ec5b0a62b122b4141c956c0b33a4d719144
Module firefox with build-id c522c1d7c484fdad1ef9c7206e61bca61ce4dc98
Stack trace of thread 7329:
#0  0x00007f5840ce5814 XDisplayString (libX11.so.6 + 0x2b814)
#1  0x00007f583f92ba1d __vaDriverInit_1_13 (nvidia_drv_video.so + 0xda1d)
#2  0x00007f5833cc3c8a n/a (libva.so.2 + 0x3c8a)
#3  0x00007f5833cc9be1 vaInitialize (libva.so.2 + 0x9be1)
#4  0x00007f583c52a367 n/a (libxul.so + 0x852a367)
#5  0x00007f583c52af79 n/a (libxul.so + 0x852af79)
#6  0x00007f583851f37e n/a (libxul.so + 0x451f37e)
#7  0x00007f583851d185 n/a (libxul.so + 0x451d185)
#8  0x00007f5838510425 n/a (libxul.so + 0x4510425)
#9  0x00007f583850f6ed n/a (libxul.so + 0x450f6ed)
#10 0x000055667da0c032 n/a (firefox + 0x4e032)
#11 0x00007f5842a3f2d0 n/a (libc.so.6 + 0x232d0)
#12 0x00007f5842a3f38a __libc_start_main (libc.so.6 + 0x2338a)
#13 0x000055667da1b7f5 _start (firefox + 0x5d7f5)
ELF object binary architecture: AMD x86-64

smb shares smb:// not working since update !?


    /run/user/1000/kio-fuse-dlubAF/smb/fritz.box.kio-discovery-wsd  loading   cd /run/user/1000/kio-fuse-dlubAF/remote                                                                                                  INT ✘ 
    /run/user/1000/kio-fuse-dlubAF/remote                                                                                                                                                                                    ✔ 
 cd /run/user/1000/kio-fuse-dlubAF/smb/dreambox.local                                                                                                                                                                                
    /run/user/1000/kio-fuse-dlubAF/remote   cd /run/user/1000/kio-fuse-dlubAF/smb/dreambox.local                                                                                                                         INT ✘ 
    /run/user/1000/kio-fuse-dlubAF/smb/dreambox.local 

I’d rethink/revert that decidion and remove them.

This might help you:

you can try to build 5.15.60-rc1 and test if your issue still exist, maybe next stable update will have 5.15.61

thank you, i read and it works with smb://IP

I have the same issue with 5.15.59 where suspend doesn’t work.

1 Like