[Stable Update] 2022-08-07 - Kernels, Nvidia, Thunderbird, Cinnamon, Glibc, GCC, LibreOffice, Firefox, MangoHud, KDE-git

with kernel 5.19.0-2 the leds showing microphone and audio disabled not working
5.18 and 5.15 they hare fine for it

Since last Stable im still experience Firefox Coredumb errors.

1 Like

Yes, kernel 5.19 has the same problem as 5.18 with scratching sound sound on AMD Ellesmere HDMI Audio Radeon RX 590. Noise starting sound on AMD Ellesmere HDMI Audio Radeon RX 590.

Fortunately, kernel 5.15 does not have that problem.

1 Like

Can this glibc issue be added to the list of known issues in the Known issues and solutions? I am also affected by this issue and can’t play some games. I always look at this list of known issues for serious issues before updating.

@thingsiplay having EAC broken by a core package update is not critical for us as a distro. However, for those who are affected I’ve added the flatpak workaround and mentioned the patched glibc packages we don’t recommend to install officially.

having issue with wifi usb adapter TP-LINK TL-WN821N after this kernel update. In fact all my network devices disappeared after update and running inxi -N returns “No PCI device data found.” message.

was able to get it working by installing rtl8192eu-git drivers package. Previously it was working on rtl8192eu package itself but its not a case anymore.

My update has no problem, but I suddenly got two orphaned packages:


Not sure what to do with them. I assigned them as explicit but don’t know where did they come from.

This update broke gcc/g++:

-- The CXX compiler identification is GNU 12.1.1
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - failed
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ - broken
CMake Error at /usr/share/cmake/Modules/CMakeTestCXXCompiler.cmake:62 (message):
  The C++ compiler


  is not able to compile a simple test program.

  It fails with the following output:

    Change Dir: /home/ave/Documents/oss/wors_tracer/build/CMakeFiles/CMakeTmp
    Run Build Command(s):/usr/bin/ninja cmTC_6166d && [1/2] Building CXX object CMakeFiles/cmTC_6166d.dir/testCXXCompiler.cxx.o
    [2/2] Linking CXX executable cmTC_6166d
    FAILED: cmTC_6166d 
    : && /usr/bin/c++   CMakeFiles/cmTC_6166d.dir/testCXXCompiler.cxx.o -o cmTC_6166d   && :
    /usr/bin/ld: /usr/lib/libm.so.6: unknown type [0x13] section `.relr.dyn'
    /usr/bin/ld: skipping incompatible /usr/lib/libm.so.6 when searching for /usr/lib/libm.so.6
    /usr/bin/ld: cannot find /usr/lib/libm.so.6
    /usr/bin/ld: /usr/lib/libm.so.6: unknown type [0x13] section `.relr.dyn'
    /usr/bin/ld: skipping incompatible /usr/lib/libm.so.6 when searching for /usr/lib/libm.so.6
    /usr/bin/ld: /usr/lib/libmvec.so.1: unknown type [0x13] section `.relr.dyn'
    /usr/bin/ld: skipping incompatible /usr/lib/libmvec.so.1 when searching for /usr/lib/libmvec.so.1
    /usr/bin/ld: cannot find /usr/lib/libmvec.so.1
    /usr/bin/ld: /usr/lib/libmvec.so.1: unknown type [0x13] section `.relr.dyn'
    /usr/bin/ld: skipping incompatible /usr/lib/libmvec.so.1 when searching for /usr/lib/libmvec.so.1
    collect2: error: ld returned 1 exit status
    ninja: build stopped: subcommand failed.

Or is the issue deeper than I can see?

❯ pacman -F /usr/lib/libm.so.6
usr/lib/libm.so.6 is owned by core/glibc 2.35-6

❯ pacman -Qi glibc
Name            : glibc
Version         : 2.36-1

So why is libm owned by an old glibc? Wasn’t it supposed to be upgraded?..

Anyways, downgrading gcc, gcc-libs, glibc and lib32-glibc, clang, llvm, llvm-libs helped. Please fix.

saddly that is right. tried 5.18 and it has the same sound problem.
i guess i go back to 5.15 and hope it does not have to much impact on gaming with proton

It’s not. -F is using own database, and you need to update it with -Fy. To query actual packages on your system you need to use -Q, in your case -Qo.

EDIT: Also you can edit the same post like I just did, and not post 10x one after another.

I always update with $ sudo pacman -Syuw . This only downloads and checks all packages without installing them, which I then later do from the tty.

Two packages, python-pivy and freecad, were marked as ‘marginal trust’ or corrupted, and thus asked to be removed, which I did. Re-downloading those two packages had the same result.

I tried to ‘fix’ the key problem by the old method of downloading archlinux-keyring and manjaro-keyring, and then $ sudo pacman-key --init , --populate, --refresh-keys but the latter step produced very many errors and possibly further corrupted my key database.

I then turned to the Manjaro wiki and also found the old method there but it is now scratched out. Luckily there is now a new method which worked to get my key database re-established.

The two problem packages were downloaded and checked without problems and I could proceed to tty $ sudo pacman -Su for a successful update.

1 Like

After this update & applying k 5.19 my suspend sticks on black screen when waking.
Using 5.18 it works ok.

Since k 5.11 iommu=soft has been flawless for suspend working on my AMD. But 5.19 has broken something anew.


I’m having issues with passing GPU to virtual machine
After the update calling nodedev-detach results in a crash in amdgpu_device_fini it was working before
As a workaround binding using vfio-pci.ids works (as long as you have second GPU ofc)

My card is Radeon RX 6800 XT

Same here: Firefox Coredump errors in journal
@bogdancovaciu posted about it HERE
Got rid of the Coredump errors by removing the libva-vdpau-driver.
Works for me as well.
At least a temporary workaround…

Yes, reported this as well, at this time I see no fixups here:


You can also bisect bad and good Kernel version to identify which commit causes this problem.

And it’s a good choice to use LTS Kernel.:

Suspend/hibernate does not work, or does not work consistently
There have been many reports about the screen going black without easily viewable errors or the ability to do anything when going into and coming back from suspend and/or hibernate. These problems have been seen on both laptops and desktops. This is not an official solution, but switching to an older kernel, especially the LTS-kernel, will probably fix this.


My guess it was something they did on 5.19 that was backported to 5.15 as well. That’s what happened last time with suspend and 5.17 which was backported to 5.15.

I already do. My whole reasoning for sticking with only “LTS” kernels was to avoid these types of nasty bugs. As you can see, it also affects me on 5.15.59, so I think the regression was backported. :frowning:

Nice find, I’ll take a read through it. I’m just tired of these frequent show-stopping bugs from the upstream kernels lately. Especially when they affect “LTS” kernels. When suspend is broken on a laptop, it’s a major issue. (This has happened before two previous times with an update to 5.15.x, one broke suspend, the other broken reboot/shutdown.)

EDIT: The last time an upstream kernel update broke suspend, a bunch of Arch Linux laptop users really felt it. So probably going to keep an eye peeled on the Arch Linux BBS.

1 Like

Then it’s a hardware related regression so maybe bisect 5.15.58 if this version work for you with 5.15.59

It gets awkward. Because the previous version on the Stable Updates was 5.15.57, which had a different issue in regards to shutdown/reboots.

Ironically, 5.15.59 seems to have fixed this issue (re: shutdown/reboot), but then introduced the suspend regression. I’m not even sure if it was 5.15.57 → 5.15.58 that caused this, or .58 → .59, due to the nature of the Stable Updates skipping over intermediary kernel releases.

I had same issues, I noticed that when I play an HDR video on VLC Player, the solution is to change the libva-vdpau-driver with intel-media-driver due i have an 10th gen Intel processor. If you want to known about it, you can read the Intel section of the “Hardware video acceleration” arch wiki post.


I have issue on KDE with last update and last kernel 5.19.0-2, it doesn’t find my audio card or microphone at all. Was everithing ok with last 5.19RC but the new official kernel doesn’t detect my audio. Using LTS kernel 5.15 everithing is ok.
My audio hw is this

  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Huawei
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 02:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Huawei
    driver: snd_pci_acp3x v: kernel alternate: snd_rn_pci_acp3x,snd_pci_acp5x
    pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 02:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Huawei driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 02:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.59-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes