[Stable Update] 2022-07-04 - Kernels, Firefox, Thunderbird, Nvidia 515.57, Python, Haskell

That was the first thing i checked, but unfortunately not the solution in this case.

It has. :grin:

The same thing if you run bleachbit as root/sudo.

The underlying pattern seems to be root/sudo + GTK under KDE.

However, native KDE and Qt applications are not affected. Only GTK, from what I have experienced.

My laptop shows no updates these nine hours later?!?

Try this command:

$ sudo pacman-mirrors -f5; sudo pacman -Syyu

Any update on when Plasma 5.25 may land on Stable?

1 Like

I had been using the proprietary NVIDIA driver setup recommended here and got a black screen after today’s update to nvidia driver version 515.57. A quick CTRL-ALT-F4 and reverting those changes from the cli to disable the manual driver selection fixed it. No more wayland though :disappointed:.

Please open a separate #support:graphic-cards thread for further troubleshooting.

1 Like
$ systemctl status systemd-vconsole-setup.service
× systemd-vconsole-setup.service - Setup Virtual Console
     Loaded: loaded (/usr/lib/systemd/system/systemd-vconsole-setup.service; static)
     Active: failed (Result: exit-code)
       Docs: man:systemd-vconsole-setup.service(8)
    Process: 756 ExecStart=/usr/lib/systemd/systemd-vconsole-setup (code=exited, status=1/FAILURE)
   Main PID: 756 (code=exited, status=1/FAILURE)

systemd[1]: Starting Setup Virtual Console...
systemd-vconsole-setup[775]: setfont: ERROR setfont.c:417 kfont_load_font: Unable to find file: ter-116n
systemd[1]: systemd-vconsole-setup.service: Main process exited, code=exited, status=1/FAILURE
systemd[1]: systemd-vconsole-setup.service: Failed with result 'exit-code'.
systemd[1]: Failed to start Setup Virtual Console.

$ cat /etc/vconsole.conf


sudo pacman -S terminus-font
sudo systemctl restart systemd-vconsole-setup.service
1 Like

Just found my old Chromebook with a hacked-in SEAbios. It had not been updated in 9 months (linux-firmware was 2021-10-02).

Had to manually set the date and time because it had forgotten and pamac/pacman were throwing certificate errors.

Removed some AUR packages and dkms modules it wanted to build. Upgraded 933 packages (2GB). Rebooted. Installed kernel 5.15.

Perfect. Everythings works and is up to date again. I love Linux in general en Manjaro in particular :clap:


Curious issue. After the update, the KDE print dialog does not show anymore the “driverless” printers. These are still well visible in the KDE system settings printers panel and in the print dialogs of non KDE applications. Any clue?

You may switch to unstable branch to help out with 5.25 Plasma testing. For stable we aim to ship 5.24.6 when it comes out.

Wow. Surely Bleachbit should work without being run as sudo… Isn’t that a graphical user application?

Still - useful to trim unwanted locales if you’re working with a small device with something like a 2GB SSD I imagine.

To prune redundant system files, such as locales, it requires being run as root. When run as root, it doesn’t touch any user home folder.

I see the “driverless” options for my Canon MFP printer as a network/LAN printer… no “driverless” options for local/direct connection (USB)

Not sure if the categories are new (local, network discovered, other network), but filtering/assigning the drivers to the appropriate (subjective) category might have removed it from your view if your printer is not networked?

Has this update fixed the sticky mouse issue from stable update of 2022-06-24 with files launching without being double-clicked and windows maximizing when selected?

You tell us. I’m not aware of any similar reports. Please open a #support thread for further troubleshooting.

A post was split to a new topic: File conflicts during update

So it will be a matter of months until 5.25 gets to stable? I am really looking forward to it!

1 Like

@Daniel-I, I apologize, but I may be missing background to correctly understand your answer. What are the “categories” and what do you mean by “filtering/assigning” the drivers to the category?

My printer is a network printer, and it correctly advertises its driverless printing functions. These are correctly identified by cups as soon as the cups-browsed service is enabled. For driverless printing on USB printers, you may need the ipp-usb package, but I have never tried that.

I see the printer in the Printers section of the System Settings using KDE and I can correctly print to the printer from applications like libreoffice, gimp, firefox, etc.

My problem is restricted to Qt applications that use the Qt print dialog (okular, kate, etc.), because the driverless printer does not appear in there, so it cannot be chosen as a destination for printing.

I have tested and this problem is specific to Manjaro. On an Ubuntu 22.04 system that has the same KDE plasma and kde framework version and just a slightly different Qt version (5.15.13), there is no issue and driverless printers can be used as destinations for driverless printing as they get listed in the Qt print dialog.


issue with driverless printers is not coming from the last update. I have managed checking a manjaro machine that has not yet received the last stable update and it also has the issue.

Opened a generic support request on the forum. Sorry for the noise on this thread.

2 posts were split to a new topic: Python-pycrypto conflict during update