[Stable Update] 2022-06-24 - Kernels, KDE Frameworks, Cinnamon 5.4, Qt5, Gstreamer, Haskell, Python

This update seems to have fixed a bug i have had for ages in plasma, where after booting to desktop having a second monitor connected but not turned on, the second desktop would appear on the primary monitor as an overlay until clicking on the desktop with the mouse.

Qbittorrent won’t start.
Exactly the same issue as this one

Telegram displays dark tray icon when dark plasma theme is enabled.

Solution:

sudo cp /usr/share/icons/breeze-dark/status/22/telegram* /usr/share/icons/breeze/status/22/
sudo cp /usr/share/icons/breeze-dark/status/24/telegram* /usr/share/icons/breeze/status/24/

Hi at all,
is Virtualbox now stabil running? The last update the guests did not run stabil.
I am on kernel 5.10.xx
Best regards Stefan

I have the exact same issue with each update and the issue appeared from 2-3 most recent updates:

cp: cannot create regular file '/var/tmp/pamac/dbs/sync/pamac_aur.db': Permission denied
Error: Failed to prepare transaction: target not found: anydesk-bin

The issue repeats for almost every single AUR package.

@thingsiplay mentioned he used sudo pamac update to “fix” it, but as far as I understand, sudo pamac is highly discouraged.

$ ls -lasih /var/tmp/pamac/dbs/sync/
total 53M
3465344 4.0K drwxrwxrwx 2 jazz  jazz  4.0K Jun 25 11:51 .
3465340 4.0K drwxrwxrwx 3 jazz  jazz  4.0K Jun 25 11:51 ..
3409908 7.1M -rw-r--r-- 1 root root 7.1M Jun 24 18:32 community.db
3409058  32M -rw-r--r-- 1 root root  32M Oct 23  2021 community.files
3409767 168K -rw-r--r-- 1 root root 168K Jun 24 18:18 core.db
3409196 1.8M -rw-r--r-- 1 root root 1.7M Oct 16  2021 core.files
3409824 1.9M -rw-r--r-- 1 root root 1.9M Jun 24 18:18 extra.db
3409541 9.6M -rw-r--r-- 1 root root 9.6M Oct 22  2021 extra.files
3410538 176K -rw-r--r-- 1 root root 176K Jun 24 18:18 multilib.db
3409573 260K -rw-r--r-- 1 root root 260K Oct 16  2021 multilib.files
3408375 4.0K -rw-r--r-- 1 root root 2.5K Jun 25 00:34 pamac_aur.db
3409647    0 -rw-r--r-- 1 root root    0 Jun 25 11:51 refresh_timestamp
3409733 4.0K -rw-r--r-- 1 root root 1.8K Dec 21  2021 sublime-text.db
3409735 4.0K -rw-r--r-- 1 root root  543 Dec 21  2021 sublime-text.db.sig

Just a heads up: I’m having some issues with Cinnamon DE as well.

For me it’s mainly that all display settings for multiple monitors are forgotten/reset to default. That means that monitor layout and orientation is off. Also the setting for which monitor is primary is gone.

Additionally, the Display settings dialog is no longer in the Start menu by itself. You have to open it through the general System Settings app.

So, this is all easily fixable, but annoying nonetheless. During a month I will easily connect my laptop to two dozen work/meeting room setups and all those display settings were handily remembered and automatically applied, so now I will face a couple of months of going into the display settings everytime I use a new desk or meeting room.

Update went well, as usual. A few hiccups to note:

  • A few AUR packages had to be uninstalled because of dependency conflicts, although the very same versions could be reinstalled afterwards. :person_shrugging:
  • Most notably, the first reboot and Plasma session start following the update was a lot longer than usual. That didn’t reproduce on subsequent reboot. :sleeping_bed:
1 Like

After update my keyboard (italian layout) doesn’t work as expected. the AltGr doesn’t work, and in the terminal i cannot write any characters. The locale.gen file seems correct like was before, i try to regenerate it with “sudo locale-gen”, but it doesn’t resolve the problem. Also Cinnamon complain about some applets that cannot be run and some other errors. I get back with timeshift and all return to normal. I wait some days to retry update.

If the solution in the wiki post does not work for you this post might help:
https://forum.manjaro.org/t/root-tip-troubleshooting-locale-errors/2100

Problem with Qt library, i can’t launch Ksiisen or Knetwalk : Cannot mix incompatible Qt library (5.15.4) with this library (5.15.5) Abandon (core dumped)
Which package is responsible ? I am on Cinnamon.

1 Like

Don’t know an application or package called “Ksiisen” (a typo?), but these kinds of problems usually stem from using an AUR package which needs to be recompiled. It might also happen if the manjaro maintainers forget to rebuild an official package, but that is rare. So check all the AUR packages you have installed and make sure to rebuild them.

In general, you should be able to find out which libs are incompatible by using ldd, e.g.

ldd $(which knetwalk) | grep Q

Note, that ldd will usually only show the symbolic links. To get the real library, use

ls -l /usr/lib/libQt5Xml.so.5
lrwxrwxrwx 1 root root 19 2022-06-09 19:51 /usr/lib/libQt5Xml.so.5 → libQt5Xml.so.5.15.4

Then check which package the lib with the incorrect version belongs to, e.g.

pacman -Qo /usr/lib/libQt5Xml.so.5.15.4
/usr/lib/libQt5Xml.so.5.15.4 is owned by qt5-base 5.15.4+kde+r164-1

Ok, i removed one appli running with QT4 and my KDE games are running again.

I would like to know what the issue is. To be honest, in the past I had numerous issues with Pamac in combination with the AUR, which is why I installed yay a not long ago. Would it make sense to disable the AUR support in Pamac and do all AUR stuff in yay instead? Even if I installed packages with Pamac.

After waiting a few hours, I have used the sudo command, even if it is discouraged. As there is no other fix.

Not sure. I have been through a lot of wine updates mostly without issues. Every time there is a new wine update, the config windows pop up for one time only. My windows based programs seems to run alright. I have install the game in Steam and it works there. I will keep the wine version to check in subsequent updates. That game is kind of my canary for windows games.

There is a better fix, not to use sudo with pamac - since it may cause more harm than good, but to rebuild your AUR packages instead. I uninstalled those packages that had issues and installed them from scratch. It worked (as a temporary fix).

2 Likes

I too had my multi-monitor systems all janked. Thankfully it was just going in and rearranging them and it was more annoying than anything


Looks like i’ll need to make a tutorial about it…

i’d advise to wait a bit until things settle down and solutions to new issues have been suggested or applied,especially if you don’t know how to handle those yourself.

Thanks:

pamac build qt5-styleplugins

fixed the issue.

I think i had that error with last(?) stable update allready.

qt5-styleplugins comes as dependency of
xfce-sx-settings that is needed by these packages:

adapta-maia-theme-3.94.0.149-2 kvantum-1.0.2-1 manjaro-base-skel-20171029-3 manjaro-sx-wallpapers-20171023-1 papirus-icon-theme-20220606-1 papirus-maia-icon-theme-20200702-1 qt5-styleplugins-5.0.0.20170311-29
qt5ct-1.5-2 xcursor-breeze-5.22.5-1 xfce-sx-settings-20190617-1

… i don’t want to remove them!

How do i tell manjaro to rebuild qt5-styleplugins automatically?!

You don’t. The only time packages like that need to be rebuilt is when there’s a new Qt 5 point release like with the recent 5.15.5 update. You are responsible for managing the packages on your own system. Remember, the AUR is neither supported by Arch nor Manjaro.