[Stable Update] 2022-05-23 - Kernels, Toolchain, NVIDIA, Mesa, KDE, Qt, Maui, LibreOffice, Plasma, Firefox, Thunderbird

Thanks! Exactly what I was looking for

If you don’t know what those are about: Uniform look for Qt and GTK applications - ArchWiki


gnome-calculator: Ctrl-Z stop working after this upgrade.

Akonadi with MySQL/MariaDB fails too often for me. Switched to PostgreSQL instead.

I think this is related to… "Hotspot Login" pops up in Network Login app when waking from sleep - #17 by GaVenga
I use ethernet, not wifi, and I am getting “Wired Ethernet: Connected to Ethernet (log in required)” on mouseover of my network connection systray icon… there was a similar “Network Manager” popup I closed; dismissing it knowing I didn’t need to login to my ethernet network before realizing it was also echo’d in the systray.

In my case, /usr/lib/NetworkManager/conf.d/20-connectivity.conf is pointing to http://ping.manjaro.org/check_network_status.txt, which if I open in a browser throws a 404 Page not found.

I’ve updated my file to include a few of the typical replacements/options, opting to use KDE for now:


…and all was well after a service restart with $ sudo systemctl restart NetworkManager


temporary Work-Arround:

I’m not sure about the errors with
journalctl -r
but the UI errors seemed to have been fixed after a few restarts.

after update, no sound output from any application.

Sound Blaster Z, pipewire-git & wireplumber. Only dummy output sink available.

My solution: rebuild all AUR pipewire packages in use:


After GNOME session restart, sound worked normally.


Same here.
Also Wi-Fi started displaying “log-in required” popup for some reason (it works fine, though).

1 Like

Thank you!

Posts #5 and #6 (in the linked thread) show you a workaround by creating a new .conf file and restarting the NetworkManager service. You can keep this change as a permanent solution too, there’s no harm done.

I’ve just noticed that my whole desktop (KDE) went black - no wallpapers, no icons. Any help is appreciated.

Correct - but: /usr/lib/NetworkManager/conf.d/20-connectivity.conf
exists in system already (I use Gnome)

what is your DE?
with no desktop you mean completely blank screen?
provide more info

Since you’re on KDE.

Are you using dual monitors? Can you test it out with only a single display?

Otherwise, you can try the following to see if it helps out:

  1. Log out of KDE

  2. Switch to TTY2:

  • CTRL + ALT + F2
  1. Login to this TTY2 terminal

  2. Stop the display-manager service:

  • sudo systemctl stop display-manager
  1. Move/delete the old kscreen config:
  • mv -v $HOME/.local/share/kscreen $HOME/.local/share/kscreen.bak
  1. Rebuild the KDE cache:
  • kbuildsycoca5 --noincremental
  1. Wait about 30 seconds

  2. Then finally restart the display-manager service and login to KDE:

  • sudo systemctl restart display-manager && exit
1 Like

KDE. Yes completely black screen, but taskbar and windows are OK (that’s why I haven’t even noticed that at first).

You’re not supposed to touch that file. You’re supposed to create a new “drop in” file under /etc/NetworkManager/conf.d/

Then let us do …/30–stupid.conf :innocent:
The offending url is inside this holy file - so you ignore “not to touch the earth” file
or nothing will change - although time changes everything
B.t.w.: today is the first day of the rest of your life!

Thank you, thank you, it did the trick. At first it looked weird with random wallpapers and the taskbar gone, but after resetting the display settings (laptop + external display) it was back to normal.