[Stable Update] 2022-05-13 - Kernels, Mesa, Nvidia, Gnome 42, PipeWire, LIbreOffice, KDE Gear & Frameworks, Virtualbox, Qemu 7.0

The problem is that GDM have updated their udev rules to not enable wayland for nvidia cards if certain power management features are not set up. Specifically, these lines in /usr/lib/udev/rules.d/61-gdm.rules

# Check if suspend/resume services necessary for working wayland support is available
TEST{0711}!="/usr/bin/nvidia-sleep.sh", GOTO="gdm_disable_wayland"
TEST{0711}!="/usr/lib/systemd/system-sleep/nvidia", GOTO="gdm_disable_wayland"
IMPORT{program}="/bin/sh -c \"sed -e 's/: /=/g' -e 's/\([^[:upper:]]\)\([[:upper:]]\)/\1_\2/g' -e 's/[[:lower:]]/\U&/g' -e 's/^/NVIDIA_/' /proc/driver/nvidia/params\""
ENV{NVIDIA_PRESERVE_VIDEO_MEMORY_ALLOCATIONS}!="1", GOTO="gdm_disable_wayland"
IMPORT{program}="/bin/sh -c 'echo NVIDIA_HIBERNATE=`systemctl is-enabled nvidia-hibernate`'"
ENV{NVIDIA_HIBERNATE}!="enabled", GOTO="gdm_disable_wayland"
IMPORT{program}="/bin/sh -c 'echo NVIDIA_RESUME=`systemctl is-enabled nvidia-resume`'"
ENV{NVIDIA_RESUME}!="enabled", GOTO="gdm_disable_wayland"
IMPORT{program}="/bin/sh -c 'echo NVIDIA_SUSPEND=`systemctl is-enabled nvidia-suspend`'"
ENV{NVIDIA_SUSPEND}!="enabled", GOTO="gdm_disable_wayland"
LABEL="gdm_nvidia_end"

To fix this I had to enable a bunch of services and add a kernel parameter. Like so

sudo systemctl enable nvidia-hibernate
sudo systemctl enable nvidia-resume
sudo systemctl enable nvidia-suspend
echo 'options nvidia NVreg_PreserveVideoMemoryAllocations=1' | sudo tee /etc/modprobe.d/nvidia-power-management.conf
sudo mkinitcpio -P
2 Likes

I am having the same issue with libkipi and the key causing a failure to build. Any ideas how to fix this?

After the update succeeded; the pamac GUI popped up a message that updating/building libkipi had failed (which overwrote the “reboot required” popup).

Taking the hint from others that it was a no longer required library for the new KDE packages that used to use it, i checked for orphans, found libkipi listed, uninstalled it, and rebooted.

Post reboot after the update when firefox launched, it was like it contained a snapshot of what was on the desktop as opposed to rendering my saved sessions last site visited (nor it’s accompanying tabs). Tried launching another firefox instance and it behaved the same. The fix was two-fold:

  1. Logging out and back in corrected the firefox rendering (no more desktop “snapshot”)
  2. Recovered my ~/.mozilla/firefox/<profile>/sessionstore-backups/ files from Back In Time to restore my saved sessions/tabs… oh and I also deleted the ~/.mozilla/firefox/<profile>/sessionstore.jsonlz4 file to ensure firefox used the restored session backups

There is a known issue with latest RSYNC and TimeShift, discussed here incompatibility with latest rsync 3.2.4 · Issue #891 · teejee2008/timeshift · GitHub, people should provide info there for a quicker fix.

5 Likes

Hi everyone. Thanks for the update!

It seems that the builtin extension vertical-overview is not working now. A post in the extension page mentions it works fine on Gnome 42 on Fedora.

Any ideas on what I can do to fix it? I can’t stand the horizontal workspace paradigm.

ps: this error is given:
GObject_Object.prototype.[__GObject__hook_up_vfunc] called on incompatible Object

Smooth update overall, thanks to the Manjaro team :slight_smile:

The only little “issue”, but it’s related to an AUR package, so …, is a required rebuild of ckb-next (seems to be related to libquazip1-qt5 update).

Update worked fine for. Just want to mention one issue again, so people are aware.

I have kernels 5.10, 5.15 and 5.17 installed. I was using 5.15 as a default kernel, because 5.17.1 couldn’t resume from hibernate on my hw (intel Haswell, using iGPU). After running the update and reboot, the system booted by default to 5.17, not my previous default 5.15. IMHO, it should only change the default kernel if the old default is not present anymore, making it a conscious decision to use another kernel.

n.b.:
The hibernation issue seems to be fixed in 5.17.6 on my machine.

1 Like

Still no official Matcha or libadwaita supported modern theme for the legacy GTK4 apps in Gnome 42 (control-center, clocks, maps, etc…).
Outdated libadwaita apps are back in the 90’s. We need Matcha to bring them back in the future and on par with the more modern GTK apps (from before libadwaita).

2 Likes

See the second top reply.

Also mingw-w64-binutils package is broken in this update. If anyone like me builds their own Wine with bells and whistles, try using this workaround, or don’t use parallel compilation (will take hours to complete). Anyways, package needs to be patched and updated.

1 Like

Well, adwaita and libadwaita are the legacy theme here.
I’ve already read they won’t update Matcha themselves for the legacy libadwaita apps but I figured someone would, or at least with a different and more modern theme. Maybe someone has knowledge of such theme being operational. Because adwaita is objectively (yes, it can be objectivized) one of the worst and most inconsistent themes out there.
I managed to produce something myself but it’s in no way in a state I can share it.
It’s really time consuming as I’m no expert.

I report breakage with gnome-calculator. It is no longer dark-themed like the other windows but white-themed. Also if it is opened when some other dark-themed application like Firefox is maximized, then xfwm freezes completely to the point that even Ctrl-Alt-F1 does not work, requiring a hard power cycle. This is 100% repeatable.

Workaround: if you need to use gnome-calculator, minimize other windows first, or do so on a different desktop.

thank you very much omano indeed this solved the problem…

1 Like

Noticed an interesting entry in the journal post update, not sure how important or not this is…
May 13 08:27:00 AM4-5600X-Linux kdesud[1815]: kf.su.kdesud: Fatal IO error, exiting...

There is a open issue upstream.
You can try to patch this yourself, there is a diff in the linked issue.

The libkipi issue is odd.

I never explicitly installed it, and I’m 100% sure I never built it from the AUR.

So I can only assume that it used to live in the official repositories and was automatically installed as a dependency of another package, and then it was demoted to the AUR, which is causing the issues we’re seeing.

There’s nothing that clearly says it’s “safe to remove”.

This was not a clean nor smooth update, that’s for sure. (Not to mention the numerous GPG errors flooding the log.)

1 Like

listed as an orphan in the pamac GUI helped me to justify uninstalling it.

1 Like

Since this update I’m having an issue with all steam games. After clicking Play, a window appears to open on the taskbar, and the cursor changes to that game’s custom cursor, but nothing else happens. Changing to the game’s window makes the computer unresponsive, except for alt-tabbing out again (as if there’s a transparent fullscreen window over everything). After a couple of minutes, the game’s window closes again with no visible error. This has happened with three unrelated games so far, all native (not Proton).

Edit: Seems to have been fixed by restarting Steam a few times.

The update went smooth. Only the libkipi AUR package didn’t update. Right after the fail I just did pamac update again and it asked me to trust some keys from “Albert A.C.”, “Christoph F.” and “Heiko B.” (I shortened the names). So for anyone who have the same issue, just try it again.

You don’t know how many times I solved a problem by just doing trying it again. :smiley: