[Stable Update] 2022-01-23 - OpenSearch, Kernels, KDE Software, Cinnamon, Pipewire, Mesa, Gnome, LibreOffice

It’s a dependency for “ldm-gdm-integration”. Also, its description says “Linux driver management”, is that not important? Anyway, that still doesn’t help for the other 1398 packages, they would also be broken. It’s not inevitable, it’s impossible.

Thanks for posting this, I have a UM425QA, and my keyboard stopped working after this update after a cold boot (it works fine in Grub, I don’t have encryption). Probably something changed between v5.15.12 and v5.15.16 in the kernel.
Weird thing is, I didn’t ever need the linked solution before, and all kernels worked fine off the bat. I’ll test to see if it is working for me.

EDIT: Nope, the solution didn’t work. @frost19k just to verify, does your laptop’s keyboard work after you’ve reached GUI without applying the solution? (Maybe you could test by entering the encryption password with an external Keyboard)

After the update (on Wayland) switching to Firefox with Super + 1 from another workspace randomly fails with:

gnome-shell[820]: meta_window_raise: assertion '!window->override_redirect' failed

Switching to other programs seems to be fine. Restart & reinstalling Firefox didn’t help. Closing it and opening it again solves it temporarily. Anyone experiencing the same issue?

I have a UM325UAZ and the exact same problem as you (solution does not work). On grub, everything is fine but when I reach the login screen, it’s impossible to type something (Ctrl+Alt+F2 does not work too). It was fine before the update. It works with the 5.14 kernel, maybe you can stick to it for a while.

Please be careful with it, because:

Our current supported kernels

linux44 4.4.299
linux49 4.9.297
linux414 4.14.262
linux419 4.19.225
linux54 5.4.173
linux510 5.10.93
linux514 5.14.21 [EOL]
linux515 5.15.16
linux516 5.16.2
linux510-rt 5.10.90_rt60
linux515-rt 5.15.13_rt26

Explicitly mentioned it in the request thread:

Doing a reboot after cold boot also works, as mentioned in the original post I replied to. So I’m happy with 5.16 for now.

I found this recent patch that probably has to do with the original bug. That patch is from Nov, and kernel v5.15.12 (from previous Manjaro stable update) was released in end of Dec; I’m not sure whether the patch made it in or not. This diff between .12 and .13 does show that change, so maybe it didn’t make it in? If so, we’re probably seeing some side-effect of that change.

I saw but if I reboot to avoid the keyboard issue, I don’t have Wi-Fi (with 5.10, 5.15 and 5.16). It seems to be a problem with mt7921e. I already tried multiple solutions for it too but didn’t find one that’s working

Yes but then I don’t have Wi-Fi. I tried different solutions but nothing worked, except rebooting around three times or using 5.14.

Oh okay, maybe it is what cause the problem.

Ok I messed around a bit more, and seem to have found the solution. Adding options i8042 probe_defer=1 to /etc/modprobe.conf does the job - I’m able to use the keyboard directly after a cold boot on 5.16. I got the module option by looking at the submitted patch I linked to:

The deferred probe mode is enabled either via the new option
i8042.probe_defer or via the quirk table entry. As of this patch, the
quirk table contains only ASUS ZenBook UX425UA.

(Note that they also added UM325UA to the table in this patch)

Thank you for your response. I tried, but it doesn’t work. Did you do something more than adding options i8042 probe_defer=1 to /etc/modprobe.conf ?

(Thanks !)

Yeah, I’d expected it to not work for you, since UM325UA is already in that table, so the option is automatically set for you. Not sure what else you can do other than creating a bug report somewhere.

I did realise that the changes made to /etc/mkinitcpio.conf didn’t actually get applied. We need to run mkinitcpio -P to recreate the images. Maybe try that (after applying the solution from the very first post I replied to)?

it looks like a fix is in the pipeline:

@philm, are you able to say when this might me merged? thank you

zfs-utils 2.1.2-2 is available in all branches, refresh your mirrors.


Okay, I found the solution. I did the one of the arch fix that @frost19k linked with the /etc/mkinitpcio.conf, create a custom one and generate the initramfs for the 5.16 kernel. And it works well on cold boot !
Thank you for your time !


I’ll have a go after my last meeting of the day

Sad, perhaps, but certainly the result of the wide open nature of Linux, which is not at all sad in my very very humble opinion. but I’ll leave the whys for some other time.

There are several choices for devs who want their apps to have a GUI: on my computer I have app GUIs written in gtk (several versions); QT (also several versions); wxwindows (probably more than one version?); one or more of python’s various GUI libraries or just from scratch; a small collection of pixilang apps whose GUIs are implemented in C by one (extraordinarily talented) multimedia developer; a handful of Java apps that come with one or two themes hard-coded in, so the only way to customize them would be to rewrite the source and recompile it myself; and several others I am surely forgetting or have never encountered.

Since every computer user will install a different set of apps, and the GUIs come from all fifteen million corners of the Linux world, it is not possible for a distro to write a single tool to rule every window decorating scheme.

You could, if you wanted to be able to configure your themes using the smallest number of tools, restrict the apps you use to whatever GUI tools your Desktop Environment supports out of the box. I use Openbox window manager, so don’t know what Gnome or KDE are up to these days, but in most cases the DE/WM theming tools may more may not be integrated with all versions of gtk, and Qt apps still need their own config tool.

So whether this would result in a machine that had all the applications you needed, I cannot say.

My advice is to back up your ~/.config directory early and often, and maybe become familiar with how color is configured: open a color picker (gcolor3, which you may already have installed, can be opened independently from graphics or theming apps) and see how colors work in the digital realm. The more you know, the easier it will be to fix things when they change.

Because things always change, but they change especially quickly in Linux rolling-release distros.

Welcome to our little microcosm of reality, where the trains most definitely do not run on time.

3 posts were split to a new topic: Systemtray bluetooth menu is empty after latest updates

It does not, no. On cold boot the built-in keyboard stops working from the initramfs stage & will not work even after I reach the GUI. However, it does work in GRUB.
This was not the case before the most recent update. Keyboard didn’t work in initramfs but was fine once I got to the GUI. So something has changed.

I have the UM325SA, btw. Maybe it’s a model specific thing? I haven’t been able to find any other solutions - I’m sorry :frowning:

No worries! It was fixed for me as mentioned in one of the earlier posts- had to set some new kernel option. It most likely is some model specific thing, since I didn’t have your issue earlier, and your solution didn’t work either. Just gotta try everything :stuck_out_tongue: