[Stable Update] 2022-01-02 - Kernels, Systemd, KDE Frameworks, Mesa, Xorg-Server, Wine, Python 3.10

Upgrade was fine for most parts, but one of python apps is broken now. I use Rummage ( Rummage - Rummage Documentation ) which is a cross platform search and replace tool (like GUI for grep) and it worked perfectly before. Right after upgrade, it didn’t start, so I re-installed app. Now it works, but GUI is terribly broken. This is how app should look like - https://facelessuser.github.io/Rummage/images/preview.png

This is how it looks after upgrade - rummage — ImgBB (notice tons of empty space at the bottom - this is where all the options should be). If I move mouse cursor over empty space, some options appear for a second and then disappear again. My guess it’s probably related to Python 3.10…

Systemd drop-in config for unit files in user context is not loaded when the drop-in directory is a symlink. Reported it as systemd issue. Drop-in config not recognized when .d directory for a unit is a symlink · Issue #21979 · systemd/systemd · GitHub

For now my workaround is to symlink the config files instead of the directories.

1 Like

After this update my Telegram icon doesn’t show the number of Unread Messages anymore.

KDE Plasma

# ~/.bash_profile
[[ -f ~/.bashrc ]] && . ~/.bashrc
export LC_ALL="C"
export EDITOR=/usr/bin/nano
[[ "$XDG_CURRENT_DESKTOP" == "KDE" ]] || export QT_QPA_PLATFORMTHEME="qt5ct"
[[ -f ~/.extend.profile ]] && . ~/.extend.profile

Hello. I’ve got a broken pip after the update.

➜  ~ pip                      
Traceback (most recent call last):
  File "/usr/bin/pip", line 33, in <module>
    sys.exit(load_entry_point('pip==20.3.4', 'console_scripts', 'pip')())
  File "/usr/bin/pip", line 25, in importlib_load_entry_point
    return next(matches).load()
  File "/usr/lib/python3.10/importlib/metadata/__init__.py", line 162, in load
    module = import_module(match.group('module'))
  File "/usr/lib/python3.10/importlib/__init__.py", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1050, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1027, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1006, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 688, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 883, in exec_module
  File "<frozen importlib._bootstrap>", line 241, in _call_with_frames_removed
  File "/usr/lib/python3.10/site-packages/pip/_internal/cli/main.py", line 10, in <module>
    from pip._internal.cli.autocompletion import autocomplete
  File "/usr/lib/python3.10/site-packages/pip/_internal/cli/autocompletion.py", line 9, in <module>
    from pip._internal.cli.main_parser import create_main_parser
  File "/usr/lib/python3.10/site-packages/pip/_internal/cli/main_parser.py", line 7, in <module>
    from pip._internal.cli import cmdoptions
  File "/usr/lib/python3.10/site-packages/pip/_internal/cli/cmdoptions.py", line 25, in <module>
    from pip._internal.cli.progress_bars import BAR_TYPES
  File "/usr/lib/python3.10/site-packages/pip/_internal/cli/progress_bars.py", line 12, in <module>
    from pip._internal.utils.logging import get_indentation
  File "/usr/lib/python3.10/site-packages/pip/_internal/utils/logging.py", line 18, in <module>
    from pip._internal.utils.misc import ensure_dir
  File "/usr/lib/python3.10/site-packages/pip/_internal/utils/misc.py", line 21, in <module>
    from pip._vendor import pkg_resources
ImportError: cannot import name 'pkg_resources' from 'pip._vendor' (/usr/lib/python3.10/site-packages/pip/_vendor/__init__.py)

Already followed some instructions to uninstall and install again, and no luck in there.

Commands that I’ve tried:

sudo pacman -Rns python-pip
yay -s python-pip
sudo paccache -r

Also, all my envs using python3.9 got broken, I have installed it again using yay.

sudo pacman -S python-pip

AFAIK its just the way it is going forward and should be nothing of concern, systemd does a host of flag checks/decisions and all negative results has word “failed” in them.

I have two or three packages installed via pip and I forgot to run this command…I haven’t noticed anything out of the ordinary so far but I’m curious about what types of problems I might bump into/what their workarounds are.

I cannot turn on Bluetooth after this update. The Bluetooth option is still there in Gnome menu but clicking it does nothing.

Use Cinnamon and this update seems to break my setup of nemo (did not start and no desktop icons), I had two aur packages I was not aware of (nemo-media-columns and nemo-compare), did a pamac build $(pacman -Qoq /usr/lib/python3.9) --no-confirm
and all worked fine again after that.
Thank you for a great update! :slight_smile:

1 Like

Telegram is built with Qt6 now, see:

FS#73234 - [telegram-desktop] v3.4.2-2 Qt6 build does not apply the system tray icon theme

1 Like

I changed it to qt6ct, thanks.
It didn’t resolve my Telegram issue though.

A post was merged into an existing topic: Optimus manager doesn’t work after upgrade

No problem at all, for the system.

No problem for you if you remember the names of the packages, or can find them again.

When you want to use one of those pip packages again, just re-install it.
Remember to put --user in the command, and not sudo.

Using ‘pip freeze’ is for people who have lots of pip packages installed.
It gives you a list, so you don’t have to remember them all.


This package change link is different from previous Stable updates, in that it is comparing Stable to Testing. Is there a way we can generate our own diff, or can we request a compare of “Stable 2022-01-02” to “Stable 2021-12-16”?


Small problem with SDDM scaling (as posted here: SDDM / login scaling broken after 2022-01-02 update). Previously scaled SDDM / login interface now tiny again on 4k screen.

1 Like

optimus-manager broker after update. Could not not run nvidia x-server.

systemctl status optimus-manager showed failed
Jan 03 22:36:52 ja-clevo systemd[1]: Starting Optimus Manager Commands Daemon...
Jan 03 22:36:52 ja-clevo python3[1059]: /usr/bin/python3: Error while finding module specification for 'optimus_manager.hooks.pre_daemon_start' (ModuleNotFoundError: No module named 'optimus_manager')
Jan 03 22:36:52 ja-clevo python3[1101]: /usr/bin/python3: Error while finding module specification for 'optimus_manager.hooks.pre_xorg_start' (ModuleNotFoundError: No module named 'optimus_manager')
Jan 03 22:36:52 ja-clevo systemd[1]: Started Optimus Manager Commands Daemon.
Jan 03 22:36:52 ja-clevo python3[1111]: /usr/bin/python3: Error while finding module specification for 'optimus_manager.daemon' (ModuleNotFoundError: No module named 'optimus_manager')
Jan 03 22:36:52 ja-clevo systemd[1]: optimus-manager.service: Main process exited, code=exited, status=1/FAILURE
Jan 03 22:36:52 ja-clevo python3[1135]: /usr/bin/python3: Error while finding module specification for 'optimus_manager.hooks.post_daemon_stop' (ModuleNotFoundError: No module named 'optimus_manager')
Jan 03 22:36:52 ja-clevo systemd[1]: optimus-manager.service: Control process exited, code=exited, status=1/FAILURE
Jan 03 22:36:52 ja-clevo systemd[1]: optimus-manager.service: Failed with result 'exit-code'

As suggested in the update notes relating to python, I ran

> pacman -Qoq /usr/lib/python3.9

and saw that optimus-manager was listed. I then ran

yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All

Started the optimus service and it started successfully but I still could not launch the nvidia x-server. I then rebooted my machine and all now works ok. I can launch nvidia x-server and optimus-manager works ok.

1 Like

Stable update [2022-01-02] upgrade process went through smoothly without any glitch.

Rebuilding of AUR based python packages went through without any hassle.

The system is more responsive and has significant improvements in program load times.

This update resolved my laptop wake-up issues. I couldn’t put my finger on what resolved this issue though I was using the same kernel earlier.

These two bugs are already fixed for stable branch :

KDE Window Decorations UI with Drag&Drop broken
KDE Plasma shows visual graphical errors


Hello, Thank you for your amazing work! I got the following problems since the update:

  • The wifi connection is unstable (driver iwlwifi driverversion=5.10.89-1-MANJARO)
  • Sudo password promts take a minute to appear
  • GDM did not work, had to install lightdm

Looks like the update breaks sane with some HP devices supported by hplip requiring a plugin.

hp-plugin -i is needed.