[Stable Update] 2022-01-02 - Kernels, Systemd, KDE Frameworks, Mesa, Xorg-Server, Wine, Python 3.10

sudo pacman -S python-pip

AFAIK its just the way it is going forward and should be nothing of concern, systemd does a host of flag checks/decisions and all negative results has word “failed” in them.

I have two or three packages installed via pip and I forgot to run this command…I haven’t noticed anything out of the ordinary so far but I’m curious about what types of problems I might bump into/what their workarounds are.

I cannot turn on Bluetooth after this update. The Bluetooth option is still there in Gnome menu but clicking it does nothing.

Use Cinnamon and this update seems to break my setup of nemo (did not start and no desktop icons), I had two aur packages I was not aware of (nemo-media-columns and nemo-compare), did a pamac build $(pacman -Qoq /usr/lib/python3.9) --no-confirm
and all worked fine again after that.
Thank you for a great update! :slight_smile:

1 Like

Telegram is built with Qt6 now, see:

FS#73234 - [telegram-desktop] v3.4.2-2 Qt6 build does not apply the system tray icon theme

1 Like

I changed it to qt6ct, thanks.
It didn’t resolve my Telegram issue though.

A post was merged into an existing topic: Optimus manager doesn’t work after upgrade

No problem at all, for the system.

No problem for you if you remember the names of the packages, or can find them again.

When you want to use one of those pip packages again, just re-install it.
Remember to put --user in the command, and not sudo.

Using ‘pip freeze’ is for people who have lots of pip packages installed.
It gives you a list, so you don’t have to remember them all.


This package change link is different from previous Stable updates, in that it is comparing Stable to Testing. Is there a way we can generate our own diff, or can we request a compare of “Stable 2022-01-02” to “Stable 2021-12-16”?


Small problem with SDDM scaling (as posted here: SDDM / login scaling broken after 2022-01-02 update). Previously scaled SDDM / login interface now tiny again on 4k screen.

1 Like

optimus-manager broker after update. Could not not run nvidia x-server.

systemctl status optimus-manager showed failed
Jan 03 22:36:52 ja-clevo systemd[1]: Starting Optimus Manager Commands Daemon...
Jan 03 22:36:52 ja-clevo python3[1059]: /usr/bin/python3: Error while finding module specification for 'optimus_manager.hooks.pre_daemon_start' (ModuleNotFoundError: No module named 'optimus_manager')
Jan 03 22:36:52 ja-clevo python3[1101]: /usr/bin/python3: Error while finding module specification for 'optimus_manager.hooks.pre_xorg_start' (ModuleNotFoundError: No module named 'optimus_manager')
Jan 03 22:36:52 ja-clevo systemd[1]: Started Optimus Manager Commands Daemon.
Jan 03 22:36:52 ja-clevo python3[1111]: /usr/bin/python3: Error while finding module specification for 'optimus_manager.daemon' (ModuleNotFoundError: No module named 'optimus_manager')
Jan 03 22:36:52 ja-clevo systemd[1]: optimus-manager.service: Main process exited, code=exited, status=1/FAILURE
Jan 03 22:36:52 ja-clevo python3[1135]: /usr/bin/python3: Error while finding module specification for 'optimus_manager.hooks.post_daemon_stop' (ModuleNotFoundError: No module named 'optimus_manager')
Jan 03 22:36:52 ja-clevo systemd[1]: optimus-manager.service: Control process exited, code=exited, status=1/FAILURE
Jan 03 22:36:52 ja-clevo systemd[1]: optimus-manager.service: Failed with result 'exit-code'

As suggested in the update notes relating to python, I ran

> pacman -Qoq /usr/lib/python3.9

and saw that optimus-manager was listed. I then ran

yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All

Started the optimus service and it started successfully but I still could not launch the nvidia x-server. I then rebooted my machine and all now works ok. I can launch nvidia x-server and optimus-manager works ok.

1 Like

Stable update [2022-01-02] upgrade process went through smoothly without any glitch.

Rebuilding of AUR based python packages went through without any hassle.

The system is more responsive and has significant improvements in program load times.

This update resolved my laptop wake-up issues. I couldn’t put my finger on what resolved this issue though I was using the same kernel earlier.

These two bugs are already fixed for stable branch :

KDE Window Decorations UI with Drag&Drop broken
KDE Plasma shows visual graphical errors


Hello, Thank you for your amazing work! I got the following problems since the update:

  • The wifi connection is unstable (driver iwlwifi driverversion=5.10.89-1-MANJARO)
  • Sudo password promts take a minute to appear
  • GDM did not work, had to install lightdm

Looks like the update breaks sane with some HP devices supported by hplip requiring a plugin.

hp-plugin -i is needed.

I use a laptop with a dock with two screens with optimus-manager. After update the screen was blank.

Fixed by
sudo pamac remove optimus-manager
sudo pamac install optimus-manager


I have a big problem. I made the last updates (2022-01-02) on Manjaro Cinnamon version. Now, the system starts but the vendor logo blinks many times and nothings happens. I must reboot with the CTRL+ALT+Del keys. I have the last 5.10 and 5.4 kernel installed but It doesn’t work even if I’m in falling back mode. I tried to switch to console mode but it doesn’t recognize my login. What can I do ? I’m desperate. Is there a way with the usb live of Manjaro to solve the issue ? What’s wrong ?

Note: I’ve got a laptop with Optimus technology. Optimus-manager is installed.

Thank you very much for your help.

Maybe try to boot with live media, and use it to chroot to your system.
Rolling back the optimus-manager seems to help.

I just noticed that the program notify-send does not work anymore, after the update 2 days ago. I know it worked a few days ago, so it is probably something after the update. When I run the command notify-send "hello" in the terminal in example it should work, but it waits as if it would wait for input and never stops, until I control-c. Any idea how to troubleshoot and if this is related to the update? Some related info:

pamac search --files -q notify-send
1 Like