[Stable Update] 2021-12-10 - Kernels, Systemd, LibreOffice, Plasma, Browser, Thunderbird

3 posts were split to a new topic: Apwal doesn’t launch anymore

Sorry I’m a new user. I clicked the second option that I had an issue and solved it myself and wanted to post how I did it but I don’t know where I can post it. Is it normally done here?

In addition to SDDM theme, I have to re-select theme in the dolphin terminal at the bottom (you can show it by pressing F4).

BTW, why does Manjaro not show in the GUI that the Linux Kernel is unsupported? Just as it shows “LTS” and “recommended”, it should show “EOL” and maybe “not recommended”.


I have found just the one odd issue, whenever I click on the news notification for this release in matray, it opens up Wine (which loads infinitely) for some reason and won’t open the forum post. This notification about a file being copied then appears:

Update went very smoothly. The issue I encountered with the last update with my icons looking “off” has been fixed with the new update so that’s nice.

EDIT: I found a minor issue that was very easily fixed after a quick search. Trying to open embedded images from discord would not open them in firefox and instead gwenview which was a new bug since updating.

Running: xdg-settings set default-url-scheme-handler http firefox.desktop in the terminal fixed my issue even though firefox was already the default setting for it. Maybe it just needed to be refreshed for whatever reason?

1 Like

I had the same issue glottophilos had, and with discord, where it looked like Wine was trying to open links. This post fixed it

Using KDE, after the update reboot the SDDM screen was reset to some weird UI and had to re-select the default Breeze theme again.

Konsole also lost its default theme.

Thanks, I fix the ssdm issue, other issue is the menu icon, it is no longer Manjaro instead plasma

I am still getting the same problem asn the 11-19-2021 update where XFCE blanks screen but no login screen once it gets locked.

I am watching this thread hoping a solution might be forthcoming.

Bluetooth is not working for me after this update and there’s some odd behavior. Bluetooth seems to not be enabled in the UI, and clicking the enable button in the settings does nothing at all. Yet, the adapter is detected in various ways. Under Bluetooth, inxi shows state: up

#inxi --admin --verbosity=7 --filter --no-host --width                                                                                                                                                                        
  Kernel: 5.15.6-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-5.15-x86_64
  root=UUID=08c9d621-0782-41c4-b2df-94c78234a2df rw rootflags=subvol=@ quiet
  apparmor=1 security=apparmor
  resume=UUID=8ca3d311-0c42-43f5-b128-2416430a77d5 udev.log_priority=3
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1
  dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 80WY v: Lenovo Y520-15IKBA
  serial: <superuser required> Chassis: type: 10 v: Lenovo Y520-15IKBA
  serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
  serial: <superuser required> UEFI: LENOVO v: 5JCN25WW date: 07/18/2018
  ID-1: BAT0 charge: 37.8 Wh (97.9%) condition: 38.6/45.0 Wh (85.7%)
  volts: 12.7 min: 11.5 model: SMP L16M3P24 type: Li-poly serial: <filter>
  status: Unknown
  RAM: total: 15.52 GiB used: 3.95 GiB (25.4%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: Quad Core model: Intel Core i5-7300HQ bits: 64 type: MCP
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: 9 microcode: EA
  cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB bogomips: 20004
  Speed: 1242 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 1242 2: 1823
  3: 1863 4: 2113
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c
  flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window hwp_epp
  hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm mca mce
  md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
  pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand
  rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2
  ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme
  vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: disabled, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel HD Graphics 630 vendor: Lenovo driver: i915 v: kernel
  bus-ID: 00:02.0 chip-ID: 8086:591b class-ID: 0300
  Device-2: AMD Baffin [Radeon RX 460/560D / Pro 450/455/460/555/555X/560/560X] vendor: Lenovo driver: amdgpu v: kernel bus-ID: 01:00.0 chip-ID: 1002:67ef
  class-ID: 0380
  Device-3: Realtek EasyCamera type: USB driver: uvcvideo bus-ID: 1-6:3
  chip-ID: 0bda:58e5 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org compositor: kwin_x11 driver:
  loaded: ati,modesetting unloaded: amdgpu alternate: fbdev,vesa
  display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6")
  diag: 394mm (15.5")
  OpenGL: renderer: Mesa Intel HD Graphics 630 (KBL GT2) v: 4.6 Mesa 21.2.5
  direct render: Yes
  Device-1: Intel CM238 HD Audio vendor: Lenovo driver: snd_hda_intel
  v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a171 class-ID: 0403
  Device-2: Samsung USBC Headset type: USB
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-4:2 chip-ID: 04e8:a051
  class-ID: 0300
  Sound Server-1: ALSA v: k5.15.6-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
  Device-1: Intel Dual Band Wireless-AC 3165 Plus Bluetooth driver: iwlwifi
  v: kernel bus-ID: 03:00.0 chip-ID: 8086:3166 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Lenovo driver: r8168 v: 8.049.02-NAPI modules: r8169 port: 3000
  bus-ID: 04:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
  bus-ID: 1-11:4 chip-ID: 8087:0a2a class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 1.82 TiB used: 334.32 GiB (17.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
  model: WDS100T2B0C-00PXH0 size: 931.51 GiB block-size: physical: 512 B
  logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
  rev: 211210WD temp: 31.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  type: HDD rpm: 5400 serial: <filter> rev: LCM2 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 914.14 GiB size: 914.14 GiB (100.00%)
  used: 295.16 GiB (32.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  label: N/A uuid: 08c9d621-0782-41c4-b2df-94c78234a2df
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 572 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  label: NO_LABEL uuid: 37CC-686B
  ID-3: /home raw-size: 914.14 GiB size: 914.14 GiB (100.00%)
  used: 295.16 GiB (32.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  label: N/A uuid: 08c9d621-0782-41c4-b2df-94c78234a2df
  ID-4: /run/media/olivier/Windows raw-size: 930.89 GiB
  size: 930.89 GiB (100.00%) used: 39.16 GiB (4.2%) fs: ntfs dev: /dev/sda3
  maj-min: 8:3 label: Windows uuid: 366A2AD76A2A9421
  ID-5: /var/cache raw-size: 914.14 GiB size: 914.14 GiB (100.00%)
  used: 295.16 GiB (32.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  label: N/A uuid: 08c9d621-0782-41c4-b2df-94c78234a2df
  ID-6: /var/log raw-size: 914.14 GiB size: 914.14 GiB (100.00%)
  used: 295.16 GiB (32.3%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  label: N/A uuid: 08c9d621-0782-41c4-b2df-94c78234a2df
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 17.08 GiB used: 0 KiB (0.0%) priority: -2
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: swap
  uuid: 8ca3d311-0c42-43f5-b128-2416430a77d5
  ID-1: /dev/sda1 maj-min: 8:1 size: 100 MiB fs: vfat label: N/A
  uuid: 8C26-D21E
  ID-2: /dev/sda2 maj-min: 8:2 size: 16 MiB fs: <superuser required>
  label: N/A uuid: N/A
  ID-3: /dev/sda4 maj-min: 8:4 size: 516 MiB fs: ntfs label: N/A
  uuid: 86DADA85DADA70C3
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-4:2 info: Samsung USBC Headset type: Audio,HID
  driver: hid-generic,snd-usb-audio,usbhid interfaces: 5 rev: 2.0
  speed: 12 Mb/s power: 100mA chip-ID: 04e8:a051 class-ID: 0300
  Device-2: 1-6:3 info: Realtek EasyCamera type: Video driver: uvcvideo
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0bda:58e5
  class-ID: 0e02 serial: <filter>
  Device-3: 1-11:4 info: Intel Bluetooth wireless interface type: Bluetooth
  driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA
  chip-ID: 8087:0a2a class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 8 rev: 3.0 speed: 5 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 61.0 C pch: 45.5 C mobo: N/A gpu: amdgpu
  temp: 49.0 C
  Fan Speeds (RPM): N/A
  Processes: 265 Uptime: 35m wakeups: 2 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1771 apt: 0 pacman: 1742
  lib: 379 flatpak: 18 snap: 11 Shell: Zsh v: 5.8 default: Bash v: 5.1.12
  running-in: konsole inxi: 3.3.09

I checked rfkill just in case and it seems all right…

#rfkill list                                                                                                                                                                                                              
0: ideapad_wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: ideapad_bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
3: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

Yet bluetoothctl returns “no default controller available” and everything in the UI behaves as though bluetooth were disabled. Everything bluetooth worked fine out of the box until now.

Upgrading broke my Cudy Realtek AC1300 USB wifi dongle’s connectivity.

Hard to hardwire an ethernet port to solve the problem via pamac build rtl88x2bu-dkms-git … for which I am extremely thankful.

Am now cooking with the latest gas. Thanks to all involved for making this possible.

In the KDE interface, if the compositor is enabled, the Night Color tab in the System Settings is slow on open and has a bug in detecting Kwin_X11.

If I’m not mistaken… that’s the default “menu icon” when Plasma Style is set to Breeze.

If I’m right, you should be able to change that back to Breath which should include the Manjaro M… or, if you find you prefer Breeze but want the M you can adjust the Panel => Application Launcher settings:

  1. Right-click empty space in panel and choose Enter Edit Mode
  2. Hover/mouse over the plasma icon to expose the App Launcher context menu and choose Configuration
  3. On the General tab, click the icon, then select choose from the context menu to open a search dialog
  4. Type manjaro in the search box, select your icon, then click OK to close the search dialog
  5. Click Apply in the App Launcher Settings, then OK to close it
  6. Click the red “x” in the small menu that’s open in the top/center of your screen to Close Edit Mode

Just wondering is there any plans for Calamares to support BTRFS, like making it easier for users to have BTRFS instead of ext4?

There was not btrfs option in Calamares? If was not, please post full filename of that ISO image.

1 Like

I have a small problem with the taskbar: the dust bin is not visible any more.

Actually, I initially thought I had to update the Profiles in Konsole and Yakuake separately too… but as it turns out, they share the Konsole settings (likely because Yakuake uses Konsole). I believe the reason it appears they are separate is that Yakuake keeps working from cached settings.

But if you make your Profile change in Konsole, then close/quit and relaunch Yakuake, you’ll see it picks up the Konsole Profile changes you made.

1 Like

I’ve sometimes found after making theme changes that logging out and back in again sets things straight; often for things inside the Panel. For example, I’ve seen it were I saw empty space in the systray that if I moused over it I saw the name of the app. logging out and back in corrected it.

1 Like

Went pretty smoothly here. As people have mentioned the Konsole profile was switched but that was just a simple click to reset to my old saved profile. Thanks all. Will report if I do find something.