[Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa

This will remove my nvidia-340xx driver. And install the video-linyx driver. My computer does not work well with it. No more options?

Do this. It is a workaround for 390 driver but it should fix the issue on older drivers too.

Hello I can confirm that this works

Only my file is under different name.

I use nvidia-340 and this file does not overwrite anything in xorg.conf.d at least in my case.

I’ve finally found parts of the issue:
I have two monitors, one of which is rotated by 90°. I’ve created a new user which can log in without issues. However, when I adjust the rotation to be “correct”, I get logged out immediately.
Upon logging in again, the rotation is not saved.
Has anyone any idea how this could be debugged or solved?
How to discriminate if that’s a cinnamon or a xorg issue?

EDIT: @Gene describes something similar here though I don’t understand how he solved it…

I’m afraid I didn’t solve the issue of the monitor. I marked my query as solved because to start with I couldn’t log in at all - I’d written a script which would orientate my monitor and that caused a crash immediately on log in. Since I’ve figured out what the issue is, I can now login - I basically just fully disconnected the monitor (power and data) and commented out my script, allowing me to login again! As the price of being able to login I’ve just stopped using my second monitor in portrait mode (my preferred orientation). It is now in landscape. I’m hoping for a more permanent fix, and have asked to have this added to the known issues.

It is not a cinnamon issue though - I use primarily i3 and occasionally (with a different user) XFCE. I think it is an Xorg issue.

1 Like

A post was split to a new topic: Boots to black screen after latest stable update

I realized both of my lts kernel packages were not marked as explicitly installed.
I marked them and the procedure to switch back to 470 was successful.
I am a bit confused about when this can happen in Arch based distros. I guess when the time Manjaro was installed on this PC , linux-lts and linux-latest packages were installed and later they became discontinued or something like that. On 2 other notebooks (with Intel GPU) of mine, kernel packages are marked as explicitly installed from the beginning.
Nvidia driver 495.44 is also suitable for my GTX 1650 VGA , but I will switch to it later. Resuming from suspend restart kwin desktop effects (due to graphichs reset) with nvidia and after that I always restart plasma, which it takes less time with the 470 driver series. I hoped 495 would solves this issue, but it did not happen.
I also noticed libxnvctrl package "NVIDIA NV-CONTROL X extension"is version still 495.44 after the downgrade of the driver.

Here an Issue which should be added to the “Known issues and solutions” list.

Issue: No search results in application launcher when using multiple kickoff instances.

Solution 1: Manually Downgrading the Kickoff Applet until the Bug is fixed Upstream.
Solution 2: Only have one Kickoff Applet, by removing the other ones.

Upstream KDE Bug: 443131 – When there's more than one Kickoff, clicking on the old one causes search to be broken until you search with the new one

(Basically they completly rewrote the codebase of the kickoff applet, which seems to only create a single search instance, which they try to bind to multiple kickoff applets. However this seems to result in some NULL exceptions, as it fails to force focus on the search object.)

Workaround Tutorial: No search results in application launcher - #6 by alkl

1 Like

You should not be using 340, as it has serious security issues that will not be fixed.

What issues do you have with Nouveau?

Has there been any news on this?
How is it that no one else sees this behavior? Are multi monitor setups with rotations that rare?

Already tried 5.15?

1 Like

I’m not aware of any further news.

@philm could this be added to the open issues, please?
Also, is this worked on? How can it be that a “stable” release breaks a core component of the os and there are zero replies by the maintainers?

What is it about? Don’t know what you’re talking about? Nvidia?

it seems that as described above (and here) a rotated secondary monitor no longer allows logging in.
Creating a new user without any saved rotation works, but when setting the “correct” rotation one gets thrown back to the login screen.
It somewhat seems x-server related.
Thanks for looking into the issue!

1 Like

I also requested that this was added to New Issues earlier.


and done.

Sorry it took so long. Just a reminder for all eligible users (tl1 and up?): the wiki post can be edited.

1 Like

No, I didn’t. I had decided to stick to Recommended and LTS.

5.15 might just do the trick. Might install it before the next update.

Unless somebody advises against a noob using the 5.15, e. g. due to some stability issues?

5.15 is the new LTS… but it is still pretty new. All-in-all it has been quite good for me, just one issue being worked through that seems to have a workaround by not using hardware acceleration in VLC (and some suggested even in Firefox).

1 Like