[Stable Update] 2021-09-24 - Kernels, LibreOffice, Browsers, Pipewire, RHVoice, KDE Frameworks, Mesa

It’s not just that G-Sync breaks with the latest driver, but that if a person loads up after the update and they have a G-Sync display, they can be stuck in a situation where they can’t boot into their Manjaro install.

If you want to test the NVIDIA driver, feel free to switch to the testing branch as mentioned, but since the NVIDIA driver is not stable, it does not belong in the stable branch.

1 Like

After this update, my system is acting totally weird.

I have Manjaro since February 2019, and everything is always been good.

But since this update I firstly encountered this issue:

Then I also noticed that mpv (has been updated from 1:0.33.1-2 to 1:0.33.1-3) after a while of playing, will freeze all the system: luckily I can go to TTY2 and there executing systemctl reboot.
But I am upset… I had a rock solid system, but since this update, has become unreliable…

EDIT: I downgraded mpv, but the issue persists: after a while (about five minutes of playing) the system completely freeze…


I switch from stable branch to testing branch:

sudo pacman-mirrors --api --set-branch testing
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu
[2021-09-27T22:27:49+0200] [PACMAN] Running 'pacman -Syyu'
[2021-09-27T22:27:49+0200] [PACMAN] synchronizing package lists
[2021-09-27T22:27:50+0200] [PACMAN] starting full system upgrade
[2021-09-27T22:28:06+0200] [ALPM] transaction started
[2021-09-27T22:28:06+0200] [ALPM] upgraded libxnvctrl (470.63.01-1 -> 470.74-1)
[2021-09-27T22:28:06+0200] [ALPM] upgraded manjaro-release (21.1.4-1.0 -> 21.1.5-1)
[2021-09-27T22:28:06+0200] [ALPM] upgraded matcha-gtk-theme (20210823-1 -> 20210924-1)
[2021-09-27T22:28:06+0200] [ALPM-SCRIPTLET] 
[2021-09-27T22:28:06+0200] [ALPM-SCRIPTLET] Firefox theme
[2021-09-27T22:28:06+0200] [ALPM-SCRIPTLET] See /usr/share/doc/matcha-gtk-theme/firefox/README.md
[2021-09-27T22:28:06+0200] [ALPM-SCRIPTLET] 
[2021-09-27T22:28:06+0200] [ALPM-SCRIPTLET] Gedit theme
[2021-09-27T22:28:06+0200] [ALPM-SCRIPTLET] See /usr/share/doc/matcha-gtk-theme/gedit/README.md
[2021-09-27T22:28:06+0200] [ALPM-SCRIPTLET] 
[2021-09-27T22:28:06+0200] [ALPM] upgraded mhwd-nvidia (470.63.01-1 -> 470.74-1)
[2021-09-27T22:28:06+0200] [ALPM] transaction completed
[2021-09-27T22:28:07+0200] [ALPM] running '30-systemd-update.hook'...
[2021-09-27T22:28:07+0200] [ALPM] running 'rebuild-detector.hook'...

(libxnvctrl ?? Is for nVidia, but on my system there is no nVidia, only Intel).

What happened:

The system freezed again for few seconds (about 15 seconds), then become responsive again.
In the Journal log I don’t see (or I am not able to search about) nothing about.

I’ll update this message: I am not totally sure of what is happening.

EDIT 3: nothing to do: I was playing again using mpv and the system freeze again.

EDIT 4: I discovered that when the system freeze, instead of doing systemctl reboot, I can execute pkill -KILL -u $myusername and the system will become usable again. But this is a workaround; shouldn’t happen.

EDIT 5: I currently using smplayer (tried various times, also for more than an hour of playing) and the system freeze doesn’t occured; the funny thing is that smplayer using mpv as video backend.

Does the snap have the same libreoffice version?

What happens if you reset Libreoffice (non-snap) to default settings?

rockin’ an old kernel there? you probably have reasons, but patches only go so far?

Old system here: Ivy Bridge - (kernel 4.14 LTS).
During these years I tried newer kernels but doesn’t play good here (eg: slow boot and no suspend-to-ram).

Otherwise good update, but for some reason my XFCE audio mixer volume meters stopped functioning. And I have no clue how to fix those.

Hi, minor issue. After updating the other day, all of the fonts turned into squares. I rebooted and all turned back to normal. That is except for one of my mail programs which is a snap program.
I’m not sure what caused the issue in the first place so am at a loss as to how to fix it in the snap program that it is still affecting.
I can use the program but if I minimize the program to the taskbar and then click on the icon the menu that comes up appears as Squares in place of letters. Also when opening a certain menu in the program to select a location on the computer it too is all squares.
Does anyone have any idea what caused this and if so a solution? Was there a font that was replaced and thus needed a reboot and that has not been replaced on the snap program?

Hello !
Same thing here, and after reboot fonts are normal.
I dont use snaps, so all programs have normal fonts.
This is the first time i see that.

I don’t use a lot of snaps but I am currently using 2. One of them has no issue at all. The other is the only program that still has the squares.

After the update KMail won’t start with error “The Akonadi personal information management service is not operational”.

❯ akonadictl start                                                                                                                                                         [127]
org.kde.pim.akonadictl: Starting Akonadi Server...
org.kde.pim.akonadictl:    done.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
org.kde.pim.akonadiserver: Starting up the Akonadi Server...                                                                                                                     

❯ org.kde.pim.akonadiserver: database server stopped unexpectedly                                                                                                               
org.kde.pim.akonadiserver: Database process exited unexpectedly during initial connection!
org.kde.pim.akonadiserver: executable: "/usr/bin/mysqld"
org.kde.pim.akonadiserver: arguments: ("--defaults-file=/home/user/.local/share/akonadi/mysql.conf", "--datadir=/home/user/.local/share/akonadi/db_data/", "--socket=/run/user/1000/akonadi/mysql.socket", "--pid-file=/run/user/1000/akonadi/mysql.pid")
org.kde.pim.akonadiserver: stdout: ""
org.kde.pim.akonadiserver: stderr: "2021-09-28 12:38:43 0 [Note] /usr/bin/mysqld (server 10.6.4-MariaDB) starting as process 189459 ...\n"
org.kde.pim.akonadiserver: exit code: 1
org.kde.pim.akonadiserver: process error: "Unknown error"
org.kde.pim.akonadiserver: Shutting down AkonadiServer...
org.kde.pim.akonadicontrol: Application '/usr/bin/akonadiserver' exited normally...

This update has solved two of my issues:

  • Problems with keys when updating - I can update the system again.
  • When using kernels 5.., exactly every second reboot resulted in a black screen, but I could login by typing the password blindly. Now I’m using 5.10.68-1 and the problem’s gone.

Now I’ve been experiencing a minor issue:

  • As I don’t like the native resolution of my laptop (I need a bit bigger letters), I use a custom screen resolution, which I set via the graphical tool (XFCE); however, this setting is lost whenever I reboot.

another ivy bridge user here. you should consider upgrading kernel for FSGSBASE support which gives sizable performance improvements on intel chips since ivy bridge. i would recommend you install kernel 5.10 (both because it is latest LTS kernel and there were further FSGSBASE support improvements) the package is “linux510”

I’ve been using Manjaro 21 for about two weeks, and really like it. I did the big update a couple of days ago, and two faults have occurred that I don’t know how to fix:
Firstly, the sound no longer works on Chromium browser. It’s fine on Firefox, and my own videos;
Secondly, when I finish for the day, I use the sleep function. The computer goes to sleep, but I can’t wake it up again. I’ve tried different keys and combinations, but I end up having to do a hard shutdown by holding the on/off switch for six seconds.
Please help.
Thank you.

I had troubles with the optimus-manager. It won’t run anymore so i had to uninstall it and rely solely on offloader prime. I also had to reinstall ntfs3 package (dkms doesnt seem to cut the mustard despite successly reporting a rebuild).

Same issue here as well.
LightDM stopped autologin despite being enabled, and some icons only show as monochrome colored, Since I’m using menda-circle.
Otherwise everything run fine so far.
I’m using Manjaro XFCE.

rofi still (started ~two updates ago) has a problem that the typed text is invisible.

I forgot to mention that I am using KDE Plasma version.

I deleted the /home/.config/libreoffice folder without any success. Export still produces a blank pdf. The flatpak (same version as fresh) also works.

used versions:

When I’m waking up the computer from sleep, I have to press the power button (one short press). Sorry to mention this if you’ve already tried this, but reading your post I wasn’t sure if you did.

You should be able to edit and delete posts.

Thank you. I did try the power button, but maybe not for long enough. I’ll try it again tomorrow.

Thanks for the tip.