[Stable Update] 2021-08-27 - Kernels, Cutefish, NetworkManager, Gnome, Pamac, Mesa, Browsers, Xorg-Server, LibreOffice

after the last update konsole is crashing on a startup with
konsole: symbol lookup error: /usr/lib/libkonsoleapp.so.21: undefined symbol: _ZN14KWindowEffects16enableBlurBehindEP7QWindowbRK7QRegion

also had rendering problems with OpenGL, as detailed in this post.
downgrading both xorg-server and xorg-server-common to 1.20.13-1 restored the system functionality.

After this update, my Dota 2 starts loads very slow, after it starts and the dota 2 logo shows it freezes with sound for like 1-2 min before the image comes. I rolled back all updates and the issue was gone.

Updated again, and the problem was back. I tried just to downgrade the xorg-server and xorg-server-common, but that did not help.

Any ideas what the issue could be?

The gnome-extension dash to panel has the issue after update of Gnome 40.4.
The bug was fixed → archlinux, after update gnome-shell from 40.3-1 to 40.4-1, the dashboard app list disappeared!!!! · Issue #1437 · home-sweet-gnome/dash-to-panel · GitHub

Yes, it was with gnome-shell-extension-dash-to-panel 43.r12.g81af73b-1. :wink:

1 Like

Since this update, I am having screen tearing issues with XFCE.
Can someone kindly help me with this? What settings or commands should I check?
Other than this, I have no other issues at my end.

Thanks in advance :slight_smile:

I fixed it using the steps mentioned here

Downgraded xorg-server and xorg-server-common.

From 1.20.13-3 down to 1.20.13-2.

I wonder why there is no bugfix in the meantime. And I wonder what changed between - these are only package releases.

1 Like

Here is where the changes are noted:


I built it without the Debian patches and my external display issue disappeared here with Intel Integrated Graphics (i915).

  Device-1: Intel 3rd Gen Core processor Graphics vendor: Dell driver: i915 
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300 

Happening for me as well on 5.13.12, though I’m not getting anything returned when issuing commands. Oddly enough,

$ echo 10 > /sys/class/backlight/intel_backlight/brightness

seems to still work, even when executed as a non-privileged user. That tells me that my udev rules for the backlight are still working fine. Very strange.

Edit to add:
This is happening on a laptop running Manjaro KDE, using the proprietary video-hybrid-intel-nvidia-prime v470.63.01.

Hi, I am having trouble with audio since the update. I have deleted my pulseaudio config tpl files and rebooted, but upon reboot my integrated speaker is detected as headphones.

inxi output

Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
Sound Server-1: ALSA v: k5.13.12-1-MANJARO running: yes
Sound Server-2: PipeWire v: 0.3.33 running: yes

Sound works flawlessly on 5.12 and i believe on previous 5.13 version, too

I’ve downgraded Network Manager from 1.32.10.-1 to 1.32.8-1
After upgrade NM wasn’t able to define WiFi device and configure connection.
WiFi adapter is Intel Wireless 8265.

As an update, installing acpilight replaces xbacklight with a python script that works, but needs sudo to run.