[Stable Update] 2021-08-27 - Kernels, Cutefish, NetworkManager, Gnome, Pamac, Mesa, Browsers, Xorg-Server, LibreOffice

One minor issue, a very little one.
I have xfce as DE, but after reboot, i ended with default xfce wallpapers (for each workspace) in /usr/share/backgrouds/xfce whereas my wallpapers are in my home partition, in another folder.
Not a big deal though.

1 Like

I have had this bluetooth problem for a long time, and it seemed solved until now. It looks as though bluez broke again.

I had issue with pamac-manager in KDE after update. It opened and immediately closed. Logs:

zsh: segmentation fault (core dumped) pamac-manager

I just reinstall pamac with this command:

sudo pacman -Sy pamac

pamac-gtk wasn’t installed.
pamac-manager I can’t reinstall because it doesn’t exist in pacman. I don’t why and how I can find it.

1 Like

Worked for me except for the first one. "no such directory’ I think it said.

Wallpaper went to xfce defaults for some reason.

After updating to the latest stable release my computer crashes after logging in (GDM). This is a hard crash and I am not able to open a virtual console (CTRL + ALT + F3). I also was experiencing the problem of Telegram not starting due to some missing library, but I installed it 3 days before this update.

I have found and resolved the problem:

Telegram is now working after the update.

After updating and rebooting I got the error message “Failed to start Light Display Manager.” Changing kernels allowed LightDM to run again. I was running 5.10.60-1 and changed to 5.4.142-1.

For me, at the end, it just reinstalled my old keyring, and no update. I also tried removing the libcanberra packages.

Edit: The update went smoothly on my other machine, so i decided to refresh my mirrors.
That got it going.

I was getting some keyring issues through pacman, then I used pamac for update and all went smooth.


After update LightDM started using very low resolution on greeter on a multi-head setup (original laptop screen 2160x1440 and external monitor 3840×2160). Multi-head support had never been great before on my setup with mixed resolutions, where the login box would be misplaced on the external monitor, but this just got worse by showing the login box at what looks like VGA resolution on both displays (very blurry and distorted image output). Only happens when external monitor is connected, else it uses correct resolution for laptop. After login all works well on my Manjaro XFCE setup, and correct resolutions are picked up. I ended up replacing gtk-greeter with mini-greeter (making the issue less noticeable).


Same issue on my laptop (Intel i5-8265U, UHD 620 Graphics, Driver OpenGL 4.6 Mesa, FHD Screen). No helpful log entries, just "lightdm.service: Failed with result ‘exit-code’. ", repeated several times.
But I was able to open a console screen (ALT-Ctrl-F2), and tried to get more information.
Started lightdm manually (as root)

lightdm --test-mode --debug

This gave some debug infos (but nothing pointed to a cause for the issue) - nevertheless lightdm started up and gave me a desktop “as usually”. After logging out from lightdm, I rebooted the laptop, and after that I was able to login normally. Lightdm seems to be working fine now - I just don’t know why it didn’t before… :thinking:

1 Like

I had the same issue and solved it for me:

pacman -S lightdm-gtk-greeter
systemctl enable lightdm

So for some reason my Pamac can’t find the updates, but instead tells me that my system is up-to-date. By checking the detailed list of updated packages from the opening post, I can tell, however, that this is not the case and that the packages are still from the previous stable update—the ones I picked for reference anyway.

Is there anything I can do here to nudge Pamac/Pacman to update or should I just wait for it to “wake up”?

sudo pacman-mirrors -f 5
pamac update

That did the trick. Thank you kindly, good sir. :slight_smile:

After the update, my two monitors had been swapped, so the secondary monitor was the first. This was caused by xorg-server / xorg-server-common. No big deal, can easily be corrected in screen settings.

1 Like

It was already posted in the announcement:

what you did was change to the fastest 5 mirrors in your area, at this point in time which might lag again next time, so:

  • check the mirrors for your location!

  • use

    sudo pacman-mirrors --country Country1,Country2 --interactive

    to manually take the fastest and up-to-date mirrors in your and any other neighbouring countries

  • keep doing that until you’ve found the fastest and stablest mirrors for you! :innocent:

  • the Manjaro team does not manage these mirrors: they are managed by local volunteers contributing to the team.

cc @admdb :point_up:


1 Like

Interesting. I have had this issue with LightDM failing to load intermittently since kernel 5.11 was introduced and on only 1 specific laptop (I have 7 machines running Manjaro).

I always wrote it off as some sort of esoteric timing issue, because sometimes it would fail 5 times in a row and then not once for a week. Sometimes it would keep failing on one specific kernel and switching to another kernel would instantly boot the laptop, but a week later that kernel would suddenly have LightDM fail.

I was too busy with work to post about the issue and usually one or two reboots would have my laptop working, so that has been my workaround for quite a while now.

Click open for inxi details
$ inxi -Fxzc0
System:    Kernel: 5.13.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: Cinnamon 5.0.5 
           Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: Dell product: XPS 13 7390 v: N/A serial: <filter> 
           Mobo: Dell model: 0G2D0W v: A00 serial: <filter> UEFI: Dell v: 1.9.0 date: 06/11/2021 
Battery:   ID-1: BAT0 charge: 35.4 Wh (71.8%) condition: 49.3/52.0 Wh (94.8%) volts: 8.5 min: 7.6 
           model: SMP DELL G8VCF6C status: Charging 
           Device-1: hid-98:fd:b4:7a:93:66-battery model: ThinkPad Bluetooth Laser Mouse charge: N/A 
           status: Discharging 
CPU:       Info: Quad Core model: Intel Core i7-10510U bits: 64 type: MT MCP arch: Kaby Lake note: check rev: C 
           cache: L2: 8 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 36812 
           Speed: 700 MHz min/max: 400/4900 MHz Core speeds (MHz): 1: 700 2: 1990 3: 1098 4: 800 5: 777 6: 1575 
           7: 700 8: 700 
Graphics:  Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 
           Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo bus-ID: 1-5:2 
           Device-3: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 5-2.3.3:6 
           Display: x11 server: X.Org 1.20.13 driver: loaded: modesetting resolution: 1: 1920x1080~60Hz 
           2: 3840x2160~60Hz 
           OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 21.2.1 direct render: Yes 
Audio:     Device-1: Intel Comet Lake PCH-LP cAVS vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 
           Device-2: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 5-2.3.3:6 
           Device-3: Realtek USB Audio type: USB driver: snd-usb-audio bus-ID: 5-2.3.4:7 
           Sound Server-1: ALSA v: k5.13.12-1-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.33 running: no 
Network:   Device-1: Intel Wi-Fi 6 AX200 vendor: Rivet Networks driver: iwlwifi v: kernel port: efa0 bus-ID: 02:00.0 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 bus-ID: 6-2.4:4 
           IF: enp62s0u2u4 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-7:3 
           Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 357.17 GiB (74.9%) 
           ID-1: /dev/nvme0n1 vendor: SK Hynix model: PC601 NVMe 512GB size: 476.94 GiB temp: 44.9 C 
Partition: ID-1: / size: 467.01 GiB used: 357.01 GiB (76.4%) fs: ext4 dev: /dev/dm-0 mapped: cryptroot 
           ID-2: /boot size: 968.3 MiB used: 127.1 MiB (13.1%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-3: /boot/efi size: 499 MiB used: 36.6 MiB (7.3%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: file size: 16 GiB used: 0 KiB (0.0%) file: /swapfile 
Sensors:   System Temperatures: cpu: 41.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 0 fan-2: 0 
Info:      Processes: 266 Uptime: 9m Memory: 15.33 GiB used: 2.53 GiB (16.5%) Init: systemd Compilers: gcc: 11.1.0 
           clang: 12.0.1 Packages: 1682 Shell: Bash v: 5.1.8 inxi: 3.3.06 
1 Like

I also had the problem that LightDM failed during startup.
For me adding logind-check-graphical=true to the [LightDM] section in /etc/lightdm/lightdm.conf did the trick.

1 Like

This resolved this issue for me: Lightdm failed to start with Kernel 5.11.14 - #10 by philm