[Stable Update] 2021-08-17 - Kernels, KDE Software, Nvidia, Firefox, Thunderbird, Mate

Hello community,

Another stable branch update with some usual updates for you. One of the highlights is the new Pahvo Release.

  • Most of our Kernels got updated. Note that 5.12 series is now marked EOL.
  • KDE Software got renewed: KDE Gear 21.08.0, KDE Frameworks 5.85.0
  • Wine is at 6.15
  • Mate 1.26.0 got released
  • Thunderbird and Firefox got renewed
  • Latest Nvidia driver brings in Vulkan fixes
  • A new AMDVLK driver update got added
  • Some KDE-git and Python updates
  • Other regular upstream updates

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux44 4.4.281
  • linux49 4.9.280
  • linux414 4.14.244
  • linux419 4.19.204
  • linux54 5.4.141
  • linux510 5.10.59
  • linux512 5.12.19 [EOL]
  • linux513 5.13.11
  • linux514 5.14-rc6
  • linux510-rt 5.10.52_rt47

Package Updates (Mon Aug 16 17:20:11 CEST 2021)

  • stable community x86_64: 533 new and 483 removed package(s)
  • stable core x86_64: 29 new and 29 removed package(s)
  • stable extra x86_64: 692 new and 855 removed package(s)
  • stable kde-unstable x86_64: 358 new and 358 removed package(s)
  • stable multilib x86_64: 15 new and 15 removed package(s)

A list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

New issues:

  • You might have issues to install this update by missing Maintainers keys. A possible solution might be:
sudo rm -r /etc/pacman.d/gnupg
sudo pacman-key --init
sudo pacman-key --populate manjaro
sudo pacman-key --populate archlinux
sudo pacman -Syvv manjaro-keyring  # just to test for key-problems, as this would fail

However, we recommend to remove the signatures of the failed packages in /var/cache/pacman/pkg/ and get the replaced ones from the Build-Server:

sudo rm -v /var/cache/pacman/pkg/*.sig
sudo pacman -Syvv
  • You might be blocked updating when using pacman due to some libcanberra packages. Simply remove those packages: sudo pacman -Rdd lib32-libcanberra-pulse lib32-libcanberra-gstreamer libcanberra-pulse libcanberra-gstreamer. We recommend to use pamac anyway, which does this automatically: pamac update

  • Compiz packages like compiz-easy-patch got dropped from our repositories. Due to protobuf update you may need to rebuild that package locally on your end. Compiz-easy-patch removed from repos

No audio after Pulseaudio v15 update

Try clearing the databases in your home folder of any old settings by executing:

rm ~/.config/pulse/*.tdb ~/.config/pulse/cookie

Reboot afterwards.

Nextcloud problem and workaround

After upgrading mariadb to 10.6.3-1 and executing

sudo systemctl restart mariadb.service && sudo mariadb-upgrade -u root -p

Nextcloud doesn’t work anymore showing several errors, all of them related to “InnoDB refuses to write tables with ROW_FORMAT=COMPRESSED or KEY_BLOCK_SIZE.

In /etc/my.cnf.d/server.cnf under section [mariadb] put:


Workaround found here: Arch Forum - [SOLVED] Issues on nextcloud 22.0.0 and mariadb 10.6

KDE logo in splash screen instead of Manjaro logo
  • Backup / remove the old ksplashrc file
  • mv ~/.config/ksplashrc ~/.config/ksplashrc.bak
  • Go to System Settings
  • Type in Splash
  • Click on Splash Screen
  • Select and Apply your desired splash screen
Telegram fails to open

Telegram fails with:

(telegram-desktop:6166): Telegram-WARNING **: 15:46:00.533: Application was built without embedded fonts, this may lead to font issues.
(telegram-desktop:6166): GLib-GObject-WARNING **: 15:46:00.619: cannot register existing type 'GtkWidget'
(telegram-desktop:6166): GLib-GObject-CRITICAL **: 15:46:00.619: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
(telegram-desktop:6166): GLib-GObject-WARNING **: 15:46:00.619: cannot register existing type 'GtkBuildable'
(telegram-desktop:6166): GLib-GObject-CRITICAL **: 15:46:00.619: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed
(telegram-desktop:6166): GLib-CRITICAL **: 15:46:00.619: g_once_init_leave: assertion 'result != 0' failed
(telegram-desktop:6166): GLib-GObject-CRITICAL **: 15:46:00.619: g_type_add_interface_static: assertion 'G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
(telegram-desktop:6166): GLib-GObject-CRITICAL **: 15:46:00.619: g_type_register_static: assertion 'parent_type > 0' failed

Upgrade to at least version Version 2.8.11-2.0 as that should fix the bug by executing:

pamac upgrade
KDE krunner and Alt+F1 issues


  • krunner does not work, no popup when typing on empty desktop and Alt+F2 shows an empty transparent window within a subdued black frame.
  • application launcher doesn’t open with Alt+F1, and when opened with mouse, the entries in the menu don’t work (restart, shutdown etc.).


  • Reboot through sudo reboot
  • remove from ~/.config :
    • kglobalshortcutsrc
    • krunnerrc
    • plasma-org.kde.plasma.desktop-appletsrc
  • change global theme and login screen to Breeze and reboot
  • login on tty and rm -rf ~/.cache
  • login on graphical screen
  • change global theme and login screen to Breath2 and reboot
KDE Plasma theme uses low contrast colors, harder to read


  • You normally use a dark Plasma theme and notice that text on your Plasma menus, widgets, and tray are more difficult to read due to a lower contrast (light grey on dark grey).

  • This is due to the newly applied Breath2 2021 Dark Plasma theme.

  • breath2-2021-dark


  • Switch back to your previously used Breath2 Dark or Breath Dark theme to bring back higher-contrast text.

  • System SettingsAppearancePlasma Style

  • breath2-original-dark

Dolphin fails to open Konsole using context menu action

Install kinit package.

pamac install kinit

Older Issues

  • OS prober does not run and add other operating systems

    Please click the ► at the beginning of this line to view this solution

    To restore, please execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

    For more information, see opening post in [Stable Update] 2021-03-08.

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: Graphics & Display - Manjaro Linux Forum or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.

Arch Linux - News: libtraceevent>=5.9-1 update requires manual intervention

OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

GDM does not start (black screen when booting gnome edition)

Log into your system via tty and depending on your use of Plymouth or bootsplash-systemd choose a option from this post


I didn’t know that 5.12.x is EOL. Updating now with Pamac CLI.

A post was split to a new topic: My Logitech MX Master 3 Wireless Mouse does not scroll well

I got the missing key error in pamac, but then none of the packages failed to install, so i don’t need to do anything then?

1 Like

Konsole instantly segfaults when I try to run it.

Here’s the output from my terminal when I try running console:

[user@user-pc ~]$ konsole -v && konsole
konsole 21.08.0
Segmentation fault (core dumped)

Mine works fine.
Try removing ~/.config/konsolerc file and ~/.local/share/konsole folder.


EDIT: Turns out the culprit is most likely “Remember window size” OFF, with it turned on, I can launch console with a customized default profile.
Thanks “dalto” from EndeavourOS forum ^_^ (link)

How should I go about fetching more info useful for developers, if needed?

Original post before I edited it

On my machine, I found out that the Segmentation Fault is caused with the following line at the top of “konsolerc”

[Desktop Entry]

Removing “Breath2.profile” makes it work again. I can keep my profile but have to switch to it every time I open Konsole, ha…
No matter what I do, I can’t get Konsole to start if I set a custom default profile, even a brand new one. But in the meantime, it works with the… erm, default default profile if that makes sense :sweat_smile:

This worked for me. I just removed the line where I had my default profile to be my custom profile. I have to remake my profile again, but at least I can stop using Kate’s terminal function as my main terminal. Thanks to you and ddns above.

1 Like

Sorry, should have clarified from the get go I can keep using my old profile, just need to switch to it manually; BUT!

I just had a look at the EndeavourOS forum, and some smart folks there figured out having “Remember window size” OFF while ALSO auto-loading a profile will make Konsole segfault. So for now, we gotta live with remembering window size I suppose! Adding this to my post now.

A post was split to a new topic: Some of my shortcuts stopped working

I had some issues with my Latte Dock layout getting messed up. I fixed that, but my system tray icons are still a little too small- not unreadable, just weird looking. I can probably fix that as well, but just a heads up to anyone reading.

A post was split to a new topic: OpenMW not starting game

Is the “Remember window size” option on the konsolerc file? I don’t seem to have it. Would I need to add it?

Everything went fine with a KDE/Nvidia system. No problems with konsole for me.

I noticed a big performance improvement after the update.


Notice performance boost on laptop with battery Ryzen 3/KDE. Update super smooth!

1 Like

Some settings seem to have been reset. E.g. when maximizing windows, the titlebar was set to disappear. That is no longer the case.

Having issue with system tray icon size.

The padding on the images seems to have been made smaller; taskbar icon sizes were unchanged. Is it related to the Plasma theme change? How can I change the size back to the previous state, though?

For now, I will stay on the 2021-08-09 release.

1 Like