[Stable Update] 2021-07-28 - Kernels, Plasma 5.22.4, Systemd, Cinnamon, Firefox, LibreOffice

Idle screen-locking no longer works on KDE after the update.

/edit: “Sometimes” it works, sometimes the screen stays on for hours.
I havent been able to really figure out whats causing it yet…

One issue I dont understand: I’m wire-connected to the modem, never needed a password. Now, it asks a pasword. Better put: it notes that I need a password to log in. While I’m fully connected. Even though speeds fluctuate…

Manjaro repo timeshift-autosnap now by default is disabled when you are not using btrfs. How about … I don’t know… warn us before just basically disabling timeshift before updates?

1 Like

Are you using Manjaro KDE? If so, do you get a dialog box asking for a password right when you log in?

The sad thing is Matti Hyttinen only forked it for adding that evil setting. Even without proper explanation.

In the past, it was only in the AUR. Unfortunately pacman and alternatives prefer to install packages from the repos over the packages from the AUR. So the Manjaro team sorta “hijacked” the installations of that package.

pulseaudio-modules-bt no longer works. If you have issues connecting to your bluetooth speaker or headset, try installing pulseaudio-bluetooth:

sudo pacman -Syu
sudo pacman -R pulseaudio-modules-bt
sudo pacman -S pulseaudio-bluetooth

If it still doesn’t work, try installing pipewire as explained here: Pipewire-pulse installation problem

Have seen this done before also with few other -git packages :unamused:
From top of the head mesa-git hijack caused a lot of problems and confusion – ESPECIALLY since it wasn’t even a live -git build helper like AUR version, but rather just a static snapshot that didn’t have anything to do with current git version.
Really wish they did -manjaro version instead of hijacking AUR packages with the same name.

4 Likes

if you specifically installed pulseaudio-modules-bt in the past for high fidelity codecs (aptx-*, ldac, etc.) and looking for alleged pulseaudio 15.0 support for the same its not coming. it only supports SBC and SBC_HQ with arch maintainers dropping support for additional libraries required for the same.

pipewire supports all codecs out of the box

You are making a good point, having it as separate package would make sense. I didn’t think about the fact that the existing installations might be affected.

It is not evil, it was necessary for having timeshift-autosnap in new installations by default. And it was not the only reason. The original seems practically unmaintained, so I took it over. Now we can add any new features we need or want.

4 Likes

@deemon @RoestVrijStaal

timeshift-autosnap-manjaro has replaced timeshift-autosnap in all branches. The latter is still available in the AUR if you don’t want to use the Manjaro version.

3 Likes

when switching the layout, the value on dash to panel does not change

1 Like

A post was split to a new topic: What happened to the forum?

@linux-aarhus - Thanks for taking the time to split the thread. I don’t intend to restart the conversation here. This is just letting people know that, I shared the opinion and went to work and couldn’t reply to the thread. Would’ve loved to share my opinions and some answers at least but the thread is locked now.

I am genuinely surprised (seriously not mocking) that my comment wasn’t hidden. So I appreciate the thread anyways. :v:

3 Likes

I have some signature errors and I cannot fix it the usual way. I tried both pamac and pacman.
Here my last attempt after empty the /var/cache/pacman/pkg directory:

(201/201) checking keys in keyring                                                                              [##################################################################] 100%
(201/201) checking package integrity                                                                            [##################################################################] 100%
error: nvidia-utils: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is unknown trust
:: File /var/cache/pacman/pkg/nvidia-utils-470.57.02-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: 0ad: signature from "Brett Cornwall <brett@i--b.com>" is unknown trust
:: File /var/cache/pacman/pkg/0ad-a24.b-7-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: libxnvctrl: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is unknown trust
:: File /var/cache/pacman/pkg/libxnvctrl-470.57.02-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: linux-firmware: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is unknown trust
:: File /var/cache/pacman/pkg/linux-firmware-20210719.r1990.168452e-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: linux512: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is unknown trust
:: File /var/cache/pacman/pkg/linux512-5.12.19-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: linux512-headers: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is unknown trust
:: File /var/cache/pacman/pkg/linux512-headers-5.12.19-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: linux513: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is unknown trust
:: File /var/cache/pacman/pkg/linux513-5.13.5-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: linux513-headers: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is unknown trust
:: File /var/cache/pacman/pkg/linux513-headers-5.13.5-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: pacman: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is unknown trust
:: File /var/cache/pacman/pkg/pacman-6.0.0-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: mhwd-nvidia-390xx: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is unknown trust
:: File /var/cache/pacman/pkg/mhwd-nvidia-390xx-390.144-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: mhwd-nvidia: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is unknown trust
:: File /var/cache/pacman/pkg/mhwd-nvidia-470.57.02-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: opencl-nvidia: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is unknown trust
:: File /var/cache/pacman/pkg/opencl-nvidia-470.57.02-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: snapd: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is unknown trust
:: File /var/cache/pacman/pkg/snapd-2.51.3-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

Is there some error from my mirror?

❯ pacman-mirrors
Pacman-mirrors version 4.21.2
Local mirror status for stable branch
Mirror #1   OK  05:55   France  http://ftp.free.org/mirrors/repo.manjaro.org/repos/
Mirror #2   OK  17:14   France  https://manjaro.ynh.ovh/

I ran into the same exact problem when I updated a few days ago. Using sudo pacman -Syu archlinux-keyring manjaro-keyring before doing anything else with the upgrade worked for me.

Still nothing:

error: manjaro-keyring: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is unknown trust

Do I need to add it’s signature manually? That seems weird…

As far as I know, that key was just expired. Try running sudo pacman-key --refresh-keys (it will take a while), and see if you can proceed with your upgrade.

(Edit: fix typo in command)

It took a while, but no updates regarding that key as I still have the same errors.

Why am I alone having these errors :mega: ? :roll_eyes:

OK, how about let’s try following the steps as explained in the wiki page Pacman troubleshooting - Manjaro, but do step 2 only at the end.

To be fair, it also took me a while to get this sorted including following the steps above.

I changed my mirror and I followed the procedure. Here is the log, still a problem:

❯ sudo rm -rf /var/cache/pacman/pkg/*
❯ sudo rm -r /etc/pacman.d/gnupg
❯ sudo pacman-key --init
gpg: /etc/pacman.d/gnupg/trustdb.gpg: trustdb created
gpg: no ultimately trusted keys found
gpg: starting migration from earlier GnuPG versions
gpg: porting secret keys from '/etc/pacman.d/gnupg/secring.gpg' to gpg-agent
gpg: migration succeeded
==> Generating pacman master key. This may take some time.
gpg: Generating pacman keyring master key...
gpg: key FFD34F59C5695F04 marked as ultimately trusted
gpg: directory '/etc/pacman.d/gnupg/openpgp-revocs.d' created
gpg: revocation certificate stored as '/etc/pacman.d/gnupg/openpgp-revocs.d/41DC11BA0D15615059B15074FFD34F59C5695F04.rev'
gpg: Done
==> Updating trust database...
gpg: marginals needed: 3  completes needed: 1  trust model: pgp
gpg: depth: 0  valid:   1  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 1u
❯ sudo pacman -Syy gnupg archlinux-keyring manjaro-keyring
:: Synchronizing package databases...
 core                                                                               170,6 KiB  1004 KiB/s 00:00 [##################################################################] 100%
 extra                                                                             1901,8 KiB  8,08 MiB/s 00:00 [##################################################################] 100%
 community                                                                            6,6 MiB  14,8 MiB/s 00:00 [##################################################################] 100%
 multilib                                                                           177,4 KiB  2,17 MiB/s 00:00 [##################################################################] 100%
:: Some packages should be upgraded first...
resolving dependencies...
looking for conflicting packages...

Packages (1) archlinux-keyring-20210802-1

Total Download Size:   0,94 MiB
Total Installed Size:  1,33 MiB
Net Upgrade Size:      0,00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 archlinux-keyring-20210802-1-any                                                   959,1 KiB  2,18 MiB/s 00:00 [##################################################################] 100%
error: failed retrieving file 'archlinux-keyring-20210802-1-any.pkg.tar.zst' from mirror.futureweb.be : 
(1/1) checking keys in keyring                                                                                  [##################################################################] 100%
downloading required keys...
:: Import PGP key 6D42BDD116E0068F, "Christian Hesse <arch@eworm.de>"? [Y/n] 
(1/1) checking package integrity                                                                                [##################################################################] 100%
error: archlinux-keyring: signature from "Christian Hesse (Arch Linux Package Signing) <arch@eworm.de>" is unknown trust
:: File /var/cache/pacman/pkg/archlinux-keyring-20210802-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

warning: manjaro-keyring-20210622-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (3) archlinux-keyring-20210802-1  gnupg-2.2.29-1  manjaro-keyring-20210622-1

Total Download Size:    3,43 MiB
Total Installed Size:  11,43 MiB
Net Upgrade Size:       0,00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 gnupg-2.2.29-1-x86_64                                                                2,4 MiB  9,36 MiB/s 00:00 [##################################################################] 100%
 archlinux-keyring-20210802-1-any                                                   959,1 KiB  14,2 MiB/s 00:00 [##################################################################] 100%
 manjaro-keyring-20210622-1-any                                                     128,8 KiB  5,47 MiB/s 00:00 [##################################################################] 100%
 Total (3/3)                                                                          3,4 MiB  8,80 MiB/s 00:00 [##################################################################] 100%
(3/3) checking keys in keyring                                                                                  [##################################################################] 100%
downloading required keys...
:: Import PGP key FC1B547C8D8172C8, "Levente Polyak <anthraxx@archlinux.org>"? [Y/n] 
:: Import PGP key 428F7ECC7117F726, "Helmut Stult <helmut@manjaro.org>"? [Y/n] 
(3/3) checking package integrity                                                                                [##################################################################] 100%
error: gnupg: signature from "Levente Polyak <anthraxx@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/gnupg-2.2.29-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: archlinux-keyring: signature from "Christian Hesse (Arch Linux Package Signing) <arch@eworm.de>" is unknown trust
:: File /var/cache/pacman/pkg/archlinux-keyring-20210802-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: manjaro-keyring: signature from "Helmut Stult (schinfo) <helmut.stult@schinfo.de>" is unknown trust
:: File /var/cache/pacman/pkg/manjaro-keyring-20210622-1-any.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] 
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

I also checked my datetime, and it’s ok:

❯ date +%x-%X
06/08/2021-09:32:31