[Stable Update] 2021-07-23 - Kernels, Nvidia, Mesa, Wine, Firefox, Thunderbird, Virtualbox

For Mozilla Firefox (KDE) User that missed the old GTK Scrollbar since the last stable release and want it back, check this out:

1 Like

I don’t see why 5.13 would need the new libusb, regardless of what mhwd reports. I would do as Fabby suggested in the thread you linked:

And remember to have a fully functional backup of your current state, just in case.

1 Like

Sounds like a bug in mhwd to me then. I followed the recommendation to unignore-update-ignore procedure. But I think this shouldn’t be necessary. I could change the Kernel now and everything is fine now.

I had, this the link:

Holding off the update until there are somewhat less issues…
(feeling somewhat uncertain…)
(post made to get follow-ups)

I don’t know why you’ve decided I need a basics lesson, I have been using linux since ~2007.

By “the devs” I’ve meant the KDE team. I know what upstream is.

1 Like

Kernel 513 and latest Nvidia drivers seem to do not like each other. After the update, my external display did not work. Switched back to 512, everythings fine.

1 Like

mhwd-kernel only hints that some packages have upgrades available but it’s not required to go through with it

you can typically bypass the nagging by answering the prompt accordingly

After the update, when opening a terminal, I get

opam: too many arguments, don't know what to do with `^', `/dev/null'
Usage: opam env [OPTION]... 
Try `opam env --help' or `opam --help' for more information.
~ $

EDIT: Not just when I open a terminal. Also after any command is run.

EDIT2: I “fixed” it by removing ~/.opam/opam-init/env_hook.fish

1 Like

As said before, it required it. There was no prompt. When tried to install the Kernel with mhwd, I got just the answer that the system needs an update with the hint to libusb. And that’s it. mhwd ends there and I can’t do anything.

Edit: I just tried it again now, and now I get the prompt. But I didn’t got it before!! Otherwise I would not create this discussion here for no reason. This prompt is new or there was bug where the prompt didn’t appear.


[quote="[HowTo] become a Manjaro power user when you’re a wizard at Windows but a N00b at Manjaro / Linux, post:1, topic:13646"]
Why can’t I make Windows jump through fiery hoops like I do with Linux???

Escpecially this :grin:

1 Like

Seems that with Kernel 5.13.4, finally suspend/resume is fixed on recent AMD chips.
For more than a quarter of a year now, I was having issues with the laptop either not entering sleep, or not waking up (freezing) or both. Only solution I had was staying on 5.11.6 or going back to 5.10 series (which was also affected for several weeks at some point).
Now they finally fixed it after breaking it so many weeks ago.
Upside: laptops with modern standby might work better now, too.

1 Like

I can’t run telegram
It gives me this error:

telegram-desktop: symbol lookup error: /usr/lib/libgiomm-2.4.so.1: undefined symbol: _ZN4Glib17SignalProxyNormal13connect_impl_EbON4sigc9slot_baseEb

Downgrade didn’t work

I am using manjaro KDE 21.1 on Lenovo Legion 5 15ARH05 Ryzen 7 4800H + Nvidia 1650GTX. After the update when the system boots the login screen stays black with only mouse cursor showing for about a minute then it flashes 2-3 times and displays the login screen but with wrong DPI. Sometimes when the login page got displayed the cursor disappears. After successful login the cursor is there and the touchpad is working again, but NetworkManager is not started. I restart it with sudo systemctl restart NetworkManager and it runs fine after that. The UI is working normally.
I am using optimus sddm switch to switch to Nvidia only mode so I can use the HDMI and display port over type-C but if I put my system to sleep black login screen again that never resumes. So i cannot login again after wake from sleep. If I switch to AMD only mode when the system is wake from sleep everything works fine, the login screen shows immediately and i can login and proceed with my work.

I tried to downgrade to archive repos back until July Six but the situation is not changed.

The situation is identical with kernel 5.10 and 5.12 and 5.13

If someone can point me to fix my system i will appreciate it very much as this is my daily driver and am working on my machine also.

All these happened after and update through sudo pacman -Syyu on Friday night.

I am using Manjaro KDE for over and year now after switch from KDE NEON and this is the first time i have such problems. Beside the current problems the system works awesome so congratulations to the team for their good work.

1 Like

I had a similar experience, systemd getting borked and had to manually turn the computer off despite it being ‘responsive’.

Same here, but using KDE and optimus notebook (nvidia mode) with 2 monitors (hdmi).

Not sure, but guess my freeze is somehow related to Tilling Extension and Virtual Desktop.

When opening some kind of windows together (I think it doesn’t go well with tilling, eg. Lutris, Steam) and changing desktop causes the freeze. Entering tty2 and looking into htop I see Xorg using 100% of the cpu.

For now turning off Tilling Extension seems to solve the freezes.

I’m currently experience a serious issue with the latest nvidia driver, 470.57.02. My system consists of a Ryzen 5 1600 CPU and a GeForce GTX 1070 GPU (should be supported by the driver according to nvidias list over supported GPU:s).
When I try to launch xorg, either by letting gdm starting it or by running startx/xinit in tty2 I get the following error:

(EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:35:0:0.  Please                                
(EE) NVIDIA(GPU-0):     check your system's kernel log for additional error                                   
(EE) NVIDIA(GPU-0):     messages and refer to Chapter 8: Common Problems in the                               
(EE) NVIDIA(GPU-0):     README for additional information.                                                    
(EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!                                          
(EE) NVIDIA(0): Failing initialization of X screen   

and later:

(EE) Screen(s) found, but none have a usable configuration.                                                   
Fatal server error:                                                                                           
(EE) no screens found(EE)      

The only kernel error related to nvidia I find in the journal is:

kernel: NVRM: GPU 0000:23:00.0: RmInitAdapter failed! (0x26:0x56:1262)       
kernel: NVRM: GPU 0000:23:00.0: rm_init_adapter failed, device minor number 0

Chapter 8 in the nvidia documentation, as suggested by the error to read, do not mention the error I have. I have looked all over the forum, but the only similar problems I can find seem to all be related to dual GPU Optimus laptops (which is not relevant in my case since the 1070 is the only GPU in the system).

I have tried to reinstall Manjaro, and it works outbox with nvidia, but that is the old driver, 465.31, and as soon as I update to the latest version the problem reoccurred. I have tried changing kernel from 510 to 54, 512, 513 and 514, but the problem remains. I tried to downgrade the driver to 465.31, by using the old pacman packages in /var/cache/pacman/pkg, but then the kernel was not able to find the nvidia drivers. After some extra research on the forum and on google it seems that it is not possible to downgrade the drivers that way.

I can use the free-drivers for now and get xorg up and running, but then I can’t use any graphics heavy applications like games, but I can at least do my work (since I don’t do any graphic intensive stuff, just editing some LaTeX, some programming and accessing super-computers through ssh). I will have to live with the situation to the weekend since I do not have time to deal with it right now.

Oh, I forgot to mention, I have no trouble with using the live-usb I used for reinstallation and the proprietary driver, but again that is the old one, 465.31. The xorg-server, however, is the same version, 1.20.11-1, in all instances, so I know that it should work with the old drivers.

initially failed to upgrade due to squashfs-tools. remove it and continue upgrading like usual. it works, nothing bad happened so far. btw I haven’t reinstall squashfs-tools.

Catfish 4.16.1 fails to execute: