[Stable Update] 2021-07-23 - Kernels, Nvidia, Mesa, Wine, Firefox, Thunderbird, Virtualbox

Bildschirmfoto vom 2021-07-23 20-04-10

1 Like

Sorry, I don’t understand. That’s my point precisely. This update includes already the updated package, but some people still have problems.

The update initially came with 2.8.11-2, which is buggy.
It was later updated to 2.8.11-2.0, which does not anymore have the bug (I can confirm it).

The patched version has not reached all the mirrors yet.


Ahhh, ok. Now I understand. Thanks! It didn’t occur to me that 2.8.11-2 and 2.8.11-2.0 were different

1 Like

Not an issue but after pacman -Syu , it is showing warning:
warning: inxi: local ( is newer than community (

10 posts were split to a new topic: How to manage a Rolling release from a user perspective

Oh boy! I checked for the Telegram update and installed it and now it doesn’t work! :smiley:

(telegram-desktop:31020): Telegram-WARNING **: 21:24:03.337: Application was built without embedded fonts, this may lead to font issues.
ALSOFT] (EE) Failed to set real-time priority for thread: Operation not permitted (1)
error: : cannot open
error: : cannot open
error: : cannot open
qt.svg: Error while inflating gzip file: SVG format check failed
qt.svg: Error while inflating gzip file: SVG format check failed
qt.svg: Error while inflating gzip file: SVG format check failed
/usr/include/c++/11.1.0/bits/stl_vector.h:1045: std::vector<_Tp, _Alloc>::reference std::vector<_Tp, _Alloc>::operator[](std::vector<_Tp, _Alloc>::size_type) [with _Tp = int; _Alloc = std::allocator<int>; std::vector<_Tp, _Alloc>::reference = int&; std::vector<_Tp, _Alloc>::size_type = long unsigned int]: Assertion '__n < this->size()' failed.
fish: Job 1, 'LANG=C telegram-desktop' terminated by signal SIGABRT (Abort)

Just to be clear, version 2.8.11-2 worked fine but 2.8.11-2.0 doesn’t. Downgrading for now.

Xfce, Kernel 4.14.
Both Telegram 2.8.11-2 and 2.8.11-2.0 works fine here.

1 Like

Yes, that works for me. Manjaro Gmome here.

My system boots to a blank screen. I can use ctrl-alt-F2 to switch TTY and then login and run startx. X starts and everything is fine. Gnome/Wayland

Also, my mouse buttons for forward / back are suddenly swapped.

[     4.220] (EE) systemd-logind: failed to take device /dev/dri/card0: Device or resource busy
[     4.220] (EE) /dev/dri/card0: failed to set DRM interface version 1.4: Permission denied
[     4.227] (EE) Failed to load module "fbdev" (module does not exist, 0)
[     4.228] (EE) Failed to load module "vesa" (module does not exist, 0)
[     4.231] (EE) Screen 0 deleted because of no matching config section.
[     4.343] (EE) modeset(0): glamor initialization failed
[     4.346] (EE) modeset(0): drmSetMaster failed: Permission denied

Edit: Both issues went away by themselves, no idea what happened. (Yes, I already rebooted several times before I wrote this initially.)

1 Like

Usando Telegram(version portable 2.8.10 descargada de la pagina oficial de Telegram, no uso la del repositorio de manjaro) en XFCE sin problemas.

Using Telegram (portable version 2.8.10 downloaded from the official Telegram website, I don’t use the one from the manjaro repository) in XFCE without problems.

WebGL no longer works on Firefox. The WebGL aquarium demo gives the following error:

It does not appear your computer supports WebGL.
Click here for more information.

Status: WebGL creation failed: * WebglAllowWindowsNativeGl:false restricts context creation on this system. () * Exhausted GL driver options. (FEATURE_FAILURE_WEBGL_EXHAUSTED_DRIVERS)

In Firefox about:config, webgl.disabled was set to false. WebGL still runs normally on Chrome.

The following workaround to re-enable WebGL on Firefox is successful
Setting webgl.force-enabled to true in Firefox about:config


A post was split to a new topic: How to manage AMD GPU drivers on a rolling release?

Update went smooth for me. Thank you Manjaro Team!

Hello, has the hard freezes due to the linux firmware for Amd CPU’s been fixed? I have downgraded to the march linux-firmware to fix this freeze where the only option is to force shut down the system.

2 posts were merged into an existing topic: How to manage a rolling release from a user perspective

If you meant the GPU-freezes: Nope.

1 Like

Why do I always have to think of Albert Einstein?


After updating:

Running Steam on manjarolinux 21.1.0 64-bit
STEAM_RUNTIME is enabled automatically
Steam runtime environment up-to-date!
Error: You are missing the following 32-bit libraries, and Steam may not run:
Steam client's requirements are satisfied
WARNING: Using default/fallback debugger launch

I have already attempted to sudo pacman -S lib32-glibc

Using a 3090, mhwd -li output:

> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting            2020.01.13                true            PCI
          video-nvidia            2020.11.30               false            PCI
            video-vesa            2017.03.12                true            PCI
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!


Sat Jul 24 02:47:34 2021       
| NVIDIA-SMI 470.57.02    Driver Version: 470.57.02    CUDA Version: 11.4     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:09:00.0  On |                  N/A |
|  0%   49C    P8    35W / 350W |    367MiB / 24265MiB |      5%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A      1639      G   /usr/lib/Xorg                     229MiB |
|    0   N/A  N/A      4025      G   /usr/bin/kwin_x11                   4MiB |
|    0   N/A  N/A      4091      G   /usr/bin/plasmashell               64MiB |
|    0   N/A  N/A      4184      G   /usr/bin/nvidia-settings            0MiB |
|    0   N/A  N/A      5912      G   ...AAAAAAAAA= --shared-files       60MiB |

edit: Not sure what happened, but if someone finds this via google some day, some combination of renaming my ~/.steam and ~/.local/share/Steam folders to a backup, then re-running Steam, then moving them back over fixed it.


Most likely a Steam issue, probably fixed by resetting Steam steam --reset (which you kinda manually did but not really).