[Stable Update] 2021-06-14 - Kernels, Browsers, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire, Haskell

I updated the system using pamac which was apparently good, but on reboot I get the kernel panic. Now I am going to try the solution in [Stable Update] 2021-06-14 - Kernels, Browsers, Mesa, Deepin, Systemd, Gnome Apps 40.2, Pipewire, Haskell - #15 by simonb

MkInitCpio issue I’ve to fix. We don’t have all kernels supporting zstd compression by default.

1 Like

How can you do that when the system is in kernel panic and won’t boot?

Testing has mkinitcpio 29-1.0, so problem version seems to have skipped Testing.

Download an Installation image, write it to a flash drive and boot from that.

Issue with mkinitcpio fixed. Those who have kernel panics on old kernels, may need to get a Manjaro install media to fix it via chroot: Run live system start terminal run su to be root run manjaro-chroot -a edit etc/mkinitcpio.conf as shown in the link run mkinitcpio -P exit chroot and reboot.


Every body who’s going to update keep in mind that you need to use linux510 or above in order to boot after this update. If you have only linux54 or below hold on your horses and wait for a fix from philm or simply edit /etc/mkinitcpio.conf with uncommenting of the line #COMPRESSION="gzip" after the update, then do sudo mkinitcpio -P and only then reboot.

UPD: Ok disregard the above, philm nailed it.


nope, you nailed it for me as you explained clearly and succintly the steps required, so thank you kindly :pray:

Thanks also to Phil and all the manjaro team, and everyone who tried to help :pray:
back on track and now correctly updated thanks to you all.

1 Like

should we remove those packages?does pamac takes care of that?

I’m retriggering the ISO builds as 54 ISOs won’t boot with this issue on mkinitcpio.

1 Like

It did for me at least.

1 Like

As @omano has said earlier in this post, those two packages can be removed first, then sudo pacman -Syyu will run as expected, which is what I did. I don’t use pamac, but others have said that works too. I’ve always used pacman, so I followed the advice from @omano.

EDIT: @philm has updated post #2 to explain this issue and how to handle properly. He says pamac update is the recommended method.


I fixed it thanks to your solution. It is a bit cumbersome having to create a Live USB but otherwise easy to do. The line COMPRESSION="lz4" in etc/mkinitcpio.conf must be uncommented.

at first I can’t upgrade because of libcanberra. you need to manually remove packages that makes the upgrade failed, if you need to remove non libcanberra packages, you can reinstall them after removing old libcanberra files

i had same problem. you can remove lib32-libcanberra-gstreamer lib32-libcanberra-pulse libcanberra-gstreamer libcanberra-pulse manually and then install lib32-libcanberra libcanberra before proceeding with the system upgrade

EDIT: if it still has dependency after you try to remove those packages, remove them too and reinstall again with the new libcanberra packages

I am using the latest kernel with the latest LTS kernel as my fallback option (both are > kernel 5.9), so I uncommented the line COMPRESSION="zstd" in etc/mkinitcpio.conf to be consistent with Arch upstream defaults, then ran sudo mkinitcpio -P && sudo update-grub and rebooted, all good.

That being said, the Manjaro default of gzip (compatible with all kernels) or the Arch Wiki recommendations are great options too!

sudo pamac update has resolved the issue on my home desktop. thank you,

1 Like

I was able to do this to. Here’s my follow-up question…as a beginner user, I’m loath to make any changes to my kernel if I don’t have a reason to do it. After checking my settings it says I’m running Kernel 4.14.235-1.

I’m just a user that needs/wants a relatively stable system (as far as rolling releases OS like Manjaro are concerned). Don’t need or want to take a risk on the bleeding edge. Which LTS kernel should I be running?

Hello Philip,

Thanks for the mkinitcpio update. I realized the default compression method is again gzip in v30-2
I have 3 LTS kernels in my Manjaro systems (5.10 , 5.4 and 4.19) to be on the safe side.
The kernel panic is solved for 5.4 LTS, but I tested 4.19 LTS as well and it fails to boot.
“Failed to start rulebased for Device events and Files”
Please check on that one too.

i use 5.10 and it’s fine, and it seems to avoid the issue reported in this update with older kernels.