[Stable Update] 2021-05-19 - Kernels, Nvidia, KDE Frameworks, Plasma, Systemd, LibreOffice, KDE Gear Mobile, FF, TB

Manjaro awesome edition updated to latest stable 21.0.5: Release Manjaro awesome 21.05 stable · bittin/iso-build · GitHub

Spyder does not start, how to fix this?

Jawad ➜ spyder
Traceback (most recent call last):
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 568, in _build_master
ws.require(__requires__)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 886, in require
needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 777, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (decorator 5.0.7 (/usr/lib/python3.9/site-packages), Requirement.parse('decorator<5'), {'spyder-kernels'})

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/bin/spyder", line 33, in <module>
sys.exit(load_entry_point('spyder==5.0.0', 'gui_scripts', 'spyder')())
  File "/usr/bin/spyder", line 25, in importlib_load_entry_point
return next(matches).load()
  File "/usr/lib/python3.9/importlib/metadata.py", line 77, in load
module = import_module(match.group('module'))
  File "/usr/lib/python3.9/importlib/__init__.py", line 127, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
  File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 855, in exec_module
  File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
  File "/usr/lib/python3.9/site-packages/spyder/app/start.py", line 34, in <module>
from spyder.utils.external import lockfile
  File "/usr/lib/python3.9/site-packages/spyder/utils/external/lockfile.py", line 31, in <module>
from spyder.utils.programs import is_spyder_process
  File "/usr/lib/python3.9/site-packages/spyder/utils/programs.py", line 29, in <module>
import pkg_resources
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3243, in <module>
def _initialize_master_working_set():
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3226, in _call_aside
f(*args, **kwargs)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 3255, in _initialize_master_working_set
working_set = WorkingSet._build_master()
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 570, in _build_master
return cls._build_from_requirements(__requires__)
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 583, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python3.9/site-packages/pkg_resources/__init__.py", line 772, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'decorator<5' distribution was not found and is required by spyder-kernels
~
✗

is out of date : https://archlinux.org/packages/community/any/spyder/ we have same version
or downgrade python-decorator ?

After downgrading Python-decorator to 4.4.2-4 now Spyder launch just for few seconds then crashes :slightly_smiling_face:

Not sure if it’s relevant to post this here because I’m not sure it’s a distro specific bug, bug the fwupd package behavior completely changed after this update : I used to find several updatables components in the tool, and now with 1.6 and the added dependency fwupd-efi, it only shows an UEFI database (in terminal or in gnome-firmware).

Edit : sorry seems to be an normal behavior without AC plugged in…

1 Like

Update went smoothly, except for two little hiccups:

  1. The update server seemed extremely slow and it took my pamac 221 minutes to download the 1.3 GB of updates. My internet was not to blame, as everything else could access the full speed.
  2. After finally finishing the download, I encountered the same error as Thunderpants and igs with plasma-desktop-primex. Replacing primex with just plasma-desktop via sudo pacman -S plasma-desktop seems to have worked and the update went through without issue after that.

How to fix this?

error: failed to commit transaction (conflicting files)
/usr/share/locale/ta/LC_MESSAGES/kcm_autostart.mo exists in both 'plasma-workspace' and 'plasma-desktop-primex'
Errors occurred, no packages were upgraded.

I removed all KDE and k* packages, reinstalled Konsole. Nothing KDE related works…

So the post right above you. The second section. :wink:

Stabilising the nvidia driver with this known bug was a bad call. Spent all day trying to figure out what was wrong.

Edit: Got my stability back with the following:

sudo pamac install downgrade
DOWNGRADE_FROM_ALA=1 sudo downgrade linux510-nvidia nvidia-utils lib32-nvidia-utils

Say yes when it asks if you’d like to add the packages to the ignore list. If it doesn’t ask, add the package names to the IgnorePkg = line in /etc/pacman.conf:

IgnorePkg = linux510-nvidia nvidia-utils lib32-nvidia-utils
2 Likes

I was pointed to this post, but, unfortunately, it has nothing to do with me. I use a GEForce RTX 2070, and it doesn’t matter which monitor I use with the HDMI port (I unplugged my DP) my computer still crashes at startup and leaves me with a black screen of death.
I can’t NOT update the graphics card, as then, no matter what I try to install afterwords, it forces the update to the graphics card.
At this point, until this is resolved, I’m looking for a different Distro in hopes of getting a pc that I can actually use, instead of a hunk of parts sitting on my desk, unused.

I am still having the same issues and I’m too much of a new Linux user to really know where to even start troubleshooting.

I have tried:

  • Uninstalling plasma-desktop-primex and replace it with plasma-desktop via the pamac gui.
  • Doing the same via console as suggested by philm
  • And I also tried to just do a sudo pacman -S plasma-desktop before updating as usual as posted by fhonb

All of those end up with the same problem:

  • When I at first try to reboot my computer after the update, I get stuck with a blurred out screen from ksmserver-logout-greeting. I can still switch activities or alt+tab and open up Yakuake with f12.
  • The only way I’ve found to actually reboot is via bash command shutdown -r 0 or similar.
  • After rebooting I get my usual auto-started applications but no task bar, start menu etc. I can’t use alt+space to search for and start applications and I seem to have no desktop as it is completely black and can’t be interacted with in any way.

Any help or suggestions would be very welcome as I have no clue where to even start with this. For now I guess I’ll just rewind with timeshift and hold off on the update a while longer.

EDIT:
My issues were solved by replacing some left-over git packages with their non-git counterparts as posted below. (I thought I had done this previously but apperantly there were a few left that I didn’t know about).

1 Like

Now I have problems with stuff like icons missing, other kde features missing like plugins missing… is there any mega package I can install to get everything back?

qbittorrent: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.29’ not found (required by /usr/lib/libtorrent-rasterbar.so.10)

This is upsetting - now Sonarr is stuckkkkkk…

Edit… did ‘paru libtorrent-rasterbar’ and for some reason had the GIT installed!!! OMG - installed community again and everything is hunky dory.

I’m not sure why that happened…

How can I rewind the updates?

I have snapshots in Timeshift from before I updated that I use. I don’t know of any other way.

Found a solution that worked for me:

1 Like

Backups are a lesson you really only have to learn once, I’ve experienced 5 or 6 no-boot breakages with manjaro updates over the 3 or 4 years I’ve used it. Mainline arch didn’t used to break like that, I just cant be bothered to set everything up manually these days.

Download timeshift and timeshift-autosnap from the aur.

You dont have to setup automatic time schedule backups, but with autosnap, every time your system updates it will take a snapshot of right before, and if it breaks you can timeshift --restore to restore it.

4 Likes

Tried nvidia-dkms to build against the kernel with the same result, no-boot blackscreen.

I don’t know why this was promoted to stable, when 1 of the two main display types is broken on it

1 Like

This finally solved my problems! Thanks a lot!

Unfortunately, before I proceed to download the update I get this message on pamac GUI.

conflicting dependencies:
- virtualbox-guest-utils and virtualbox-guest-utils-nox are in conflict

What should be done in this case?

1 Like