[Stable Update] 2021-05-19 - Kernels, Nvidia, KDE Frameworks, Plasma, Systemd, LibreOffice, KDE Gear Mobile, FF, TB

I have an Nvidia GTX 960 with the proprietary driver and two 1080p monitors, one connected to HDMI and the other to DVI. Will I be okay applying this update?

I updated anyways and it all seems to be okay with my configuration and both my monitors seem to be working.
It was also my first stable update after installing Pipewire and it works alright.
So, no problems on my part with:

  • KDE Plasma
  • i5-4460
  • GTX 960
  • 16GB DDR3 RAM
  • Two 1080p monitors(HDMI, DVI)
1 Like

Lost compiz running on top of Mate. Mate is running fine, but compiz isn’t starting. Any help will be greatly appreciated.

EDIT: OK seems i solved it myself … killing pamac, remove db lock, removing the locally newer pamac version and sudo update-grub did the trick for me … at least it is still working after a reboot.

Original post:
Well … i tried to update but now pamac ist stuck :frowning:

Is it save to kill the task :(?
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-5.12-x86_64-fallback.img
==> Image generation successful
Updating Grub-Bootmenu
Generating grub configuration file …
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.12-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.12-x86_64.img
Found initrd fallback image: /boot/initramfs-5.12-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
It’s output will be used to detect bootable binaries on them and create new boot entries.
umount: /var/lib/os-prober/mount: das Ziel wird gerade benutzt.
rmdir: konnte ‘/var/lib/os-prober/mount’ nicht entfernen: Das Gerät oder die Ressource ist belegt
rmdir: konnte ‘/var/lib/os-prober/mount’ nicht entfernen: Das Gerät oder die Ressource ist belegt

After updating, my plasmashell (I think) doesn’t work. After splash screen I get black screen with no Plasma stuff, only cursor, sometimes I can open terminal over Yakuake if it starts automatically and then I can start other programs as usual, but still no task bar, workspaces desktops or anything.

plasmashell                                                                                                                                                                      130 ↵
plasmashell: symbol lookup error: /usr/lib/libKF5PlasmaQuick.so.5: undefined symbol: _ZN14KWindowEffects11slideWindowEP7QWindowNS_17SlideFromLocationEi
1 Like

Same problem here.
Not sure where to start no this one.

~ >>> kquitapp5 plasmashell && kstart5 plasmashell                                                                   
"Application plasmashell could not be found using service org.kde.plasmashell and path /MainApplication."
~ >>>
OS: Manjaro Linux x86_64                                                                
Kernel: 5.11.19-1-MANJARO                                                                  
Resolution: 3840x2160, 2560x1440                                                        
DE: Plasma                                                                              
WM: KWin                                                                                
Themes: Breeze Dark [Plasma], Breath [GTK2/3]                                            
Icons: breeze-dark [Plasma], breeze-dark [GTK2/3]                                       
Terminal: konsole Terminal Font: Noto Mono 10                                                             
CPU: AMD Ryzen 7 3800X (16) @ 4.200GHz  
GPU: NVIDIA GeForce RTX 2060  
Memory: 2827MiB / 32085MiB
1 Like

I upgrade my wifi card to AX210 on my X230 Thinkpad. The card isn’t usable until I rename / remove the following file.
iwlwifi-ty-a0-gf-a0.pnvm under /usr/lib/firmware/
I am on 5.11 now and it was the same with 5.12

Well … i now killed pacman as it won’t close on its own and cancel button was disabled.
I had to delete /var/lib/pacman/db.lck now sudo pacman -Syyu results in:
Warnung: pamac-cli: Lokale Version (10.1.2-0.1) ist neuer als extra (10.0.6-2)
Warnung: pamac-common: Lokale Version (10.1.2-0.1) ist neuer als extra (10.0.6-2)
Warnung: pamac-flatpak-plugin: Lokale Version (10.1.2-0.1) ist neuer als extra (10.0.6-2)
Warnung: pamac-gtk: Lokale Version (10.1.2-0.1) ist neuer als extra (10.0.6-2)
Warnung: pamac-snap-plugin: Lokale Version (10.1.2-0.1) ist neuer als extra (10.0.6-2)

Seems i got an anhealthy pamac? I will revert to the old version.

Me neither, and when something like this happens for the 3rd time in couple of months on a computer from work, it’s a problem. I noticed someone else posted the same problem in 13-5 update, no solution yet. And only three posts about this error, we’re not getting help any time soon Search results for '_ZN14KWindowEffects11slideWindowEP7QWindowNS_17SlideFromLocationEi' - Manjaro Linux Forum

Why would you even add nvdia drivers update if it’s not ready yet. Literally spent hours fixing it, eventually ending up with nouveau. :-1:


@Manjaro team After update the reboot was necessary → my reboot stopped with black screen. I had to do 2 times (twice) Ctrl+Alt+Del in order to make reboot hapenning successfully. Should I (or could I) do something about this ?

Similar to this? [Stable Update] 2021-05-19 - Kernels, Nvidia, KDE Frameworks, Plasma, Systemd, LibreOffice, KDE Gear Mobile, FF, TB - #68 by CalibratedCabbage

Right after updating, I started getting

The window switcher installation is broken, resources are missing.

Every time I ALT+TAB’d.
Haven’t rebooted yet

EDIT: reboot made it go away it seems

A post was split to a new topic: Make zsh default in Plasma and XFCE editions

A post was split to a new topic: Imagemagick6 build problem

@CalibratedCabbage My reboot issue does not look (to me) like yours. I had this quite minor issue only in one desktop, not in laptops. My now, after this (Ctrl+Alt+Del) was done, this does not happen any more in the desktop in question.

1 Like

The amdgpu-bug causing a lockup after suspend still seems present in 5.12.2
Haven’t dared to check latest 5.11, as I will then lose 5.11.6, which is the last (known to me) working kernel from 5.11 without lockups after suspend (on my Ryzen 4600U-based laptop).

For anyone affected, 5.10.32+ seems fine, too.

Can be issue of your GTK theme, but similar one/related is already reported (if I’m not wrong).

You may downgrade pamac to the actual repo version.
sudo pacman -Syyuu

How long did you wait with the black screen? My laptop took much longer than usual on the next boot - looks like it was running fsck - but it booted up fine…

In case it helps, I had Compiz issues (on XFCE) after updating - including no ability to run CompizConfig. Chose to rebuild it (from within Pamac [10.0.6-2] “compiz-easy-patch”) and it required a new/updated dependency (sorry - clicked through accidentally before noting precisely what it was!).

After that rebuild and another restart, Compiz has been working as it was before the update.

Kernel 5.10.36-2-MANJARO

1 Like