[Stable Update] 2021-05-06 - Kernels, Mesa, VirtualBox, LxQt 0.17, Deepin, Gnome Apps 40.1

Updated everything this morning (Manjaro Gnome), about 80-ish packages.

Everything went fine, asked me to reboot so I did.

On boot:

  1. Dell screen
  2. Password for disk encryption
  3. Another Dell screen
    – everything normal up until here –
  4. All black screen, nothing except for my keyboard lighting up when I click.

Tried alt + ctrl + F1 (and F2), nothing happened.

Did a force shutdown (power button for about 10sec.)

Boot again, and now it works. Might take a Timeshift backup next time because I nearly cr*pped my pants :sweat_smile:

Should I be worried or consider this a one time glitch in the maxtrix and forget about it if it doesn’t occur again?

I’m on 5.10 LTS, have the latest NVIDIA drivers (hybrid laptop) with optimus-manager.

After updating my multiseat-setup was broken, so that lightdm would refuse to start. I could start xfce with startx, but only one seat worked.

Today i solved the problem by disabling 2 config-files which were brought by recent updates to /usr/share/X11/xorg.conf.d These configfiles may break all multiseat-setups using loginctl see arch-multiseat

in short all you have to do is disabling these files:

sudo mv /usr/share/X11/xorg.conf.d/10-amdgpu-nvidia-drm-outputclass.conf /usr/share/X11/xorg.conf.d/10-amdgpu-nvidia-drm-outputclass.conx       
sudo mv /usr/share/X11/xorg.conf.d/10-intel-nvidia-drm-outputclass.conf /usr/share/X11/xorg.conf.d/10-intel-nvidia-drm-outputclass.conx

if you are interested in details see the full info at Multiseat-Setup broken by …

1 Like

The firmware for Ravenridge (Zen 1 + Vega APU (2*00U)) in 20210426.fa0efef is faulty again (also was with the last stable update in April/End of March):
It crashes amdgpu within 2 hours of runtime. The messages in the kernellog switching on every crash, so they’re not helpful. Last time I got

amdgpu 0000:04:00.0: amdgpu: [gfxhub0] retry page fault (src_id:0 ring:0 vmid:1 pasid:32769, for process Xorg pid 942 thread Xorg:cs0 pid 981)

, the crash before was throwing:

drm:amdgpu_gart_unbind [amdgpu]] ERROR Timeout waiting for VM flush ACK!

Tried Kernel 5.10.30 – 34 and 5.4.106 – 116 and some new parameters like amdgpu.noretry=0 but the only solution is to copy back the old firmwarefiles (/usr/lib/firmware/amdgpu/) and recreate initramsfs.

Therefore I’m pretty sure the source of this new instability is the new firmware (see also the releasedates of new firmware in AMD’s repository - great, I not allowed to link it -.-’ ).
According to another user from another forum this also concerns Navi 21 (but not Navi 10).

5.11.14 is better

more info here:

The only problem I’ve found is that suddenly my user gets locked out after multiple failed login attempts (sodding capslock!) which has never been a problem before. (And isn’t required behaviour on my home computer anyway).

The solution seems to be to edit /etc/security/faillock.conf, uncomment “deny = 3” and change it to “deny = 0”.

I tested deepin and Budgie then shared problem detailed system report in external topic for not occupying this topic.


grub seems to have borked something, i switched to linux512 and removed linux58 and linux511 but grub still thinks linux58 is installed.

$ mhwd-kernel -li              
Currently running: 5.12.1-2-MANJARO (linux512)
The following kernels are installed in your system:
* linux510
* linux512
* linux54


Found linux image: /boot/vmlinuz-5.8-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.8-x86_64.img
Found initrd fallback image: /boot/initramfs-5.8-x86_64-fallback.img

No, grub sees the kernel and initramfs in /boot. Delete those manually.

well did not something break, as every time previously it has been removed automatically? Maybe incompatibility between mhwd-kernel or grub and linux512 ?

The package removal of a kernel package should trigger a pacman hook (/usr/share/libalpm/hooks/60-mkinitcpio-remove.hook) which in turn calls the /usr/share/libalpm/scripts/mkinitcpio-remove script which should remove those remnants.
Don’t know what went wrong on your system.


Am I the only who has problems with “Print Screen” button after this update?

On KDE, “Print Screen” button on keyboard does nothing now (it used to capture screenshots with Spectacle in the past). I even re-configured keyboard shortcuts via settings - no luck. No matter what I do, “Print Screen” button alone doesn’t work anymore. If I configure shortcut to use SOME_OTHER_BUTTON + “Print Screen”, it works fine.

PrtSc still working for me on KDE.

It isn’t a recommended LTS kernel yet. This is my primary work computer, I don’t change my kernel very often.

1 Like

My Manjaro Gnome PC doesn’t boot after the update. It had kernel 5.9 on it and it said it was removing it but I guess it didn’t replace it with anything? Just reading the notes here and yeah I guess it’s end of life now. I usually have LTS kernels but I guess I forgot to change it after a new install a few months back.

Anyway I’ve got a UEFI install and it just hangs at the motherboard manufacturer’s logo screen. I can reboot with Ctrl + Alt + Del but that seems like about it. Should I boot from install media and jump into my current install and do something?

Could you post a screenshot with your keyboard shortcuts for Spectcacle, please? System Settings > Shortcuts > Spectacle

@toxpal, here is a screenshot of my Spectacle shortcuts:

Thank you, your config is exactly the same as mine. for some reason, it doesn’t work for me, no matter if Spectacle is running or not. Worked just fine in the past…

After some more tests, I now believe it’s related to Spectacle itself. Even after I open it manually, clicking “Take a new Screenshot” sometimes closes Spectacle. I mean not minimizing to tray or showing a selection window for screenshot, but closing the app. When I re-open Spectacle manually, it instantly gets minimized and displays a selection window for screenshot.

LTS kernels are always usually recommended. @nightmare-2021 apparently forgot to add that. :wink: See below :point_down:

1 Like

I haven’t forgotten that, but the 5.10 kernel is deliberately not recommended for now :wink:

The reason is that it has not yet achieved sufficient stability and a lot is still being tinkered with.
You can see it in the many fixes - kernel updates come twice a week.

So it doesn’t matter if I set the kernel to recommended - that doesn’t make it any better.


Firefox just does not allow me to search after restart or boot for couple min. internet connectivity is not an issue as chromium works fine and all any other internet apps just work