[Stable Update] 2021-04-09 - Kernels, Systemd, Gnome 40 Apps, Mesa 21.0.1, Kernels, Browsers

Only the apps are updated.

  • We updated Gnome Apps to 40. Shell and extensions are kept at 3.38 series.

I had an issue related to npm; “exists in filesystem”
I fixed it by doing npm r -g npm and then upgrading again
Besides that, everything went smoothly.

I have a small issue on one machine. While updating language it failed, without any hints :face_with_raised_eyebrow:

after update, VLC plays all videos with dark screen, correct audio though.

1 Like

hi, guys

I upgrade without issues but my gnome desktop not changed to 40.0 just version updated

Screenshot from 2021-04-09 19-19-21

Just one issue detected: The annoying “Applications updated” menu effect is back. (KDE Plasma)

From the announcment:

1 Like

Bro when release gnome shell 40 ?

Currently some of the default extensions manjaro uses haven’t been completely ported to gnome 40 yet, such as dash to dock and dash to panel. The respective devs are working on it though, but they’re currently not stable yet. That’s why I’m guessing there’s a delay, and it’s likely that the gnome-shell update will be delayed until these extensions are in a more workable state.


Just enbale it

I had to remove the following conflict packages before the update:

pulseaudio-equalizer pulseaudio-jack pulseaudio-lirc pulseaudio-rtp pulseaudio-zeroconf

now I have no sound, even with pipewire pipewire-pulse pipewire-jack pipewire-alsa installed and I can’t play any videos, neither the media player nor browser, since they just doesn’t load.


After the update, when I type yay -Qtd in the terminal, I get exit status 1. This is new and does not seem to be normal. With pacman -Qtd, everything behaves normally as before (which means no output in this case).

EDIT: Never mind! Rebuilding initial ram disk images and another reboot solved the issue!

I’m using kitty as terminal emulator. Before the update it worked fine, but now I get:

[099 17:41:33.930482] [glfw error 65543]: GLX: Failed to create context: BadValue (integer parameter out of range for operation)
[099 17:41:33.930513] Failed to create GLFW temp window! This usually happens because of old/broken OpenGL drivers. kitty requires working OpenGL 3.3 drivers.

Any ideas where to look?

I’m using a GTX 1050 Ti with the Nvidia driver (non-open-source).

$ sudo glxinfo -B
name of display: :0
X Error of failed request:  BadValue (integer parameter out of range for operation)
Major opcode of failed request:  151 (GLX)
Minor opcode of failed request:  24 (X_GLXCreateNewContext)
Value in failed request:  0x0
Serial number of failed request:  99
Current serial number in output stream:  100

This is new:

NVRM: API mismatch: the client has the version 460.67, but
NVRM: this kernel module has the version 460.56.  Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.

Do I need to something else after a kernel update, when using the Nvidia drivers?

I had to answer some questions:

:: Starte vollst?ndige Systemaktualisierung…
:: hunspell-en_US durch extra/hunspell-en_us ersetzen? [J/n]
:: python-dbus durch extra/dbus-python ersetzen? [J/n]
:: python-dbus-common durch extra/dbus-python ersetzen? [J/n]
L?se Abh?ngigkeiten auf…
Suche nach in Konflikt stehenden Paketen…
:: dbus-python und python2-dbus stehen miteinander in Konflikt. python2-dbus entfernen? [j/N] j :point_up:

All worked well so far

I had an issue whilst updating Gimp (plugin) that requires gegl >= 0.4.30. Currently, the version from the Official repo doesn’t meet such requirement, so it would be nice to update gegl next time.

Gnome shell hasn’t been updated to 40 yet. It will be there after testing thoroughly.

Just a cosmetic issue, 5.10 is not flagged as LTS in the kernel manager:


Can’t start Cmake:
cmake-gui: error while loading shared libraries: libQt6Widgets.so.6: cannot open shared object file:No such file or directory

The download is very, very, very slow :sleepy:

1 Like

sudo pacman-mirrors --fasttrack && sudo pacman -Syyu