[Stable Update] 2021-04-09 - Kernels, Systemd, Gnome 40 Apps, Mesa 21.0.1, Kernels, Browsers

Everything almost went smoothly, apart from a nasty bug with GNOME’s “Select Network” pop-up (in GNOME’S quick settings drop-down menu), preventing it from closing (which makes the computer unusable until hard reset).


These commands in Terminal have fixed the issue for me:

sudo ln -fs /usr/share/fontconfig/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d/ to have back the lcd filter (in facts fonts looked a little bit ugly without such conf file)


A post was split to a new topic: Lenovo e585 - ryzen 5 2500u - vega 8

Updated on two Xfce systems through pamac-gui.

On the desktop though, pamac-gui hanged on the conflict resolution phase. Launching the update with pacman instead revealed the cause:

:: removing python2-twisted breaks dependency 'python2-twisted' required by python2-incremental

Those package not being actually used, i removed them, then proceeded to update with pamac-gui.

1 Like

Had to do the sound fix, other then that the gnome favorite icons seem to be aligned differently? I might be imagining this:

The admin backend is currently disabled until the upstream issue is fixed:

1 Like

May I ask what happened with this thread? It wasn’t available for at least an hour.

I mean is the update still a valid stable update or was something revoked maybe?

Nothing was revoked, probably someone from staff marked by mistake this topic as private :stuck_out_tongue:

Thanks for that, @Yochanan.

It seems to me only every other kernel version released in Manjaro works on my laptop running Manjaro KDE.

5.10.23-1, 5.4.105-1 and 4.19.180-1 work fine for me.

5.11.6-1 and 5.9.16-1 don’t work well at all. With those the graphic effects don’t work, like no inverting of window colors (for apps that don’t support a dark theme…), no desktop zooming (for apps with too small text) and some fn-buttons like volume control and screen brightness don’t work.

Kernel 5.11.2 didn’t work on my laptop at all - just hanged after login (both GUI and from TTY session). 5.10.* worked fine OOB. This update has 5.11.10 and it works OK for me.

everything got big in gnome shell, changed gnome-shell font size and it came back to normal size, just a temporary fix…

Today I ran into a bug in GNOME.

WiFi selection panel buttons are not working, it can not be canceled or closed even after connecting a network.

And, one more thing here since Manjaro 19. After turning off Wi-Fi, it’s going to be in Airplane Mode, is this necessary? If it is, I don’t think it should open Bluetooth when I turn off the Airplane Mode.

After this update the menu would break in the middle of normal use. Every icon just became squished into the top left corner. When I open application from the launcher they open into into a window that will not let me use interact with it. So far I don’t know what’s causing it and I can only fix it by rebooting.

Now it is :slightly_smiling_face:

Hello drmaxhattan
I had that happen about a month ago thereabouts, did mention on the forum here, I’m using 5.4 LTS and just an update or two later my system ( dolphin ) went back to normal speed, I remember years ago there was a discussion in the old forum about that slowness and seemed that Dolphin and KDE occasionally are not in sync with each others thingymebobs, try to wait awhile (an update or two) as it should fix itself usually does, things like this can happen. :relaxed:

I’m experiencing an issue identical to the one listed here.

If I try to run cmake CMakeLists.txt on a project with the line find_package(GTest REQUIRED) without gmock installed, I get the following error:

CMake Error at /usr/lib64/cmake/GTest/GTestTargets.cmake:112 (message):
  The imported target "GTest::gmock" references the file


  but this file does not exist.  Possible reasons include:

  * The file was deleted, renamed, or moved to another location.

  * An install or uninstall procedure did not complete successfully.

  * The installation package was faulty and contained


  but not all the files it references.

Call Stack (most recent call first):
  /usr/lib64/cmake/GTest/GTestConfig.cmake:42 (include)
  /usr/share/cmake-3.20/Modules/FindGTest.cmake:187 (find_package)
  CMakeLists.txt:11 (find_package)

If I do install gmock, that fixes the issue, but it never appeared before this update. Or at least, I can’t think what else might have caused it to start happening.

Nothing seems to work in WINE!
Opening from menu where they used to work or from command line both show wine processes in System Activity but no windows appear.
Work around in this post Problems with wine - #4 by jrichard326 also doesn’t help.

Mesa 21.0 caused issues with Wine for many people.


The single quote behavior of keyboard layout English (US intl., with dead keys) seems to have changed.

When I hit the single quote key followed by the space bar I now get a forward tick ´ where I used to get a single quote '. On the double quote key this did not change.

single quote:
Peek 2021-04-12 08-02

double quote:
Peek 2021-04-12 08-04

Have not found the cause of this yet.