[Stable Update] 2021-03-18 - Kernels, Plasma, Frameworks, LibreOffice, Firefox, Systemd

Strange, kernel 5.10.23-1-MANJARO is still not marked as LTS :thinking:

3 Likes

Thanks for the reply Ben. Didn’t work though. Although no error is shown, I get the same login screen and on inputting my password, it locks up.

Hello all, if this may help someone else. After the 03-08-2021 update (and upgrade to kernel 5.11?) I noticed that the Fn keys of my Dell laptop (Intel GPU) no longer controlled the screen brightness. Since my issue was not fixed with today’s update I figured the issue was something local :crazy_face: .

After much research and playing around with suggestions on the Arch wiki for Backlight, I added acpi_backlight=native to grub and restarted, and now my Fn backlight keys are working again.

Huge thanks to the Manjaro team for making this great distro!

EDIT (more info): During my investigation, I ran ls /sys/class/backlight/ and it listed both acpi_video0 and intel_backlight as the output. After I added acpi_backlight=native as a kernel parameter and rebooted, only intel_backlight is now output, so my laptop developed a driver issue that I was able to correct by editing grub. In addition to my Fn brightness keys working again, now the screen brightness also dims after a period of time of not touching the keyboard just like before!

EDIT 2: In order to have my computer running KDE to start up at the brightness level I desire, I also had to go into System Settings>Power Management>Power Saving>On Battery>Screen brightness and set the slider to 20%. Click Apply.

2 Likes

My Intel AX210 wifi card stopped working with this update (but BT on the card works fine)

[    1.872647] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
[    1.874224] Bluetooth: hci0: Found device firmware: intel/ibt-0041-0041.sfi
[    1.943335] iwlwifi 0000:01:00.0: loaded firmware version 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
[    2.491891] [drm] Found VCN firmware Version ENC: 1.12 DEC: 2 VEP: 0 Revision: 1
[    2.491904] [drm] PSP loading VCN firmware
[    2.641312] iwlwifi 0000:01:00.0: firmware didn't ACK the reset - continue anyway
[    2.986691] Bluetooth: hci0: Failed to send firmware data (-38)
[    3.596696] Bluetooth: hci0: Minimum firmware build 1 week 10 2014
[    3.596910] Bluetooth: hci0: Found device firmware: intel/ibt-0041-0041.sfi
[    4.755047] Bluetooth: hci0: Waiting for firmware download to complete

There’s an open Arch bug report about it: FS#70071 - [linux-firmware] AX210 wifi card not working after last update

2 Likes

Great, thanks so much! I also just learnt how to do downgrade too.

I originally installed my system with Cinnamon and then switched to KDE later. After the update today and a reboot, a lot of icons are now changed. I think they are the same ones as on Manjaro systems that get installed with KDE straightaway, which I’m not opposed to at all, it’s just something to get used to.

But what’s less nice is that the system settings are now white themed, despite all settings saying the opposite and even after I switch them all to something else, apply, switch back and apply again. No other program has this issue.

A post was split to a new topic: Issues with latest stable update

I know what it feels like, but please consider:

  • Don’t trust any OS (not even Windows or Mac) to not lose your work.
    Always backup/save to an external drive,
    which you disconnect before updating.

  • Timeshift should cover only the OS, not your work.
    Keep your work on another drive/partition/filesystem,
    or if you can’t, put it in a separate part of the OS’s filesystem
    that you can exclude from timeshift.
    (i don’t use actual ‘timeshift’ so don’t know if that’s possible.)
    It seems necessary to keep the home folder in the timeshift,
    as that where a lot of the configuration is,
    so I put my own data elsewhere (on another drive in my desktop box).

  • If you need to keep working, can’t afford downtime,
    wait a couple of days before you apply a big update.
    Phil and the other maintainers respond very quickly
    to bug reports that are coherent and informative.
    They quickly push corrections to the stable repo,
    and people who update later have a smooth run.

8 Likes

So, if I had Timeshift I could have roll back to previous state when everything worked fine?

That’s the usual idea.

EDIT:
I do my own thing with BTRFS snapshots, but as far as I know,
you’re supposed to use Timeshift on only the operating system,
and keep your own data out of it.
Make backups of your own work separately, not as part of system Timeshift.

1 Like

update went well thus i can use manjaro, but i have a problem with the watchdog.service. It’s missing and from what i found at the internet it causes a hang if shutting down or reboot.
there is the message
“a job is running for session 2 of user …” while the optimus-manager is shutting down. several others had the same issue and it depends from the nvidia-driver. Actually i have no solution and would appreciate some instructions how to solve the issue.
thanks in advance

so far i found an old archive

and indeed it seems that there are multiple modules of the watchdog are installed that interfere
> lsmod | grep iTC

iTCO_wdt 16384 0
intel_pmc_bxt 16384 1 iTCO_wdt
iTCO_vendor_support 16384 1 iTCO_wdt

any suggestions or help avaiable ?
thanks in advance

1 Like

try this:

Blacklist the modules in /etc/modeprobe.d/blacklist.conf (create this file if you don’t have it).

To disable watchdog timers (both software and hardware), append nowatchdog to your boot parameters.

sudo nano /etc/modprobe.d/blacklist.conf

    # disable intel mei (including mei_watchdog)
    blacklist intel_pmc_bxt          16384  1 iTCO_wdt
    blacklist iTCO_vendor_support    16384  1 iTCO_wdt

    # Do not load the 'iTCO_wdt' watchdog module on boot.
    blacklist iTCO_wdt
2 Likes

i’ll give it a try but i have to do it later. it’s late and i have to sleep.
thank you for your fast answer, if i have further trouble i will open a thread but for now
many thanks

1 Like

After restoring a TimeShift backup and then messing with the grub for 2 hours like I have to every time, I got it back to pre-today’s update. My question is, how do I avoid this problem if I want to update again? Do I change my theme to default or something? Thanks.

Also, a live USB desktop could copy the files you need
BEFORE overwriting them with Timeshift.

An issue with Timeshift is that you can’t selectively restore your system using the app, but you CAN selectively restore anything else.

Always do a fresh timeshift snapshot to save any work before you upgrade (assuming you still include your work files in your system backup…).

1 Like

I think it’s not a common error. Today’s update removed any errors I had in the past… it’s the best yet.

Not sure about your themes, but I was on Nordic when I did the update, I didn’t edit my GRUB significantly however - maybe that’s an issue. Have you used grub-customizer? Grub customizer is a good way of adding layers of complexity which cause many issues…

Any further discussion should go off to a new topic here.

I too was on Nordic. I wasn’t able to fix my issue though, as it appears you were. I have never used grub-customizer either. I keep things pretty normal. Again though, how do I go about updating from this point?

I have a similar issue, both on my laptop and desktop.

The current theme cannot be loaded due to the errors below, please select another theme.

file:///usr/share/sddm/themes/breeze/Main.qml:26:1: plugin cannot be loaded for modhle “org.kde.plasma.core": Cannot load library /usr/lib/qt/qml/org/kde/plasma/core/libcorebindingsplugin.so: (/usr/lib/libKF5KIOCore.so.5: undefined symbol: _ZN4KJob14percentChangedEPS_mNS_14QPrivateSignalIE)

Yesterday, I made the the update on three computers:
KDE and XFCE and kernel 5.4, 4.19, 4.14.
All went fine.

Thanks!
:star_struck: