[Stable Update] 2021-02-28 - Kernels, Plasma 5.21.1, Frameworks 5.79, Firefox, Thunderbird, Python

Solution for pulseeffects here: What is the correct way to install package “manjaro-pipewire”? - #7 by kagetora13

2 Likes

Hi,
I have the same problem with screen sharing.
Could you describe how to perform the downgrade of pipewire?

I found a better solution/ workaround:
Accoring to this bug report in the Pipewire repo if you uncomment the “metadata” module in the default section of the file /etc/pipewire/media-session.d/media-session.conf and restart the pipewire service with systemctl --user restart pipewire.service it works again :partying_face:

5 Likes

Ooops, didn’t stand reboot:

$ pulseeffects

(pulseeffects:193857): pulseeffects-ERROR **: 13:56:18.866: pipe_manager: context connection failed
Trappe pour point d'arrêt et de trace (core dumped)

Smooth update on my Tuxedo Pulse 15 (AMD Ryzen 7 4800H + iGPU) with Manjaro KDE. The new application launcher with dark theme really is something pretty!

Once again, thanks Manjaro Team! :clap:

I suspect the EOL to mean that there are no more updates. You can (suggestion) delete the kernel (after you selected an other one, of course) of just use is as long as it lasts…

Hi Guys,

An error message (a pop-up window) began appearing since yesterday, when I tried to run a VM image in VirtualBox saying "Kernel driver not installed (rc=-1908). The VirtualBox Linux kernel driver is either not loaded or not set up correctly. Please try setting it up again by executing '/sbin/vboxconfig' as root."

However that command is not available at Manjaro, so I searched our forum for a solution to the issue. A post from @linux-aarhus had what I was looking for:

[root tip] VirtualBox - Installation - USB - Shared Folder

If you look at the part a little before “Load kernel modules”, you will see the answer:

So, I’ve installed the missing modules and run the command sudo vboxreload. Now everything is back to normal.

Thanks a lot Frede (@linux-aarhus)!

1 Like

Is the extra hard drive space worth suspend? I mean how long does it take to boot up? It takes less than 30 seconds here. I see people post all the time about long boot times. If I feel like turning the box off - it goes off. If I want it to stay on all night - it stays on all night. If I had long start up boot time - I could see reconsidering.

Hibernation uses swap space on the hard drive, suspend uses RAM. :wink:

1 Like

I had a pipewire-media coredumb error after this update, i restarted the service and after a system restart the error just vanished from journal. I not even know what this app is good for.

I just hope this error is not coming back anytime soon :space_invader:

kde x11 session permanently stucks on loading animation for me, (kde plasma session crashes instantly, but it never worked, so it’s kinda no biggie).

Any info on how to debug this?

Boot is about a minute from button to desktop, allowing my password entry for login and keepass. The advantage of suspend is everything stays where it is, browser pages stay open, working on something, leave it open. Of course in the morning I press a key and within a second I am back and everything is ready.
I have an UPS so nothing is at risk, I reboot daily anyway as I have a testing partition which sees a lot of use too.
It may not be for everyone but it works for me.

Hello!

I used the workaround you posted and worked fine here.

But the downgrading steps are here: Downgrading packages - Manjaro Linux

@Kobold See here.

1 Like

KDE user. I’ve had a few issues after the update:

  1. The meta key no longer opens the start menu. I am unable to set it as a shortcut either, I can only configure meta + another button.

  2. The start menu is poorly responsive now. The time it takes to react seems to have increased, though I am unable to measure that. Sometimes, non-reproducibly, but frequently enough to be annoying, clicks on it are ignored, and a second click is required. It seems to happen more right after clicking on a program in the task manager.

  3. Icons in the system tray are too small now. This seems to be a recurring problem. I set icons to scale with panel height, but this does not fix the problem. They are about 50% of the panel height.

Does not work at my side because a combo is expected: (Meta +...) neither @Heavymetalpenguin94 works because of the same reason (Ctrl + Meta + ...).

STRANGELY enough when installing a vanilla manjaro in a VM, the Launcher (of whatever it is called) opens at pressing on Super. No way i’m going to completely reinstall my system.

Edit: Nevermind, I got it working by assigign Alt+F1 according to this thread.

Still weird that this pesty regression pops up every time.

The keyboard layout switching widget is no longer displayed on the lock screen. Add please.

1 Like

Update without problem: many thanks Manjaro team :clap: :clap:

After this update, my laptop is much warmer, and the battery life went from 7h to 3h, so there seems to be somethig wrong with power management.
Internal temperature is about 65 degrees celsius, where it was at 38 before.
How can this be fixed ?

1 Like

The Pipewire-Media Core Dumb error is back!

I knew that link already, but its not explain, who can deactivate it and who not, why should i deactivate it when i possible need it.

Looks like there is no real solution at the moment or?

Bug:

systemd-coredump[11675]: Process 11671 (pipewire-media-) of user 1000 dumped core.
                                                      
Stack trace of thread 11671:
#0  0x0000556d6467f03b n/a (pipewire-media-session + 0x2003b)
#1  0x0000556d6467da6b n/a (pipewire-media-session + 0x1ea6b)
#2  0x00007fd1bb162df4 n/a (libpipewire-module-protocol-native.so + 0x>
#3  0x00007fd1bb15caa2 n/a (libpipewire-module-protocol-native.so + 0x>
#4  0x00007fd1bb15cff8 n/a (libpipewire-module-protocol-native.so + 0x>
#5  0x00007fd1bc248d9b n/a (libspa-support.so + 0x6d9b)
#6  0x00007fd1bc1c15ab pw_main_loop_run (libpipewire-0.3.so.0 + 0x425a>
#7  0x0000556d6466b7dc n/a (pipewire-media-session + 0xc7dc)
#8  0x00007fd1bbe84b25 __libc_start_main (libc.so.6 + 0x27b25)
#9  0x0000556d6466bc5e n/a (pipewire-media-session + 0xcc5e)
                                                      
Stack trace of thread 11673:
#0  0x00007fd1bbf5c39e epoll_wait (libc.so.6 + 0xff39e)
#1  0x00007fd1bc2521f1 n/a (libspa-support.so + 0x101f1)
#2  0x00007fd1bc248d04 n/a (libspa-support.so + 0x6d04)
#3  0x00007fd1bc1a7f50 n/a (libpipewire-0.3.so.0 + 0x28f50)
#4  0x00007fd1bc033299 start_thread (libpthread.so.0 + 0x9299)
#5  0x00007fd1bbf5c053 __clone (libc.so.6 + 0xff053)
░░ Subject: Process 11671 (pipewire-media-) dumped core
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ Documentation: man:core(5)
░░ 
░░ Process 11671 (pipewire-media-) crashed and dumped core.
░░ 
░░ This usually indicates a programming error in the crashing program and
░░ should be reported to its vendor as a bug.

gotcha. good you’re paying attention.