[Stable Update] 2021-01-19 - Kernels, XFCE, Plasma, PulseAudio, Pipewire, Mesa, Firefox, Thunderbird, KDE Apps

Hello everybody,
the update went through without any problems. Now only have a warning message when booting:

the device is not configured to be mounted read-write! It may be fsck’d again later.

Can that cause problems? Or just ignore it?



The update here seemed to mess up my displays. None of my displays are being detected and right now the displays are mirrored. Xrandr just outputs them as one display called “default”. Thanks :slight_smile:

Almost everything went smoothly. The update from XFCE 4.14 to 4.16 caused the XFCE panel “Sensor plugin” to take 10 times the vertical space. Even after setting it to 1 line, it’s huge for no reason. Here’s a screenshot showing the issue right now:

I guess I’ll have to submit a bug report and disable this plugin so I can use my panel’s vertical real estate properly.

A little issue with the whisker menu. Like @Glock24 the ‘favorites’ are gone, except ‘xfce-Terminal’ and ‘thunar’. When I put ‘E-Mail’ to ‘favorites’ it is gone from there after reboot.

Welcome to Manjaro
You can use a older kernel with more option to boot
and take the old one (◠‿・)—☆

1 Like

I use KDE and had the 5.4 LTS Kernel.

After installing updates and rebooting, I got the “Failed to start Load Kernel Modles” error.

I am still stuck there. I didn’t have another kernel installed.

Full disclosure - I’m not an expert and fairly limited at this, so my attempt at a solution may be wrong.

I tried chroot from a live Manjaro USB. My first thought was to reinstall my kernel and install a second kernel. When I try to do either with sudo mhwd-kernel -i while in chroot, I receive the following error -> “no targets specified” (I got into chroot with sudo manjaro-chroot -a, Manjaro is the only OS installed on my system).

I tried following some online instructions for restoring the bootloader, but that did not fix the problem.

Does anyone have any ideas? If so, please tell me specifically what to try or what information you need (and how I should get it).

[Resolved following this solution -> Problems with new Manjaro update and nvidia - #2 by Mirdarthos]

I would say that you need to fsck your drives from time to time anyway. And the root filesystem should be scanned every boot for the best, it doesn’t take long, don’t worry.
Also, In my experience, I encounter invalid or garbage inodes across the system quite often. One day I found some qt5 library damaged which caused quite a problem. fsck fixed that in a moment though. I guess it’s my hard-drive fault anyway.

Had to change my vote… :frowning:

I was using xfce4 screensaver with the default settings. Following the update, when the saver came on due to inactivity, as opposed to setting lock explicitly, there were TWO login dialogs in sequence, the second of which would not accept any input characters. That is, once I logged into the first, there was a second lockscreen which was not allowing input. I had to REISUB to get back into my computer, at which point I uninstalled the screensaver and set locking to only happen when done explicitly. That works.

Since the grub has been been updated, the following comment is relevant and you may want the following changes:

1 Like

A post was split to a new topic: Cannot select GNOME from Architect

Yes, plese guys: reports such issues on upstream:

And posts the link here, so anyone can follow and contribute as well :slight_smile:

1 Like

Yes, that was what I meant by that. Thanks for the extra reminder for those who didn’t know.

1 Like

Known issue. See here and here. In the end we have to monitor it more.


After uncommenting the following line in /etc/grub, the warning message has disappeared. :slight_smile:

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically
# GRUB_ROOT_FS_RO=true     <-----------------
1 Like

Smooth update here. I’m still sticking with the 5.4 “LTS” “Recommended” Kernel until the 5.10 one has those tags in the Manjaro Settings Manager.

1 Like

Update went almost perfectly, except it flushed out favourites and some of the icons became default (show desktop, power icon and logout icon) I have Manjaro XFCE with Gnome installed as an alternative.

What about using the DKMS drivers?

This way you shouldn’t need to manually recompile yourself.

KDE Plasma, kernel 5.4.89-1 smooth update and reboot. Everything is fine.

Great work, Everyone!


When I reboot, my computer did not start.

I got the following message:

[FAILED] Failed to start Load Kernel Modules.

Then I had to press Ctrl + Alt + F2 to enter my computer and follow Phil’s advice to compile the drivers.

I’m using:

  • VGA compatible controller: NVIDIA Corporation GT218 [GeForce 8400 GS Rev. 3] (rev a2)
  • Kernel 5.4.89-1
  • nVidia drivers 340xx

After rebooting I was able to log in again. What a scare!

smooth update. I thought we are gonna get new kde kickoff redesign. where is it?