[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

Nope! All it did is legit marked the system as “up to date”, but has not updated anything at all…

And the logs says that now many system components are missing…
Hopefully i’ll reboot, it will fail to boot, then I will enter a chroot environment to merge a previous snapshot and to update remotely with an ISO having a previous version of pamac…

Not a big deal, just a small annoyance…

I have a 3-boot laptop with each Manjaro in Unstable, and another laptop in Stable. I mix maybe between them, I saw a lot of Pamac upgrades lately. Dunno if it could be related.
Lots of Haskell and Python too.

I just successfully upgraded the system following the procedure I stated! :partying_face:

Seems to be a sort of bug with the newer pamac version…

1 Like

I had a kernel panic on shutdown after update, replace journalist, restart and removed mhwd-nvidia-340x.
After start all seems work well except one little issue;I have this error proc: Bad value for 'hidepid' on dmesg.
The kernel is 5.4.


I had this issue, and the suggested workaround solved it.

rebuild-detector notified me of vmware-horizon-client needing a rebuild but after the upgrade it won’t build anymore due to missing sha256sum validation of vmware-bundle.eclass. EDIT: I had to clean the AUR cache to rebuild it properly.

Everything else went fine for me.

Many thanks and Happy 2021!

Have the same error running mhwd

~ >>> mhwd                                                                                                
Warning: config '/var/lib/mhwd/local/pci/video-nvidia-455xx/MHWDCONFIG' is invalid!
> 0000:07:00.0 (0300:10de:1402) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2020.11.30               false            PCI
    video-nvidia-390xx            2020.11.30               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

For me it’s harmless and looking for a AMD video card anyway.

It’s not an error, it’s a log message you can safely ignore.
Probably, you are using new systemd on old kernel.

If you want to fix it, upgrade your kernel or downgrade your systemd.
Github: systemd/systemd - proc: Bad value for ‘hidepid’

I ran the update in the terminal. Everything went well until I attempted to run terminator. It refused to start. Even after I uninstalled it, ran a clean, and reinstalled it, it still would not start. Finally, I attempted to start it from another terminal. I got the following message. Thanks for a great distro.

[don@don-optiplex990 ~]$ terminator

(terminator:3743): Gtk-WARNING **: 18:50:03.467: Theme parsing error: gtk.css:2:33: Failed to import: Error opening file /home/don/.config/gtk-3.0/window_decorations.css: No such file or directory

(terminator:3743): Gtk-WARNING **: 18:50:03.469: Theme parsing error: gtk.css:68:35: The style property GtkButton:child-displacement-x is deprecated and shouldn’t be used anymore. It will be removed in a future version

(terminator:3743): Gtk-WARNING **: 18:50:03.469: Theme parsing error: gtk.css:69:35: The style property GtkButton:child-displacement-y is deprecated and shouldn’t be used anymore. It will be removed in a future version

(terminator:3743): Gtk-WARNING **: 18:50:03.469: Theme parsing error: gtk.css:73:46: The style property GtkScrolledWindow:scrollbars-within-bevel is deprecated and shouldn’t be used anymore. It will be removed in a future version
Traceback (most recent call last):
File “/usr/bin/terminator”, line 48, in
import terminatorlib.optionparse
File “/usr/lib/python3.9/site-packages/terminatorlib/optionparse.py”, line 24, in
from . import config
File “/usr/lib/python3.9/site-packages/terminatorlib/config.py”, line 76, in
from validate import Validator
ModuleNotFoundError: No module named ‘validate’
[don@don-optiplex990 ~]$

The warring is related to the line in the /etc/default/grub added some time ago. It allows to use systemd-fsck for filesystems check:

# Uncomment to ensure that the root filesystem is mounted read-only so that
# systemd-fsck can run the check automatically

More on the subject:


Upgrade the terminator:

`sudo pacman -U https://mirror.f4st.host/archlinux/community/os/x86_64/terminator-2.0.1-1-any.pkg.tar.zst`

In case it has not been mentioned. I had to add this key -

gpg --recv-keys EB4F9E5A60D32232BB52150C12C87A28FEAC6B20

to get rebuild-detector to install. Check out the comments from the aur page.


Well, didn’t go so well. Probably my fault, but not sure.

I think Kernel 5.8 was removed and was updated to 5.9.

Kernel 5.9 gives me black screen after grub. Boot with 5.4, no problem. Saw some talk in this thread about nvidia so removed those. Then removed 5.9 and reboot, and this in order to install 5.10 instead.

Tried booting into 5.4 again, black screen after grub on this one. Can’t ctrl-alt-f2 and no success getting into tty with the systemd.xxz.zzz (forget the exact text; replaces quiet) edit in grub. Recovery mode is a black screen as well.

Should I start a new thread? I’ll continue to Google my way out of this, either way.

Update 1:
Seeing what I can do with manjaro-chroot and mhwd (mhwd -a pci free 0300) and mhwd-kernal to install 5.10 etc. I had to run pacman -S mhwd to get the mhwd’s installed.

Update 2:
Free driver didn’t fix the issue but, running mhwd -a pci nonfree 0300 seems to have fixed my problem. I’m now on 5.10 and have removed 5.9 and its nvidia driver.

This makes sense, as I think removing the nvidia drivers is why I got the black screen, at least the second time around with 5.4 (the initial 5.9 may be the issue noted up thread.)

Anyway, not exactly sure what happened but, I think I’m back in business. Thanks!

These wiki were helpful:
GRUB/Restore the GRUB Bootloader - Manjaro (talks about manjaro-chroot in the context of restoring GRUB but, the Manual Chroot part can be a useful guide for using manjaro-chroot with mhwd & mhwd-kernal; note my update 1 if you don’t have mhwd installed.)
Manjaro Kernels - Manjaro (guide on installing/removing/listing Kernals from terminal)
Configure Graphics Cards - Manjaro (installing/removing/listing gpu drivers from terminal)


No, you didn’t. rebuild-detector is in our repos now. Perhaps your mirrors aren’t up to date?

1 Like

Then why was it recommended to install it with the link going to the AUR? :thinking:

I have not done the update yet as it says to do the install before the update.

Same for me with kernel 5.10.

Gnome does not load at all.

I am with AMD.

I’m in a hurry, but trying to figure this out…

Good question. Edited.

1 Like

Noticed that noto-fonts looks different. And emojis are broken

Kernel not work with my AMD System (Black Screen)
I go back to 5.9

System:    Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 Desktop: KDE Plasma 5.20.4 Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: GL702ZC v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: GL702ZC v: 1.0 serial: <filter> UEFI: American Megatrends v: GL702ZC.306 date: 07/05/2019 
Battery:   ID-1: BAT0 charge: 61.1 Wh condition: 61.1/74.2 Wh (82%) model: ASUSTeK ASUS Battery status: Not charging 
CPU:       Info: 6-Core model: AMD Ryzen 5 1600 bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 76673 
           Speed: 1378 MHz min/max: 1550/3200 MHz boost: enabled Core speeds (MHz): 1: 1378 2: 1375 3: 1270 4: 1265 5: 1374 
           6: 1374 7: 1375 8: 1374 9: 1269 10: 1268 11: 2334 12: 2344 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: ASUSTeK 
           driver: amdgpu v: kernel bus ID: 0c:00.0 
           Device-2: Realtek USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus ID: 1-8:3 
           Display: x11 server: X.Org 1.20.10 driver: amdgpu,ati unloaded: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: Radeon RX 580 Series (POLARIS10 DRM 3.39.0 5.9.16-1-MANJARO LLVM 11.0.0) v: 4.6 Mesa 20.3.1 
           direct render: Yes 
Audio:     Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] vendor: ASUSTeK driver: snd_hda_intel 
           v: kernel bus ID: 0c:00.1 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 12:00.3 
           Sound Server: ALSA v: k5.9.16-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 v: kernel port: e000 
           bus ID: 06:00.0 
           IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: AzureWave driver: rtw_8822be v: N/A port: d000 
           bus ID: 07:00.0 
           IF: wlp7s0 state: up mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 95.14 GiB (8.2%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 250GB size: 232.89 GiB temp: 41.9 C 
           ID-2: /dev/sda vendor: Seagate model: ST1000LX015-1U7172 size: 931.51 GiB 
Partition: ID-1: / size: 211 GiB used: 95.14 GiB (45.1%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 299.4 MiB used: 280 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: partition size: 17.2 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 63.9 C mobo: N/A gpu: amdgpu temp: 57.0 C 
           Fan Speeds (RPM): cpu: 2300 
Info:      Processes: 323 Uptime: 20m Memory: 15.64 GiB used: 2.31 GiB (14.8%) Init: systemd Compilers: gcc: 10.2.0 
           Packages: 1400 Shell: Bash v: 5.1.0 inxi: 3.2.01

See edit to known problems.

1 Like

I had a a problem wit python 3.9 update
python: error while loading shared libraries: libpython3.8.so.1.0: cannot open shared object file: No such file or directory

Was “solved” linking the library from python 3.9
sudo ln -s /usr/lib/libpython3.9.so.1.0 /usr/lib/libpython3.8.so.1.0

Now works fine

❯ python -V
Python 3.9.1

1 Like