[Stable Update] 2020-12-30 - Kernels, KDE, Cinnamon, LibreOffice, Python 3.9, Mesa 20.3.1

I was told to post this here, so I shall. Yet another NVIDIA issue.

I will briefly state the problem and solution first for anyone who comes across this on Google; a full bug report is below.

Fresh install of i3 community edition with proprietary drivers on a GTX1650.
First thing I do after booting the new system is a pamac update.

Expected Result
Update of some 200 preinstalled packages.

Actual Result
Pamac fails to find some files (see below) and aborts the entire operation. I am unable to update or install any packages.

Manually reinstall the packages that pamac does not like. This resolves the file conflicts. The relevant commands are:
pamac reinstall mhwd-nvidia
pamac reinstall linux59-nvidia

So much for the short version. For the developers, here is a full bug report:

System Specs

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=8e531136-cb5e-482b-b408-f4a908c97701 rw quiet apparmor=1 
  security=apparmor resume=UUID=6d2fd7aa-1851-4511-88ad-250de514cdc6 
  Desktop: i3 4.19 info: i3bar dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop System: ASUS product: All Series v: N/A serial: <filter> 
  Mobo: ASUSTeK model: H87-PLUS v: Rev X.0x serial: <filter> 
  UEFI: American Megatrends v: 0502 date: 07/16/2013 
  Info: Quad Core model: Intel Core i5-4570 bits: 64 type: MCP arch: Haswell 
  family: 6 model-id: 3C (60) stepping: 3 microcode: 28 L2 cache: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 25609 
  Speed: 801 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 801 2: 800 3: 800 
  4: 800 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU116 [GeForce GTX 1650] driver: nvidia v: 455.45.01 
  alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:2188 
  Display: x11 server: X.Org 1.20.10 compositor: picom v: git-dac85 
  driver: nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 92 s-size: 530x301mm (20.9x11.9") 
  s-diag: 610mm (24") 
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 93 size: 527x296mm (20.7x11.7") 
  diag: 604mm (23.8") 
  OpenGL: renderer: GeForce GTX 1650/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01 
  direct render: Yes 
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20 
  Device-2: NVIDIA TU116 High Definition Audio driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 chip ID: 10de:1aeb 
  Device-3: Logitech QuickCam Communicate MP/S5500 type: USB 
  driver: snd-usb-audio,uvcvideo bus ID: 1-3:3 chip ID: 046d:09a1 
  serial: <filter> 
  Device-4: Kingston HyperX Cloud Stinger Wireless type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-12:5 chip ID: 0951:16da 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus ID: 03:00.0 
  chip ID: 10ec:8168 
  IF: enp3s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 596.17 GiB used: 9.12 GiB (1.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WD6400AAKS-65A7B2 
  size: 596.17 GiB block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  serial: <filter> rev: 3B01 
  ID-1: / raw size: 585.24 GiB size: 575.05 GiB (98.26%) used: 9.12 GiB (1.6%) 
  fs: ext4 dev: /dev/sda2 maj-min: 8:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 10.64 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda3 maj-min: 8:3 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 30 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 35% 
  Processes: 172 Uptime: 16m wakeups: 0 Memory: 9.67 GiB 
  used: 1.49 GiB (15.4%) Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 
  pacman: 1058 lib: 299 Shell: Bash v: 5.1.0 running in: urxvtd inxi: 3.2.01 

How to Reproduce

  • On a system with an NVIDIA GTX1650 (that’s a card from 2019, so it is definitely supported), install the i3 Community Edition with proprietary drivers. (Presumably the edition does not actually matter, but I have only tested on i3.)
  • Boot the new system.
  • Issue a pamac update (or a pamac install of any package).

Expected Behavior
Pamac updates all packages.

Observed Behavior
Pamac downloads all packages, then fails the file conflict checks as follows:

Checking keyring...                                                                                                                                                                                        [250/250]
Checking integrity...                                                                                                                                                                                      [250/250]
Loading packages files...                                                                                                                                                                                  [250/250]
Checking file conflicts...                                                                                                                                                                                 [177/250]
Error: could not open file /var/lib/pacman/local/linux59-nvidia-455xx-455.45.01-4/files: No such file or directory
Error: could not open file /var/lib/pacman/local/nvidia-455xx-utils-455.45.01-1/files: No such file or directory
Checking file conflicts...                                                                                                                                                                                 [250/250]
Warning: mhwd-nvidia: /var/lib/mhwd/ids/pci/nvidia.ids already existed in filesystem
It has been backup to /var/lib/mhwd/ids/pci/nvidia.ids.old
Warning: mhwd-db: /var/lib/mhwd/db/pci/graphic_drivers/hybrid-amd-nvidia-prime/MHWDCONFIG already existed in filesystem
It has been backup to /var/lib/mhwd/db/pci/graphic_drivers/hybrid-amd-nvidia-prime/MHWDCONFIG.old
Warning: mhwd-db: /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-prime/MHWDCONFIG already existed in filesystem
It has been backup to /var/lib/mhwd/db/pci/graphic_drivers/hybrid-intel-nvidia-prime/MHWDCONFIG.old
Warning: mhwd-db: /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG already existed in filesystem
It has been backup to /var/lib/mhwd/db/pci/graphic_drivers/nvidia/MHWDCONFIG.old
Warning: lib32-nvidia-utils: /usr/share/licenses/lib32-nvidia-utils already existed in filesystem
It has been backup to /usr/share/licenses/lib32-nvidia-utils.old
Error: Failed to commit transaction: transaction not prepared

Manually reinstall mhwd-nvidia and linux59-nvidia to resolve the file conflicts.

If you are downloading the packages no problem, the problem is when pamac or pacman is installing.

XFCE user here. Kernel 5.10 won’t get past this message on bootup: “Failed to start light display manager”, no other indications of what went wrong. 5.9 works. Also looks like my Netgear A7000 wireless adapter (using these drivers: GitHub - aircrack-ng/rtl8814au: Realtek rtl8814au driver) is not recognised anymore either. I tried installing the drivers again, but to no avail (looks like installation goes fine, but adapter stays dead).

edit: A7000 works fine now. Turns out that I needed to install linux-headers again. When I tried that, it initially installed them for kernel 5.10, but not kernel 5.9. Thus, I had to install 5.9 headers separately, and when that was done, the dkms install brought my wifi adapter back. All good on that front. Light display manager is still perplexing me though.

I report that with the new kernel 5.10 my old Philips webcam doesn’t work anymore. It is still working with kernel 5.9. Not a big issue for me, I’ll wait for a kernel update.


Bus 001 Device 003: ID 0471:0311 Philips (or NXP) PCVC740K ToUcam Pro [pwc]

v4l2-ctl --list-devices
Philips 740 webcam (usb-0000:02:00.0-6):

sudo rmmod uvcvideo && sudo modprobe uvcvideo
[sudo] password di paolo:
rmmod: ERROR: Module uvcvideo is not currently loaded

lsmod | grep pwc
pwc 94208 1
videobuf2_vmalloc 20480 1 pwc
videobuf2_v4l2 36864 1 pwc
videobuf2_common 65536 2 videobuf2_v4l2,pwc
videodev 290816 4 videobuf2_v4l2,pwc,videobuf2_common

see this page, might not be the same issue but will help you troubleshoot:

re-install the app as python interpreter has been updated from 3.8 to 3.9

I now have about a week continuously crashes, and it seems to be always the same issue and it somewho seems related to streaming/watching e.g. video (in my case VLC) all those crashes I’ve had accoured during some kind of active VLC running…

I did find a more or less similar Bug in the KernelLogs https://bugzilla.kernel.org/show_bug.cgi?id=206017 but the stated workaround by adding amdgpu.noretry=0 to the kernel boot options doesn’t help.

I am using a AMD Ryzen 5 3400G with Radeon Vega Graphics on Mesa 20.3.1 with Kernel 5.10.2-2

Jan 14 15:10:23 x570 kernel: [drm:amdgpu_dm_atomic_commit_tail [amdgpu]] *ERROR* Waiting for fences timed out!
Jan 14 15:10:28 x570 kernel: [drm:amdgpu_dm_atomic_commit_tail [amdgpu]] *ERROR* Waiting for fences timed out!
Jan 14 15:10:28 x570 kernel: [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx timeout, signaled seq=14799974, emitted seq=14799976
Jan 14 15:10:28 x570 kernel: [drm:amdgpu_job_timedout [amdgpu]] *ERROR* Process information: process vlc pid 36686 thread vlc:cs0 pid 36700
Jan 14 15:10:29 x570 kernel: [drm:amdgpu_cs_ioctl [amdgpu]] *ERROR* Failed to initialize parser -125!
Jan 14 15:10:29 x570 kernel: [drm:amdgpu_cs_ioctl [amdgpu]] *ERROR* Failed to initialize parser -125!

Install KDiff3

It does not have the “anti-root”-check buildin like the rest of KDE.

1 Like

The issue I am facing is that Discover is not working. GTK theme has an error that every restart the buttons to minimize, maximize and close get out of shape.

Cyclic dependency detected between “file:///usr/lib/qt/qml/org/kde/kirigami.2/styles/org.kde.desktop.plasma/Units.qml” and “file:///usr/lib/qt/qml/org/kde/kirigami.2/styles/org.kde.desktop.plasma/Units.qml”
corrupted double-linked list
Aborted (core dumped)

First I have to update rebuild-detector with pamac install --no-upgrade rebuild-detector.
Then today the update ran flawlessly with sudo pacman -Syu in TTY.
I use KDE, stable kernels and video-hybrid-intel-nvidia-prime with a GeForce 940MX.

This work around makes my notebook to not show the HDMI audio option

Since the update I have random issues when shuting down: Maybe 1 in 3 times it does not shut down properly and stays at a console. Every time there is a different error message at the last line, so far I had

  • Couldn’t unmount /tmp
  • Kernel Panic
  • mdadm: Cannot get exclusive access to /dev/md127 :Perhaps a running process, mounted filesystem or active volume group?

Is there a way to track down the problem?
Can I check what mdadm is doing?

I tried launching kernel 5.9, but it didn’t boot (just black screen), but I will try again and report back if this issue persists or if the shutdown issue is solved by running the older kernel.

In the meantime: Any advice is highly appreciated (things I should check and stuff)! Thank you very much in advance. :slight_smile:

you can type

sudo systemctl mask lvm2-monitor.service

& @philm

** update **
I waited 2 more weeks and just tried again.
This time it went super smooth, and booted up nice and quick with no errors. Even tested a few Steam games, and loaded Blender and tried out some CUDA features. Even the compositor was activated upon bootup… which I think is new. I’m pretty sure that prior to now, I’ve been needing to activate it with each boot, otherwise wasn’t getting anything close to 144-240Hz, and had tearing.

To recap:
Timeshifted back to normal.
Waited 2 weeks.
Tried update again.

Thank for all the hard work!

Should I expect any issues with that? I don’t think that I actively created a LVM partition, but I think BTRFS uses it per default, so maybe other constellations do it too?

NAME               FSTYPE            FSVER    LABEL                    UUID                                   FSAVAIL FSUSE% MOUNTPOINT
loop0              squashfs          4.0                                                                            0   100% /var/lib/snapd/snap/jdup
loop1              squashfs          4.0                                                                            0   100% /var/lib/snapd/snap/core/10583
loop2              squashfs          4.0                                                                            0   100% /var/lib/snapd/snap/jupyter/6
loop3              squashfs          4.0                                                                            0   100% /var/lib/snapd/snap/core/10577
loop4              squashfs          4.0                                                                            0   100% /var/lib/snapd/snap/core18/1932
loop5              squashfs          4.0                                                                            0   100% /var/lib/snapd/snap/core18/1944                                                                                                         
├─nvme0n1p1        vfat              FAT32                             FB0A-4A6C                               299.1M     0% /boot/efi
├─nvme0n1p2        linux_raid_member 1.2      manjaro-gnome:MyRAIDRoot 93d77c1b-04ce-654c-c39c-7b7333f44351                  
│ └─md127                                                                                                                    
│   └─md127p1      ext4              1.0                               ea81fc07-ed51-4e22-a5e7-7f794de0071a    229.5G    68% /
└─nvme0n1p3        swap              1                                 55bc25d1-e8c9-437a-a61f-3b932523e6ed                  
├─nvme1n1p2        linux_raid_member 1.2      manjaro-gnome:MyRAIDRoot 93d77c1b-04ce-654c-c39c-7b7333f44351                  
│ └─md127                                                                                                                    
│   └─md127p1      ext4              1.0                               ea81fc07-ed51-4e22-a5e7-7f794de0071a    229.5G    68% /
└─nvme1n1p3        swap              1                                 5a9cf68a-3631-4a33-a8a8-b828b4ec472a

then you should stay with ( raid here)

sudo systemctl enable lvm2-monitor.service

and also use only Kernel 5.9 with btrfs

Kernel 5.10.8 should bring a fix. I’m looking forward to it. :slight_smile:

Thanks for the tip, but having followed your advice, I’m still being told nordvpn needs to be updated whenever I use it. This is even after the 19 jan 21 stable update. In pamac, version 3.8.9 of nordvpn-bin has been flagged as out of date (since 12 jan), but AUR has no newer version yet. I’ll just wait it out, I guess.

No issues here with that version on a Stable and Unstable xfce installation. I use it with openvpn in Network Manager as I prefer visual indication when the VPN is on. In my amateur testing, openvpn and nordlynx speeds were about the same here.